Welcome to the North American Subaru Impreza Owners Club Monday August 20, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 01-10-2018, 01:58 PM   #30201
Obviously Tyler
Scooby Specialist
 
Member#: 395955
Join Date: Jul 2014
Chapter/Region: Tri-State
Location: Bucks County, PA
Vehicle:
2016 WRX
2018 Crosstrek

Default

Quote:
Originally Posted by von Wachtstain View Post
You wouldn't know part number ? :P
I do not.
* Registered users of the site do not see these ads.
Obviously Tyler is online now   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-10-2018, 04:46 PM   #30202
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: California
Vehicle:
2013 WRX Limited
SWP

Default

Quote:
Originally Posted by flyboy1100 View Post
so are you tearing into it or having a shop do it?
Honestly, I'm thinking about parting it out of OEM parts, and scraping it. I don't have the time to tear the motor apart, let alone pull the motor out. And if I have a shop tear it down, it'll cost me about $1~1.5k. Then if it's ringland, I may need to rebore the engine cylinder + get new pistons or find a new used engine which is an additional cost... I figure it wouldn't make sense as it may cost an upwards of $4k, more or less, which would be nearly half the cost of the car... So in my mind, parting it out and scraping it would make the most sense, as I could easily make $2k(Wheels, seats, dash parts, etc), which would recoup for the loss of the car, and go towards a new car. It's no where the cost of the car, but I figure, it'll be better than paying possibly an upwards of $4k...

But i'm still debating what i'll do and will need to make up some more time to see what's going on, if I can see anything...

Quote:
Originally Posted by Angelus911 View Post
What year is your Impreza? Is it covered under the extended warranty Subaru offered us oil burners? IIRC it was 5 years 100k miles for the engine
It's a 2012, so it's just a little under a year over the 5 year warranty....
theoutbackdream is offline   Reply With Quote
Old 01-10-2018, 05:34 PM   #30203
DieselDorf
Scooby Newbie
 
Member#: 454773
Join Date: Sep 2016
Chapter/Region: MWSOC
Location: Traverse City, MI
Vehicle:
2012 Impreza Sport
Pearl White

Default

I would call Subaru of America .
The least they could do is a free inspection to see what is wrong then you have a better idea of what to do.

Less than 50k on a car something like this shouldn't happen, I bet they will do something g for you or maybe a discount on the repair.

Even if it is 4K to fix you still could sell it and make 6k that you wouldn't have otherwise.
DieselDorf is offline   Reply With Quote
Old 01-10-2018, 06:26 PM   #30204
flyboy1100
Scooby Guru
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

Warranty was extended to 8yrs/100k
flyboy1100 is offline   Reply With Quote
Old 01-10-2018, 06:26 PM   #30205
Angelus911
Scooby Specialist
 
Member#: 89967
Join Date: Jun 2005
Chapter/Region: NESIC
Location: MA
Vehicle:
2012 Impreza Sport
DGM

Default

Actually, the warranty is 8 years 100k so you should still be covered.

https://jalopnik.com/subaru-settles-...ars-1752805682
Angelus911 is offline   Reply With Quote
Old 01-10-2018, 07:03 PM   #30206
DieselDorf
Scooby Newbie
 
Member#: 454773
Join Date: Sep 2016
Chapter/Region: MWSOC
Location: Traverse City, MI
Vehicle:
2012 Impreza Sport
Pearl White

Default

Isn't that warranty just for oil consumption though? I think this is a case of oil explosion.
DieselDorf is offline   Reply With Quote
Old 01-10-2018, 07:12 PM   #30207
Commander Keen
Scooby Specialist
 
Member#: 319157
Join Date: May 2012
Chapter/Region: MAIC
Vehicle:
2012 Impreza 4DR 5MT

Default

And if not, you'll at least get a free autopsy.
Commander Keen is offline   Reply With Quote
Old 01-10-2018, 07:24 PM   #30208
Angelus911
Scooby Specialist
 
Member#: 89967
Join Date: Jun 2005
Chapter/Region: NESIC
Location: MA
Vehicle:
2012 Impreza Sport
DGM

Default

Well, he consumed a lot of oil at once.

I'm sure given the warranty and the PR around the issue, they'd want to make it right. It's one thing if someone was negligent and seized their engine, this seems just like a random catastrophic failure.
Angelus911 is offline   Reply With Quote
Old 01-11-2018, 02:38 AM   #30209
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: California
Vehicle:
2013 WRX Limited
SWP

Default

Quote:
Originally Posted by DieselDorf View Post
I would call Subaru of America .
The least they could do is a free inspection to see what is wrong then you have a better idea of what to do.

Less than 50k on a car something like this shouldn't happen, I bet they will do something g for you or maybe a discount on the repair.

Even if it is 4K to fix you still could sell it and make 6k that you wouldn't have otherwise.
Yea, i'm planning to call SOA ASAP. Just been so busy that I haven't had time to deal with it.

I hope they can do something, but if they can't, oh well..

True, but that's also $4k that could go towards a new car. And then I wouldn't really have to deal with paying for other things, like a rental.

Quote:
Originally Posted by flyboy1100 View Post
Warranty was extended to 8yrs/100k
Quote:
Originally Posted by Angelus911 View Post
Actually, the warranty is 8 years 100k so you should still be covered.

https://jalopnik.com/subaru-settles-...ars-1752805682
Maybe I can use this against SOA.. haha

Quote:
Originally Posted by DieselDorf View Post
Isn't that warranty just for oil consumption though? I think this is a case of oil explosion.
LOL

I don't know if it's oil explosion. It could just be a case of serious oil consumption, that happened out of no where. Or something else went fatally wrong.

Quote:
Originally Posted by Commander Keen View Post
And if not, you'll at least get a free autopsy.
Hope so.

Quote:
Originally Posted by Angelus911 View Post
Well, he consumed a lot of oil at once.

I'm sure given the warranty and the PR around the issue, they'd want to make it right. It's one thing if someone was negligent and seized their engine, this seems just like a random catastrophic failure.
Yea.. haha

Knowing subaru, I'm sure they will do something right. I just need to make up the time to figure out what I can do, and what SOA can do. Yea definitely. I took care of this care like no other and haven't let anyone else work on the car, so I know what's been done to it.....

Or maybe.. Just maybe.. I dropped my 10mm socket into the oil filler cap, and that's where it's been hiding. Just Kidding.

Anyways...

I'll keep you guys posted. Hopefully during the weekend, i'll have enough time to get started on this..
theoutbackdream is offline   Reply With Quote
Old 01-12-2018, 07:20 PM   #30210
DieselDorf
Scooby Newbie
 
Member#: 454773
Join Date: Sep 2016
Chapter/Region: MWSOC
Location: Traverse City, MI
Vehicle:
2012 Impreza Sport
Pearl White

Default

Probably no one has heard of this but just in case.

After going down a big hill (one I drive down everyday) I heard this kind of nails on chalkboard scratch noise for just a few seconds followed by a noise that sounded like a spring rebounding with a thud.

Not super loud I had to turn the music down to tell, I'm pretty sure it was my car but not 100% sure.

I had the car in manual mode since it was icy out and I didn't want it to downshift on me, and it made the noise a little after I switched back into auto. Probably not related but the more info the better.
DieselDorf is offline   Reply With Quote
Old 01-13-2018, 02:09 PM   #30211
DieselDorf
Scooby Newbie
 
Member#: 454773
Join Date: Sep 2016
Chapter/Region: MWSOC
Location: Traverse City, MI
Vehicle:
2012 Impreza Sport
Pearl White

Default

A little salty. Went from 50 and pouring rain to about 15 and snowy over night. At least the roads were drivable!







DieselDorf is offline   Reply With Quote
Old 01-16-2018, 12:13 PM   #30212
nubsub
Scooby Specialist
 
Member#: 313575
Join Date: Mar 2012
Location: SF Bay Area, CA
Vehicle:
2012 Impreza 2.0i HB

Default

haven't been on NASIOC in a while, but man... i'm so sorry to hear about this. what an amazingly unfortunate event. i hope SOA can do something for you and you can figure out what happened. but i completely understand -- at this stage in my life, i don't have much time to play detective and sometimes the most efficient route is the only route to take due to practicality.

aside: i'm still awestruck of my 1-2mpg uptick in MPGs since following your Amsoil CVT experience and my own fluid change. the trend continues and i have enough fill-ups to know that it is statistically significant.

best of luck with your car and do keep us posted if you can. i'm sure the rest of us would like to know if we are driving ticking time bombs

Quote:
Originally Posted by theoutbackdream View Post
Yea, i'm planning to call SOA ASAP. Just been so busy that I haven't had time to deal with it.

I hope they can do something, but if they can't, oh well..

True, but that's also $4k that could go towards a new car. And then I wouldn't really have to deal with paying for other things, like a rental.




Maybe I can use this against SOA.. haha


LOL

I don't know if it's oil explosion. It could just be a case of serious oil consumption, that happened out of no where. Or something else went fatally wrong.


Hope so.



Yea.. haha

Knowing subaru, I'm sure they will do something right. I just need to make up the time to figure out what I can do, and what SOA can do. Yea definitely. I took care of this care like no other and haven't let anyone else work on the car, so I know what's been done to it.....

Or maybe.. Just maybe.. I dropped my 10mm socket into the oil filler cap, and that's where it's been hiding. Just Kidding.

Anyways...

I'll keep you guys posted. Hopefully during the weekend, i'll have enough time to get started on this..
nubsub is offline   Reply With Quote
Old 01-16-2018, 01:56 PM   #30213
DieselDorf
Scooby Newbie
 
Member#: 454773
Join Date: Sep 2016
Chapter/Region: MWSOC
Location: Traverse City, MI
Vehicle:
2012 Impreza Sport
Pearl White

Default

Here's those salty pics that wouldn't load earlier.







DieselDorf is offline   Reply With Quote
Old 01-16-2018, 02:00 PM   #30214
Obviously Tyler
Scooby Specialist
 
Member#: 395955
Join Date: Jul 2014
Chapter/Region: Tri-State
Location: Bucks County, PA
Vehicle:
2016 WRX
2018 Crosstrek

Default

Quote:
Originally Posted by nubsub View Post
i'm sure the rest of us would like to know if we are driving ticking time bombs
You aren't. Relax.
Obviously Tyler is online now   Reply With Quote
Old 01-17-2018, 01:34 AM   #30215
Pelco
Scooby Newbie
 
Member#: 435599
Join Date: Dec 2015
Location: Los Angeles, CA
Vehicle:
2016 Impreza Sport
White

Default

Quote:
Originally Posted by DieselDorf View Post
Here's those salty pics that wouldn't load earlier.







Damn salty. All these flavours and you choose to be...
Pelco is offline   Reply With Quote
Old 01-24-2018, 08:27 AM   #30216
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default oil pressure light on with proper oil level

Hi all,

2012 Impreza with 78k miles on the odometer. This car has never consumed oil, and it's still not consuming oil.

Anyway, on my way into work this morning, my oil pressure (not oil level) light turned on. The car was running fine; no unusual sounds or behavior other than the light itself. This seemed very strange; I had checked the oil level less than a month ago, and it was perfect. So I couldn't imagine that the oil level had fallen that much in such a short time.

After letting the car sit in my office parking lot for an hour, I checked the oil level, which is full.

Has anyone else experienced this? I'm thinking it's probably a bad oil pressure sensor, since the car seems to be running perfectly, and the oil level is good.

Thoughts? Can I drive it to the dealer for a check-up, or should I have it towed?

Last edited by sgoldste01; 01-24-2018 at 09:22 AM.
sgoldste01 is offline   Reply With Quote
Old 01-24-2018, 08:37 AM   #30217
Angelus911
Scooby Specialist
 
Member#: 89967
Join Date: Jun 2005
Chapter/Region: NESIC
Location: MA
Vehicle:
2012 Impreza Sport
DGM

Default

I've never had that happen before - closest thing for me was the low oil light after only 1400 miles on a roadtrip.

Very odd, I would think it would be a bad oil sensor as well if the oil level is still full.

How far away is your Subaru dealer? If it's not too far away I would think it would be OK to drive. You could always call them I guess and see what they recommend as well.
Angelus911 is offline   Reply With Quote
Old 01-24-2018, 08:40 AM   #30218
Obviously Tyler
Scooby Specialist
 
Member#: 395955
Join Date: Jul 2014
Chapter/Region: Tri-State
Location: Bucks County, PA
Vehicle:
2016 WRX
2018 Crosstrek

Default

Sounds like an oil pressure sensor issue.
Obviously Tyler is online now   Reply With Quote
Old 01-24-2018, 09:21 AM   #30219
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

Quote:
Originally Posted by Angelus911 View Post
I've never had that happen before - closest thing for me was the low oil light after only 1400 miles on a roadtrip.

Very odd, I would think it would be a bad oil sensor as well if the oil level is still full.

How far away is your Subaru dealer? If it's not too far away I would think it would be OK to drive. You could always call them I guess and see what they recommend as well.
Just went out and started the car. Oil Pressure Light is out. I think I'll take it for a short drive during my lunch hour and see if I can get the light to come back on again.
sgoldste01 is offline   Reply With Quote
Old 01-24-2018, 10:01 AM   #30220
Angelus911
Scooby Specialist
 
Member#: 89967
Join Date: Jun 2005
Chapter/Region: NESIC
Location: MA
Vehicle:
2012 Impreza Sport
DGM

Default

Good luck, hopefully nothing major and just the sensor like you said.

I still need to take my car back into the dealer before I reach 100k, I have a small oil leak somewhere in the engine after my shortblock replacement, and it leaves a pretty bad burning oil smell after every drive. Also have some residue around the oil pan/drain plug as well.
Angelus911 is offline   Reply With Quote
Old 01-24-2018, 12:36 PM   #30221
sgoldste01
Scooby Specialist
 
Member#: 322264
Join Date: Jun 2012
Chapter/Region: Tri-State
Location: Webster, NY
Vehicle:
2012 Impreza Sp 5sp
Obs Blk Prl/Drk Gray Mtl

Default

Quote:
Originally Posted by Angelus911 View Post
Good luck, hopefully nothing major and just the sensor like you said.

I still need to take my car back into the dealer before I reach 100k, I have a small oil leak somewhere in the engine after my shortblock replacement, and it leaves a pretty bad burning oil smell after every drive. Also have some residue around the oil pan/drain plug as well.
Just went for a 15-minute test drive (including some steep hill climbs and descents), and couldn't get the Oil Pressure Light to come on again. For now, I'm going to assume it was a false alarm, and will monitor the light closely for awhile.

sgoldste01 is offline   Reply With Quote
Old 01-24-2018, 12:47 PM   #30222
flyboy1100
Scooby Guru
 
Member#: 314216
Join Date: Mar 2012
Location: ND
Vehicle:
2012 2.0i Sport 5MT
DGM

Default

maybe there was a piece of fuzz or gunk that momentarily messed up the sensor, it happens on my motorcycle....
flyboy1100 is offline   Reply With Quote
Old 01-24-2018, 01:48 PM   #30223
CLL_OBP
Scooby Specialist
 
Member#: 310435
Join Date: Feb 2012
Location: Fayetteville, NC
Vehicle:
'12 Sport Limited
Mobil 1 0W20 154,001 mi

Default

A sgoldste01 sighting! Haven't seen you post in a minute. Hope all is well.

Never had the oil pressure light come on but the low oil light comes on at the full mark for me. If your pressure switch is bad, at least it's cheap and easy to change, $16.38 on subarupartswarehouse.
The oil level switch on the other hand cost four times more and is a P.I.T.A to replace.

theoutbackdream, sorry to hear about your engine. I'm curious to know what caused this with only 45K miles. I'll be at 140K tomorrow.
CLL_OBP is offline   Reply With Quote
Old 01-24-2018, 04:45 PM   #30224
theoutbackdream
Scooby Specialist
 
Member#: 301179
Join Date: Nov 2011
Chapter/Region: BAIC
Location: California
Vehicle:
2013 WRX Limited
SWP

Default

Quote:
Originally Posted by nubsub View Post
haven't been on NASIOC in a while, but man... i'm so sorry to hear about this. what an amazingly unfortunate event. i hope SOA can do something for you and you can figure out what happened. but i completely understand -- at this stage in my life, i don't have much time to play detective and sometimes the most efficient route is the only route to take due to practicality.

aside: i'm still awestruck of my 1-2mpg uptick in MPGs since following your Amsoil CVT experience and my own fluid change. the trend continues and i have enough fill-ups to know that it is statistically significant.

best of luck with your car and do keep us posted if you can. i'm sure the rest of us would like to know if we are driving ticking time bombs
No worries... ***** happens.

I'm still waiting on the word from SOA to see what they can do. The wait is killing me.. .

Yea.. it sucks, but life happens. haha got to make it work some how.

Yea, I had the same experience, as I mentioned in our PM's... I don't know why.. but hey, I'm happy that I got 1-2mpg more. lol

I'll keep you guys posted. And don't worry, you aren't driving a ticking time bomb. Relax...

Quote:
Originally Posted by Angelus911 View Post
I've never had that happen before - closest thing for me was the low oil light after only 1400 miles on a roadtrip.

Very odd, I would think it would be a bad oil sensor as well if the oil level is still full.

How far away is your Subaru dealer? If it's not too far away I would think it would be OK to drive. You could always call them I guess and see what they recommend as well.
The oil level low on the dipstick after the event ensued. So i'm sure the oil pressure light didn't fail. I did top off the oil about a week prior to the incident. My local dealer is about 20min, but I'm not going to risk it. I'm just waiting for SOA's input on what they can do to help out.

Quote:
Originally Posted by Obviously Tyler View Post
Sounds like an oil pressure sensor issue.
If it was, I wouldn't have had a huge puff of white smoke. Lol

Quote:
Originally Posted by Angelus911 View Post
I still need to take my car back into the dealer before I reach 100k, I have a small oil leak somewhere in the engine after my shortblock replacement, and it leaves a pretty bad burning oil smell after every drive. Also have some residue around the oil pan/drain plug as well.
Shortblock replacement... Did you get a free block after passing the oil consumption test? or was this something else?
theoutbackdream is offline   Reply With Quote
Old 01-24-2018, 04:49 PM   #30225
Obviously Tyler
Scooby Specialist
 
Member#: 395955
Join Date: Jul 2014
Chapter/Region: Tri-State
Location: Bucks County, PA
Vehicle:
2016 WRX
2018 Crosstrek

Default

Quote:
Originally Posted by theoutbackdream View Post
If it was, I wouldn't have had a huge puff of white smoke. Lol
That was intended for sgoldste01. I should have quoted. Sorry.
Obviously Tyler is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2012 Impreza STI concept art khaki_man Member's Car Gallery 37 03-15-2011 02:02 AM
Newsflash: 2012 Impreza looks like BigElm's Butt WagonMonster Off-Topic 4 02-28-2011 07:11 PM
2012 Impreza Concept Zakster87 General Community 14 11-17-2010 04:09 PM
Possibly looking into a 2011 or 2012 Impreza? xenonk Mid Atlantic Impreza Club -- MAIC 1 08-05-2010 09:48 PM

All times are GMT -4. The time now is 10:57 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.