Welcome to the North American Subaru Impreza Owners Club Saturday August 18, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 05-07-2003, 01:14 AM   #1
AndreWRX
Scooby Newbie
 
Member#: 35802
Join Date: Apr 2003
Location: Pine Brook
Vehicle:
2005 Pontiac GTO
Yellow Jacket Yellow

Default running too rich

02 WRX, 3" turbo back high flow cat, APS large top mount, Aem intake, samco tubing into VF30 turbo, STi injectors, walbro 255 l/ph fuel pump, w/ Unichip and Pruven catless upipe. Car is sitting at Pruven Performance, at idle car is demanding tons of fuel as though my foot was in it. Things checked and/or replaced thus far, fuel pressure regulator, unichip, ECU, EGT probe, compression test excellent, pressure test fine. They are checking the MAP sensor and getting back to me and have been excellent to me. Any suggestions are welcome to helping to solve this problem?
* Registered users of the site do not see these ads.
AndreWRX is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 05-07-2003, 01:44 AM   #2
Matty
Scooby Specialist
 
Member#: 13408
Join Date: Dec 2001
Location: Hood River ..Oregon
Vehicle:
2008 LGT
black

Default I've been reading

The MRT performance forums for awhile now...many guys over in Australia are running VF30's,28's23's.. at fairly high boost with only a fuel pump upgrade...and using the 440cc injectors and good engine management, they've been at this longer than we have...so maybe there is something to this..They seem to be going to bigger injectors with the Vf22 at high boost...like 18-20 and even more psi
Matty is offline   Reply With Quote
Old 05-07-2003, 12:53 PM   #3
AndreWRX
Scooby Newbie
 
Member#: 35802
Join Date: Apr 2003
Location: Pine Brook
Vehicle:
2005 Pontiac GTO
Yellow Jacket Yellow

Default

don't think that's the issue, the guys at Pruven tune the car and set the fuel amount via Unichip, the car seems to be panicking and thinking its running ultra lean, maybe a bad 02 sensor? Someone help, my car has been there for over a week, I miss it!
AndreWRX is offline   Reply With Quote
Old 05-07-2003, 01:20 PM   #4
nizz
Scooby Specialist
 
Member#: 188
Join Date: Aug 1999
Location: New York
Vehicle:
2004 Forester XT
24k gold on white

Default

Try taking out the Unichip and then start the car and see if it still idles rich. If it idles fine after you remove the Unichip, then it is more than likely that the fuel map on the Unichip is bad.

nizz
nizz is offline   Reply With Quote
Old 05-07-2003, 02:06 PM   #5
AndreWRX
Scooby Newbie
 
Member#: 35802
Join Date: Apr 2003
Location: Pine Brook
Vehicle:
2005 Pontiac GTO
Yellow Jacket Yellow

Default

Thanks guys, I appreciate all replies. If you read my post, I have listed everything they have already tried such as removing the unichip and letting the car run with stock ecu, replacing Unichip, egt probe, MAF, etc. I wish it were something that simple.
AndreWRX is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Running too rich, what to do (UTEC) EJ205rulezall Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 15 04-24-2004 03:00 PM
running too rich! Haase14 Mid West Subaru Owners Club Forum -- MWSOC 3 04-22-2003 01:37 PM
running too rich romoranger Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 7 03-01-2003 01:35 PM
Running too rich...will intake help? KillerRex Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 4 12-10-2002 06:57 AM
Can running too rich for too long throw a CEL? Bighurt1 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 7 03-26-2002 04:57 PM

All times are GMT -4. The time now is 02:19 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.