Welcome to the North American Subaru Impreza Owners Club Tuesday May 11, 2021
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Baja Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 01-30-2006, 09:16 AM   #1
ez bturbo
Scooby Newbie
 
Member#: 56048
Join Date: Feb 2004
Location: Aiken, SC
Vehicle:
2004 baja turbo 5spd
black/dark gray

Default Baja T hesitating & other problems

If I get on my 04 baja Turbo 5-speed at about 2500rpm or lower, it bucks a lot, hesitates, and then finally decides to go. It was never great below 2500rpm when you got on it, but its worse now. Any ideas? Im at 38k miles now, powertrain has more than 3/36 on these doesnt it? I havent had a chance to check that out.

Bigger concern -- if I drive the car more than about 20 minutes, I noticed it seems much less responsive. I started looked at the boost gauge, and noticed that it stops making full boost, it will go up to about .3MPa, maybe .4mpa, maximum in any gear, in other words making only 5-6 pounds of boost. If I stop the car and restart, it fixes this problem for another 20 minutes. Whats going on? I am going to have to take it in, but Im trying to see if anyone has seen something like this previously.
* Registered users of the site do not see these ads.
ez bturbo is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-30-2006, 11:44 AM   #2
memphisjames
Scooby Newbie
 
Member#: 41835
Join Date: Aug 2003
Chapter/Region: South East
Location: Elvisland
Vehicle:
2006 Bitchin' Baja-T
Black on Black!

Default Could be this...

memphisjames is offline   Reply With Quote
Old 02-06-2006, 07:34 PM   #3
masubi
Scooby Newbie
 
Member#: 94769
Join Date: Aug 2005
Location: The OC
Vehicle:
2005 Baja
Black

Default

Quote:
Originally Posted by ez bturbo
If I get on my 04 baja Turbo 5-speed at about 2500rpm or lower, it bucks a lot, hesitates, and then finally decides to go. It was never great below 2500rpm when you got on it, but its worse now. Any ideas? Im at 38k miles now, powertrain has more than 3/36 on these doesnt it? I havent had a chance to check that out.

Bigger concern -- if I drive the car more than about 20 minutes, I noticed it seems much less responsive. I started looked at the boost gauge, and noticed that it stops making full boost, it will go up to about .3MPa, maybe .4mpa, maximum in any gear, in other words making only 5-6 pounds of boost. If I stop the car and restart, it fixes this problem for another 20 minutes. Whats going on? I am going to have to take it in, but Im trying to see if anyone has seen something like this previously.
I have an 05 and the first problem is just like mine. I have taken it to the dealer twice so far and they just reset the computer. I am taking it in next week for the third time to see what they are going to do. I don't have a boost gauge, so I am not sure about the second.
masubi is offline   Reply With Quote
Old 02-06-2006, 07:41 PM   #4
ez bturbo
Scooby Newbie
 
Member#: 56048
Join Date: Feb 2004
Location: Aiken, SC
Vehicle:
2004 baja turbo 5spd
black/dark gray

Default

show them the service bulletin on that link, tell them you have rough idle. Mine started shuddering pretty good at idle, but I have no tools or time where I am at right now so I am just not driving it anymore.
ez bturbo is offline   Reply With Quote
Old 02-15-2006, 02:15 PM   #5
ez bturbo
Scooby Newbie
 
Member#: 56048
Join Date: Feb 2004
Location: Aiken, SC
Vehicle:
2004 baja turbo 5spd
black/dark gray

Default

I just want to say that I did the union screw screen removal from the link above, and that fixed the problems. I think it responsiveness is the best its ever been, even when I got it new. It no longer hesitates when I get on it in low rpm, and pulls smooth and strong.
ez bturbo is offline   Reply With Quote
Old 02-15-2006, 06:16 PM   #6
memphisjames
Scooby Newbie
 
Member#: 41835
Join Date: Aug 2003
Chapter/Region: South East
Location: Elvisland
Vehicle:
2006 Bitchin' Baja-T
Black on Black!

Default

Thanks for the update.
memphisjames is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hesitation & Boost problems turboryan Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 8 12-05-2008 11:06 AM
Need help on low RPM hesitation/High EGT problem kracka99 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 13 08-28-2005 09:31 PM
Hardcore Bogging & Other Problems Soon2BturbodRS Service & Maintenance 7 06-13-2005 11:59 PM
Problem w/ Kumho MX's out of round & other questions BIGSKYWRX Tire & Wheel 4 03-02-2005 08:33 PM
Baja Bed Cover, and other newby questions TurBaja Baja Forum 8 04-08-2004 08:54 AM

All times are GMT -4. The time now is 08:46 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.