Welcome to the North American Subaru Impreza Owners Club Wednesday November 29, 2023
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 10-08-2006, 03:28 PM   #1
ImpreziveWRX
Scooby Specialist
 
Member#: 17643
Join Date: Apr 2002
Chapter/Region: SCIC
Location: SoCal 714
Vehicle:
2002 WRX Wagon
PSM

Default Gas smell that is not related to cold weather

I am having gas smell problem for a long time...
It gets to a point that I stopped at a red light and I can smell it really bad

Most thread point to cold weather and the 02 WRX leaking problem but this one is not

It is not from my engine bay, I added RTV sealant to make sure no leak from my down pipe and cat back section... but the smell is still there...

Yesterday I have my car jacked up and I noticed the section with heaviest odor is my rear passenger side wheel...

I didn't overfill, didnít spill any gas when I filling it up... I just have no idea what happens.

Anything that I need to check into?
Let me know

Thanks in advance
* Registered users of the site do not see these ads.
ImpreziveWRX is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-08-2006, 05:03 PM   #2
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 RAV4 MT
15 WRX/11 CRZ

Default

Have you changed the fuel pump or removed it for any reason? The gasket under the cover where the pump goes into the tank may be damaged and this will cause a fuel smell in the car, if the leak is bad enough you may also get an evaporative system CEL.
Mulder is offline   Reply With Quote
Old 10-08-2006, 07:07 PM   #3
ImpreziveWRX
Scooby Specialist
 
Member#: 17643
Join Date: Apr 2002
Chapter/Region: SCIC
Location: SoCal 714
Vehicle:
2002 WRX Wagon
PSM

Default

Yes, I got the loose gas cap CEL before but it was gone after my "fuel filter" was replaced...

I have replaced my fuel pump before due to a turbo upgrade
What can I do myself to check for the damaged gasket?

I am not skilled expert but I do some work myself
ImpreziveWRX is offline   Reply With Quote
Old 10-08-2006, 09:41 PM   #4
ImpreziveWRX
Scooby Specialist
 
Member#: 17643
Join Date: Apr 2002
Chapter/Region: SCIC
Location: SoCal 714
Vehicle:
2002 WRX Wagon
PSM

Default

Quote:
Originally Posted by Mulder View Post
Have you changed the fuel pump or removed it for any reason? The gasket under the cover where the pump goes into the tank may be damaged and this will cause a fuel smell in the car, if the leak is bad enough you may also get an evaporative system CEL.
Is this the part I need?
I need to get it fixed ASAP...


Thanks in advance
ImpreziveWRX is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Gas Leak-Not due to cold weather. ChronicWRX Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 13 12-02-2009 09:37 PM
Cold weather ticking --not related to engine speed nardvark Service & Maintenance 11 02-12-2009 09:40 PM
is boosted84wagonmonster capable of making a thread NOT related to food? boosted84wagonmonster Off-Topic 19 06-24-2007 09:48 PM
My STI Does NOT like the cold weather!!!! Mikemar Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 19 11-12-2004 05:28 PM
head lights not coming in cold weather reaubideux Electrical & Lighting 1 11-27-2003 10:28 PM

All times are GMT -4. The time now is 06:17 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2023 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.

When you click on links to various merchants on this site and make a purchase, this can result in this site earning a commission
Affiliate programs and affiliations include, but are not limited to, the eBay Partner Network.