Welcome to the North American Subaru Impreza Owners Club Monday January 21, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Tribeca Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 11-05-2018, 10:19 AM   #1
Unclebilly
Scooby Newbie
 
Member#: 489793
Join Date: Aug 2018
Vehicle:
2018 WRX

Default Tribeca Project

I have had my new WRX just over 2 months and bought a Tribeca to replace my wifeís aging Lexus LX450...

The Tribeca has a weird shifting issue which seems to be common. The problem came about after the serpentine belt broke so it was driven with low voltage.

Iím thinking the issue is likely the TCU needing a reflash but it could be the valve body or the torque converter. It has 112000 miles on it and no hitch so I doubt it is worn out.

From sitting a year, the brakes are rusty and there are some minor power steering leaks.

My plan is to replace the brakes and the power steering rack and then take it to get the transmission diagnosed.
* Registered users of the site do not see these ads.
Unclebilly is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-25-2018, 12:32 AM   #2
Unclebilly
Scooby Newbie
 
Member#: 489793
Join Date: Aug 2018
Vehicle:
2018 WRX

Default

So I followed my plan above. The tranny diagnosis came back perfect. The fluid analysis came back good and the tranny shop didn’t even reccomend changing fluid.

The dealer did the reflash and updated the software to deal with the 2-3 and 3-2 shift and it drives beautifully. My wife loves it.
Unclebilly is offline   Reply With Quote
Old 11-26-2018, 04:43 PM   #3
Sub!eDr!ver
Scooby Newbie
 
Member#: 88924
Join Date: Jun 2005
Location: Atlanta, GA, USA
Vehicle:
2014 Cadenza, Sedona
Past: Tribeca LGTx2 Justy

Default

Glad to hear it. My '07 was a great car, for 150,000+ miles, then my wife crashed it. I almost bought another Tribeca, but ended up in a Kia Sedona instead.
Sub!eDr!ver is offline   Reply With Quote
Old 12-21-2018, 12:18 AM   #4
Unclebilly
Scooby Newbie
 
Member#: 489793
Join Date: Aug 2018
Vehicle:
2018 WRX

Default

After just short of a month, it looks like the torque converter is suspect. It worked perfectly until Tuesday when the torque converter wouldn’t unlock and the vehicle stalled and would stall everytime it was put into drive.

It decided to cooperate when I got there and I drove it home.

On the way to the dealer yesterday, it threw a P0741 code - torque converter control solenoid. The dealer confirmed today that the problem was the torque converter... I guess i’m doing a TC over Christmas...
Unclebilly is offline   Reply With Quote
Old 01-19-2019, 10:35 AM   #5
Unclebilly
Scooby Newbie
 
Member#: 489793
Join Date: Aug 2018
Vehicle:
2018 WRX

Default

So I bought the 143 torque converter which is the updated one. I got a new one from Subaru off of eBay. I also was able to find a torque converter control solenoid for it (for the Nissan trans). It was $60 and I will keep it as a spare.

While I had the exhaust off, I decided to take advantage of the ‘improved’ access and do the spark plugs. The rear drivers side plug required the expertise of my 8 year old son and his small hands to do.

Unfortunately I broke the electrical connector on the drivers exhaust vvt actuator while prying the engine over to get that last coil back in... a new one is on its way and then I can button this thing up, hopefully for good. It has spent more time on my hoist since we’ve owned it than it had on the ground... mostly waiting for parts.
Unclebilly is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 04:22 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.