Welcome to the North American Subaru Impreza Owners Club Monday July 16, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 12-15-2008, 05:48 PM   #1
fl4tsc
Scooby Specialist
 
Member#: 177247
Join Date: Apr 2008
Chapter/Region: South East
Location: Greenville, SC
Vehicle:
2005 WRX 16G-XT+EWG
1980 Porsche 911SC 3.6L

Default can't get door cards back on

well i took the door cards off to do an interior swap that didn't end up happening and i can't seem to get the 2 front ones back on. specifically the clip that is right below the speaker. i can get every other clip to go on fine but for some reason that last clip just doesn't want to go back in. it feels like the rubber surround is in the way but i've been messing with it for half an hour and haven't made any headway. am i doing something wrong? thanks.
* Registered users of the site do not see these ads.
fl4tsc is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-15-2008, 06:40 PM   #2
fl4tsc
Scooby Specialist
 
Member#: 177247
Join Date: Apr 2008
Chapter/Region: South East
Location: Greenville, SC
Vehicle:
2005 WRX 16G-XT+EWG
1980 Porsche 911SC 3.6L

Default

anybody?
fl4tsc is offline   Reply With Quote
Old 12-15-2008, 06:56 PM   #3
SueBaroo
Scooby Specialist
 
Member#: 140838
Join Date: Feb 2007
Chapter/Region: SCIC
Location: Rancho Cucamonga, CA
Vehicle:
2002 WRX Wagon
03WRX/06STi/07FOZ/08LEG

Default

Did you actually get on your back with a flash light and see if it's lined up?

For some reason that sounded sexual..
SueBaroo is offline   Reply With Quote
Old 12-15-2008, 07:02 PM   #4
fl4tsc
Scooby Specialist
 
Member#: 177247
Join Date: Apr 2008
Chapter/Region: South East
Location: Greenville, SC
Vehicle:
2005 WRX 16G-XT+EWG
1980 Porsche 911SC 3.6L

Default

yeah that's what i don't get... it looks fine and all the other clips go in easy but the last one just doesn't want to work.???
fl4tsc is offline   Reply With Quote
Old 12-15-2008, 07:48 PM   #5
Audiosavvy
Scooby Guru
 
Member#: 150794
Join Date: Jun 2007
Chapter/Region: SCIC
Location: Bakersfield, CA
Vehicle:
Qcab dakota 4x4
LT1 Formula Firebird

Default

You need to stop trying before you ruin your speakers. It's not going in for a reason, and if the delicate surround/cone of the speaker is holding you up, it won't last long.

First, this should be in the Car Audio section. So I'll move it and we'll go from there

What speakers are they and what spacers did you use?
Also, did you trim the vertical lip on the backside of the door panel? It sticks out almost 1/4" and has a sharp bottom lip which can easily tear the speaker's surround.
I suggest removing the speaker and see if the door panel goes on. If so, you know for sure that some modification will be needed.
Audiosavvy is offline   Reply With Quote
Old 12-15-2008, 07:55 PM   #6
fl4tsc
Scooby Specialist
 
Member#: 177247
Join Date: Apr 2008
Chapter/Region: South East
Location: Greenville, SC
Vehicle:
2005 WRX 16G-XT+EWG
1980 Porsche 911SC 3.6L

Default

i think they are the stock speakers... i don't know for sure cuz i bought the car used but they sound like crap so i assume they are.
fl4tsc is offline   Reply With Quote
Old 12-15-2008, 08:03 PM   #7
Audiosavvy
Scooby Guru
 
Member#: 150794
Join Date: Jun 2007
Chapter/Region: SCIC
Location: Bakersfield, CA
Vehicle:
Qcab dakota 4x4
LT1 Formula Firebird

Default

Do they look boring and have a textile surround with paper crap cone?
Audiosavvy is offline   Reply With Quote
Old 12-15-2008, 09:10 PM   #8
fl4tsc
Scooby Specialist
 
Member#: 177247
Join Date: Apr 2008
Chapter/Region: South East
Location: Greenville, SC
Vehicle:
2005 WRX 16G-XT+EWG
1980 Porsche 911SC 3.6L

Default

this is what they look like...



from looking at it closer everything lines up but something is hitting. probably the speaker which won't allow the card to get close enough to the door to clip together.

wonder how they got them on last time?
fl4tsc is offline   Reply With Quote
Old 12-15-2008, 09:13 PM   #9
Daishi00
Scooby Guru
 
Member#: 78952
Join Date: Jan 2005
Chapter/Region: MAIC
Location: BSG junkie
Vehicle:
2005 WRX
CGM

Default

Is the bottom of the speaker actually below the rubber gasket? if it is I'll put money that's where your door card is hitting.
Daishi00 is offline   Reply With Quote
Old 12-15-2008, 09:14 PM   #10
Audiosavvy
Scooby Guru
 
Member#: 150794
Join Date: Jun 2007
Chapter/Region: SCIC
Location: Bakersfield, CA
Vehicle:
Qcab dakota 4x4
LT1 Formula Firebird

Default

That is a Kicker DS60, not a stock speaker, and I can all but guarantee that it's the problem right now.
Audiosavvy is offline   Reply With Quote
Old 12-15-2008, 09:21 PM   #11
fl4tsc
Scooby Specialist
 
Member#: 177247
Join Date: Apr 2008
Chapter/Region: South East
Location: Greenville, SC
Vehicle:
2005 WRX 16G-XT+EWG
1980 Porsche 911SC 3.6L

Default

so any recommendations on how to make it work?
fl4tsc is offline   Reply With Quote
Old 12-15-2008, 09:46 PM   #12
qualityracer
Scooby Newbie
 
Member#: 176016
Join Date: Mar 2008
Location: boston ma
Vehicle:
2002 2.5rs impreza
dark blue

Default

if you are putting back your OEM card back in, make sure that your window is rolled down, and making sure that there are no clips blocking the clip holes.
qualityracer is offline   Reply With Quote
Old 12-16-2008, 02:12 AM   #13
Audiosavvy
Scooby Guru
 
Member#: 150794
Join Date: Jun 2007
Chapter/Region: SCIC
Location: Bakersfield, CA
Vehicle:
Qcab dakota 4x4
LT1 Formula Firebird

Default

Quote:
Originally Posted by qualityracer View Post
...making sure that there are no clips blocking the clip holes.

That's a good point. If a clip pulled out of the door panel and stuck in the door on removal and by chance you moved some around, there may simply be a clip there, not allowing it to snap in. I've seen it happen, especially on Chevy's which NEVER go back together the same way they came apart.
Audiosavvy is offline   Reply With Quote
Old 12-16-2008, 07:19 AM   #14
boostdog
Scooby Specialist
 
Member#: 149752
Join Date: May 2007
Location: NW Arkansas
Vehicle:
2017 wrx
ICE ICE BABY SILVER!

Default

^^ that's for d*mn sure. when i used to sell/install anyone with a chevy/gmc pickup owner had to sign a waiver stating that the broken panel on the C pillar was not our fault. it always breaks when taking it apart. same goes with the s10 and sonoma you have to be very careful when taking the huge 1 piece radio surround that goes pretty much the entire length of the dash. it would get caught on the hazard button and crack it.
boostdog is offline   Reply With Quote
Old 12-16-2008, 09:21 AM   #15
fl4tsc
Scooby Specialist
 
Member#: 177247
Join Date: Apr 2008
Chapter/Region: South East
Location: Greenville, SC
Vehicle:
2005 WRX 16G-XT+EWG
1980 Porsche 911SC 3.6L

Default

no all the clips are where they should be. i checked after some got stuck in the back doors. i tried trimming off some plastic on the inside of the card which seems to have helped a little but it still won't hook up. how the hell did they get them on last time?!?
fl4tsc is offline   Reply With Quote
Old 12-16-2008, 09:55 AM   #16
boostdog
Scooby Specialist
 
Member#: 149752
Join Date: May 2007
Location: NW Arkansas
Vehicle:
2017 wrx
ICE ICE BABY SILVER!

Default

does your orig door card go back on? if so i would turn both over and compare. make the new one like the old is what i would
boostdog is offline   Reply With Quote
Old 12-16-2008, 10:39 AM   #17
ThreeEleven
Scooby Specialist
 
Member#: 157894
Join Date: Aug 2007
Chapter/Region: MWSOC
Location: Saint Peters, MO
Vehicle:
2007 WRB WRX
EJ257

Default

He didn't do the interior swap, so he's trying to put the original door card back on. He didn't swap speakers recently so the door card was on with the same speakers that're there now. Sounds like some people think he took the door card off to swap speakers or something?
ThreeEleven is offline   Reply With Quote
Old 12-16-2008, 10:40 AM   #18
fl4tsc
Scooby Specialist
 
Member#: 177247
Join Date: Apr 2008
Chapter/Region: South East
Location: Greenville, SC
Vehicle:
2005 WRX 16G-XT+EWG
1980 Porsche 911SC 3.6L

Default

^^exactly... that's why it's so weird.
fl4tsc is offline   Reply With Quote
Old 12-16-2008, 11:24 AM   #19
punk
Scooby Specialist
 
Member#: 169792
Join Date: Jan 2008
Chapter/Region: NESIC
Location: Bellingham, MA
Vehicle:
2005 STI
White

Default

Might be a long shot, but are you sure it was snapped all the way in to begin with? You may have just pulled the panel off without even noticing that the corner clip was not even in.
punk is offline   Reply With Quote
Old 12-17-2008, 09:52 AM   #20
fl4tsc
Scooby Specialist
 
Member#: 177247
Join Date: Apr 2008
Chapter/Region: South East
Location: Greenville, SC
Vehicle:
2005 WRX 16G-XT+EWG
1980 Porsche 911SC 3.6L

Default

truthfully i think your right... i really don't see any other way they could have been.
fl4tsc is offline   Reply With Quote
Old 12-17-2008, 10:40 AM   #21
Aaron'z 2.5RS
Scooby Guru
 
Member#: 1026
Join Date: Mar 2000
Chapter/Region: MWSOC
Location: Hickigan
Vehicle:
'00 RS/WRX Stg5
'98 RS Stock

Default

Maybe the clip under the speaker wasn't fully engaged to begin with... I mean it's easy enough for that to happen... The onr forward and the one aft got seated, but not the one you are talking about??

I see the stock speacer was used, which is like 1/2" at the top and 3/4" at the bottom... that could be part of the problem.. I guess..

When you pull the door panel back off, is there any indication ON the speaker itself that it was touching? Or do you think it's hitting the tweeter? If it's touching the tweeter, there really isn't much you can do besides try a different spacer (Kartboy) or a different speaker..
Aaron'z 2.5RS is offline   Reply With Quote
Old 12-17-2008, 11:27 AM   #22
chazly413
Scooby Specialist
 
Member#: 151079
Join Date: Jun 2007
Chapter/Region: MAIC
Location: College Park, MD
Vehicle:
2005 2.5RS RBP
too many friction losses

Default

That rubber gasket at the bottom of the door; are you pulling that around the card to snap it back in? I know if I don't pull the gasket out, my card won't snap in over there.
chazly413 is offline   Reply With Quote
Old 12-17-2008, 11:53 AM   #23
boostdog
Scooby Specialist
 
Member#: 149752
Join Date: May 2007
Location: NW Arkansas
Vehicle:
2017 wrx
ICE ICE BABY SILVER!

Default

Let your g-friend try as she maybe more of a man than you are....JK JK.. OP you need to just take your time and line up everything. i have had my cards off 4-5 times and never have had any issues like your having. just put away your vagina and be smart.....oh i kill me! JK
boostdog is offline   Reply With Quote
Old 12-17-2008, 12:42 PM   #24
Audiosavvy
Scooby Guru
 
Member#: 150794
Join Date: Jun 2007
Chapter/Region: SCIC
Location: Bakersfield, CA
Vehicle:
Qcab dakota 4x4
LT1 Formula Firebird

Default

You may need to pull DOWN on the bottom of the door panel, I suspect that it's extremely close to clearing, and plastic is flexible
Audiosavvy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Corpus Christi: Help, I can't get my IC back on my 07 STI Spectre186 Texas Impreza Club Forum -- TXIC 8 09-21-2008 12:07 AM
I can't get my strut back on my car, help? Gso2k Brakes, Steering & Suspension 10 07-10-2008 12:43 AM
Trouble putting door cards back on after sound deadening, input appreciated. SLOMatt Car Audio, Video & Security 13 04-30-2008 04:34 PM
Am i retarded? Can't get airbox cover back on mc2 Legacy Forum 5 02-03-2007 02:45 PM

All times are GMT -4. The time now is 08:24 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.