Welcome to the North American Subaru Impreza Owners Club Monday January 21, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 01-11-2019, 11:24 AM   #1
Powattackpow
Scooby Newbie
 
Member#: 339759
Join Date: Dec 2012
Default Swapping from phase I to phase II transmission issue

I swapped out my GF8 transmission to a phase II (TY754VSBAA, unsure from what car) . Everything works fine but now when the car is warm/hot and I turn my steering wheel completely the car begins making clunking noises . When the wheel is straight , nothing is wrong .

The shop I take my car to says since itís a different transmission gen , the axles need to be replace to fit proper length , is that true or transmission has nothing to do with the length of the axles ? Thanks in advance for any help and suggestions !
* Registered users of the site do not see these ads.

Last edited by Powattackpow; 01-11-2019 at 11:52 AM.
Powattackpow is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-11-2019, 11:55 AM   #2
Powattackpow
Scooby Newbie
 
Member#: 339759
Join Date: Dec 2012
Default

Powattackpow is offline   Reply With Quote
Old 01-12-2019, 10:39 AM   #3
Powattackpow
Scooby Newbie
 
Member#: 339759
Join Date: Dec 2012
Default

Update: axles were replaced but noise is still there . Help please
Powattackpow is offline   Reply With Quote
Old 01-13-2019, 08:26 PM   #4
binny
Scooby Newbie
 
Member#: 198108
Join Date: Dec 2008
Location: Australia
Vehicle:
MY98 WRX
Blue

Default

Did you also change the rear diff?

watched the vid - you probably need to have a look around the suspension
binny is offline   Reply With Quote
Old 01-13-2019, 08:31 PM   #5
Blktrax
Scooby Specialist
 
Member#: 220971
Join Date: Aug 2009
Chapter/Region: South East
Location: West, NC
Vehicle:
2002 WRX 223K Mi.

Default

Sounds like suspension/steering issues, ball joints, lower control arm bushings, strut mounts, tie rods/rack.

If it was axles you'd have a thumping noise driving and turning, not when sitting still. Unless the wheel bearings are so bad they're about to fall out.
Blktrax is offline   Reply With Quote
Old 01-13-2019, 08:48 PM   #6
Powattackpow
Scooby Newbie
 
Member#: 339759
Join Date: Dec 2012
Default

Quote:
Originally Posted by binny View Post
Did you also change the rear diff?

watched the vid - you probably need to have a look around the suspension
Checked the rear diff and itís good , gonna replace the center diff tomorrow . Hopefully itíll be the key . Checked my suspension and itís good , only few thousand on them (st coilovers)
Powattackpow is offline   Reply With Quote
Old 01-13-2019, 08:50 PM   #7
Powattackpow
Scooby Newbie
 
Member#: 339759
Join Date: Dec 2012
Default

Quote:
Originally Posted by Blktrax View Post
Sounds like suspension/steering issues, ball joints, lower control arm bushings, strut mounts, tie rods/rack.

If it was axles you'd have a thumping noise driving and turning, not when sitting still. Unless the wheel bearings are so bad they're about to fall out.
Changed al of those last year , theyíre all good . Did a full check on everything revolving around my suspension
Powattackpow is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 05:09 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.