Welcome to the North American Subaru Impreza Owners Club Sunday May 9, 2021
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 02-28-2021, 01:54 AM   #1
opualuan
Scooby Newbie
 
Member#: 265940
Join Date: Dec 2010
Default Suspension noises 11 wrx hatch

Just had my struts (OEM) professionally replaced on all four corners of my 2011 wrx hatch, and new whiteline/kartboy sways/endlinks put in. I have a creaky old bedspring sound on passenger side front now at low speeds, when parked if I stand on the sill and bounce it will creak badly.

Does this indicate something to do with the spring, strut, or something about the install? Could the strut itself be blown out of the box?
* Registered users of the site do not see these ads.
opualuan is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-23-2021, 04:28 PM   #2
duder56
Scooby Newbie
 
Member#: 522926
Join Date: Mar 2021
Chapter/Region: Tri-State
Location: NY
Vehicle:
2008 Impreza OBS
Silver

Default

Old thread but here you go:



Lubricate your sway bar bushings and links... 9/10 times creaks are from aftermarket bushings not having adequate lubrication or fitment. If that does not work, then look for loose parts... If no parts are loose (or you can't tell by yourself) have it diagnosed by a professional to see if anything is actually wrong.


My bet is sway bar bushings
duder56 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 04:55 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.