Welcome to the North American Subaru Impreza Owners Club Thursday October 17, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 10-06-2019, 03:00 AM   #1
2006Blackeye
Scooby Newbie
 
Member#: 500015
Join Date: Apr 2019
Default weird sound after replacing clutch

I just installed a oem completion clutch kit and a tsk3 snout sleeven repair kit on a 2005 legacy gt after my throw out bearing exploded I was super careful with the install greasing everything and torquing to spec but now I am getting a weird sound as soon as I start the car sounds like its coming from the bell housing area I have only started the car a few times and have let it run for only a few seconds i'm scared I'm gonna damage something but the sound is there with the clutch engaged and disengaged but the pitch slightly changes. What could be the issue or be causing this sound?
* Registered users of the site do not see these ads.
2006Blackeye is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 10-06-2019, 12:55 PM   #2
viper_crazy
Scooby Specialist
 
Member#: 298403
Join Date: Oct 2011
Chapter/Region: W. Canada
Vehicle:
2008 WRX Premium
Spark Silver

Default

Video/sound clip may help.
viper_crazy is offline   Reply With Quote
Old 10-10-2019, 08:32 PM   #3
greasecoyote
Scooby Newbie
 
Member#: 506808
Join Date: Sep 2019
Default

Did you perhaps install the clutch disc upside down? Usually one side fits flat on the flywheel and one side will interfere with stuff if installed in that orientation?
greasecoyote is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 10:09 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.