Welcome to the North American Subaru Impreza Owners Club Wednesday October 5, 2022
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Car Audio, Video & Security

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 01-11-2022, 03:57 AM   #26
RRATS
Scooby Newbie
 
Member#: 510835
Join Date: Jan 2020
Chapter/Region: MWSOC
Location: Chicago suburbs
Vehicle:
2017 STI Limited
Pure Red

Default

Just gotta source an amp now ***129300;
* Registered users of the site do not see these ads.
RRATS is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-11-2022, 12:10 PM   #27
S2000_Europe
Scooby Newbie
 
Member#: 297373
Join Date: Oct 2011
Chapter/Region: South East
Location: South East
Vehicle:
2018 STI Type RA
Black

Default

Just a quick question. I have a sti 2018 unit with No HK no apple car. My car does not come with the SOS button.

I just want navigation, I prefer via apple car but the navigation option in the stereo is also fine

which OEM alternative I have? is there any more or less plug and play?
S2000_Europe is offline   Reply With Quote
Old 01-11-2022, 12:22 PM   #28
S2000_Europe
Scooby Newbie
 
Member#: 297373
Join Date: Oct 2011
Chapter/Region: South East
Location: South East
Vehicle:
2018 STI Type RA
Black

Default

it is the unit FV833UM
S2000_Europe is offline   Reply With Quote
Old 01-12-2022, 09:54 PM   #29
protivakid
Scooby Newbie
 
Member#: 265148
Join Date: Nov 2010
Location: MA
Vehicle:
2016 WRX
White

Default

Quote:
Originally Posted by S2000_Europe View Post
Just a quick question. I have a sti 2018 unit with No HK no apple car. My car does not come with the SOS button.

I just want navigation, I prefer via apple car but the navigation option in the stereo is also fine

which OEM alternative I have? is there any more or less plug and play?
Not sure about Euro cars but I imagine you could do the same, just swap in a radio from a 2019+ WRX.
protivakid is offline   Reply With Quote
Old 01-13-2022, 01:11 PM   #30
S2000_Europe
Scooby Newbie
 
Member#: 297373
Join Date: Oct 2011
Chapter/Region: South East
Location: South East
Vehicle:
2018 STI Type RA
Black

Default

Quote:
Originally Posted by protivakid View Post
Not sure about Euro cars but I imagine you could do the same, just swap in a radio from a 2019+ WRX.
Thank you, no need to buy gps antenna? the one that goes under the dash?

my car is USDM. I was living in Europe when opened the account
S2000_Europe is offline   Reply With Quote
Old 01-15-2022, 04:58 PM   #31
sb817
Scooby Newbie
 
Member#: 521042
Join Date: Dec 2020
Default

Would it be possible to do this swap on a 2018 STI Type RA? I only want CarPlay. Would I still need the amp adapter?
sb817 is offline   Reply With Quote
Old 01-17-2022, 10:12 AM   #32
protivakid
Scooby Newbie
 
Member#: 265148
Join Date: Nov 2010
Location: MA
Vehicle:
2016 WRX
White

Default

Quote:
Originally Posted by S2000_Europe View Post
Thank you, no need to buy gps antenna? the one that goes under the dash?

my car is USDM. I was living in Europe when opened the account
If you buy a MAP button radio you will need an GPS antenna if you want the Nav to work. If you buy a PHONE button radio then no gps antenna needed.


Quote:
Originally Posted by sb817 View Post
Would it be possible to do this swap on a 2018 STI Type RA? I only want CarPlay. Would I still need the amp adapter?
Should be fine on the RA, the radio doesn't care if it's in a RA STI or a Base WRX. If you buy a MAP button radio then yes you will need an AMP and an adapter. The adapter you build will depend on if your RA already has a HK Nav radio or not.
protivakid is offline   Reply With Quote
Old 01-17-2022, 12:28 PM   #33
sb817
Scooby Newbie
 
Member#: 521042
Join Date: Dec 2020
Default

Thanks for the reply. So, it seems like the unit w/just the phone would be plug and play with the door, steering wheel button, and USB port caveats
sb817 is offline   Reply With Quote
Old 01-18-2022, 12:06 PM   #34
protivakid
Scooby Newbie
 
Member#: 265148
Join Date: Nov 2010
Location: MA
Vehicle:
2016 WRX
White

Default

Quote:
Originally Posted by sb817 View Post
Thanks for the reply. So, it seems like the unit w/just the phone would be plug and play with the door, steering wheel button, and USB port caveats
I re-read your comment and yes those would be the caveats. Just make sure you don't have a HK amp now or the Phone radio may actually be harder.
protivakid is offline   Reply With Quote
Old 02-04-2022, 11:41 PM   #35
Asymmetry
Scooby Newbie
 
Member#: 92646
Join Date: Aug 2005
Location: Sydney
Vehicle:
MY03 WRX Toaster
Silver

Default

Great work!

Wish I saw this before I did my conversion, would of saved me a lot of headaches.
Asymmetry is offline   Reply With Quote
Old 02-10-2022, 12:45 AM   #36
YumGTR
Scooby Newbie
 
Member#: 63779
Join Date: Jun 2004
Chapter/Region: MAIC
Location: Montgomery Village, MD
Vehicle:
1989 BNR32

Default

I have a 2018 Type RA. I picked up a non-amplified, 6Ē with physical buttons head unit from a 2020 wrx I believe. I believe it is actually manufactured by HK but like I said it doesnít require an amp as my car doesnít have one, nor did it come with telematics. Just by virtue of swapping over the head units alone here is what worked:

- backup camera with lines
- Bluetooth phone and audio
- Sirius/Xmas
- front/back and left/right fade
- dimming

What doesnít work is:
- steering wheel controls
- usb iPhone/iPod controls (will launch but then disconnect repeatedly so I canít successfully play any audio from the phone unless unplugged from the car and connected to BTA)
- usb carplay/android auto

I purchased a double 2.1amp usb jack used on eBay and plugged it in yesterday excited that it might let CarPlay work but alas, my phone wonít charge when connected to the replacement unit I got at all, and iPod controls donít even begin to launch like with the original .5amp 2018 usb connectors. Itís like the phone and HU arenít connecting at all.

Maybe someone scammed me with a bum part on eBay so I ordered a new one from the dealership but I canít return it if it is opened as It is an electrical part and more than double what I paid on eBay for the used one. Le sighÖ

I wish I had found this thread for the blue wire into the 12p connector my car doesnít have, in order to kill the HU when the door opens if the key is off. Instead I bought a body control module for a 2020 and thought maybe that would help me get it. Expensive oversight. Does anyone know if the bcm comes into play at all with this?
YumGTR is offline   Reply With Quote
Old 02-11-2022, 05:49 PM   #37
vw_mkv
Scooby Newbie
 
Member#: 208896
Join Date: Apr 2009
Chapter/Region: W. Canada
Location: Richmond, BC
Vehicle:
2018 STI Type RA
WRB

Default

Quote:
Originally Posted by YumGTR View Post
I have a 2018 Type RA. I picked up a non-amplified, 6Ē with physical buttons head unit from a 2020 wrx I believe. I believe it is actually manufactured by HK but like I said it doesnít require an amp as my car doesnít have one, nor did it come with telematics. Just by virtue of swapping over the head units alone here is what worked:

- backup camera with lines
- Bluetooth phone and audio
- Sirius/Xmas
- front/back and left/right fade
- dimming

What doesnít work is:
- steering wheel controls
- usb iPhone/iPod controls (will launch but then disconnect repeatedly so I canít successfully play any audio from the phone unless unplugged from the car and connected to BTA)
- usb carplay/android auto

I purchased a double 2.1amp usb jack used on eBay and plugged it in yesterday excited that it might let CarPlay work but alas, my phone wonít charge when connected to the replacement unit I got at all, and iPod controls donít even begin to launch like with the original .5amp 2018 usb connectors. Itís like the phone and HU arenít connecting at all.

Maybe someone scammed me with a bum part on eBay so I ordered a new one from the dealership but I canít return it if it is opened as It is an electrical part and more than double what I paid on eBay for the used one. Le sighÖ

I wish I had found this thread for the blue wire into the 12p connector my car doesnít have, in order to kill the HU when the door opens if the key is off. Instead I bought a body control module for a 2020 and thought maybe that would help me get it. Expensive oversight. Does anyone know if the bcm comes into play at all with this?
You just need a new usb module for a 19+ car for that to work. Same goes for the steering wheel control, the buttons are in different location on 19+
vw_mkv is offline   Reply With Quote
Old 02-11-2022, 06:28 PM   #38
S2000_Europe
Scooby Newbie
 
Member#: 297373
Join Date: Oct 2011
Chapter/Region: South East
Location: South East
Vehicle:
2018 STI Type RA
Black

Default

Quote:
Originally Posted by vw_mkv View Post
You just need a new usb module for a 19+ car for that to work. Same goes for the steering wheel control, the buttons are in different location on 19+
I have an usb module if you are interested
S2000_Europe is offline   Reply With Quote
Old 02-12-2022, 07:49 AM   #39
protivakid
Scooby Newbie
 
Member#: 265148
Join Date: Nov 2010
Location: MA
Vehicle:
2016 WRX
White

Default

Quote:
Originally Posted by YumGTR View Post
I have a 2018 Type RA. I picked up a non-amplified, 6Ē with physical buttons head unit from a 2020 wrx I believe. I believe it is actually manufactured by HK but like I said it doesnít require an amp as my car doesnít have one, nor did it come with telematics. Just by virtue of swapping over the head units alone here is what worked:

- backup camera with lines
- Bluetooth phone and audio
- Sirius/Xmas
- front/back and left/right fade
- dimming

What doesnít work is:
- steering wheel controls
- usb iPhone/iPod controls (will launch but then disconnect repeatedly so I canít successfully play any audio from the phone unless unplugged from the car and connected to BTA)
- usb carplay/android auto

I purchased a double 2.1amp usb jack used on eBay and plugged it in yesterday excited that it might let CarPlay work but alas, my phone wonít charge when connected to the replacement unit I got at all, and iPod controls donít even begin to launch like with the original .5amp 2018 usb connectors. Itís like the phone and HU arenít connecting at all.

Maybe someone scammed me with a bum part on eBay so I ordered a new one from the dealership but I canít return it if it is opened as It is an electrical part and more than double what I paid on eBay for the used one. Le sighÖ

I wish I had found this thread for the blue wire into the 12p connector my car doesnít have, in order to kill the HU when the door opens if the key is off. Instead I bought a body control module for a 2020 and thought maybe that would help me get it. Expensive oversight. Does anyone know if the bcm comes into play at all with this?
That's odd the USB jack doesn't work, what's the part number? Does it say 2.1A right on it?
protivakid is offline   Reply With Quote
Old 02-12-2022, 08:05 AM   #40
S2000_Europe
Scooby Newbie
 
Member#: 297373
Join Date: Oct 2011
Chapter/Region: South East
Location: South East
Vehicle:
2018 STI Type RA
Black

Default

Quote:
Originally Posted by protivakid View Post
That's odd the USB jack doesn't work, what's the part number? Does it say 2.1A right on it?


should be like this

S2000_Europe is offline   Reply With Quote
Old 02-12-2022, 07:39 PM   #41
RRATS
Scooby Newbie
 
Member#: 510835
Join Date: Jan 2020
Chapter/Region: MWSOC
Location: Chicago suburbs
Vehicle:
2017 STI Limited
Pure Red

Default

Iíve been at it today doing this swap on my 17 STI limited.
Iíve got everything hooked up, radio, map, and all speakers work.
The usb jack I have (2.1) doesnít recognize thereís something plugged into it. Tried plugging the old one in too (non 2.1) but it doesnít recognize that one either
RRATS is offline   Reply With Quote
Old 02-12-2022, 10:30 PM   #42
S2000_Europe
Scooby Newbie
 
Member#: 297373
Join Date: Oct 2011
Chapter/Region: South East
Location: South East
Vehicle:
2018 STI Type RA
Black

Default

the blue wire that goes from the 12 pin to the door ground is 14 gauge?and how long? 4ft?
S2000_Europe is offline   Reply With Quote
Old 02-16-2022, 03:44 AM   #43
CXVninja84
Scooby Newbie
 
Member#: 438216
Join Date: Jan 2016
Default

The 2.1A, 2020+ version of the USB port that's in that picture is wired differently than the 2018 USB port. These dual port USB ports are powered from the car's fusebox and the +12v power wire is on a different pin on the back of that jack. I suspect this is why it's not recognized by the new headunit.
CXVninja84 is offline   Reply With Quote
Old 02-17-2022, 08:59 AM   #44
lukikosa
Scooby Newbie
 
Member#: 528002
Join Date: Dec 2021
Default

Quote:
Originally Posted by S2000_Europe View Post
should be like this



Check the 8 pin cube. Until the 2019 version, the power supply was on the 5th pin. You probably have a 2020 usb port and need to switch pin 5 -> pin 6.
it is a white 8-pin cube

Last edited by lukikosa; 02-17-2022 at 02:13 PM.
lukikosa is offline   Reply With Quote
Old 02-19-2022, 12:55 PM   #45
lukikosa
Scooby Newbie
 
Member#: 528002
Join Date: Dec 2021
Default

#protivakid
Are you interested in what may be caused by the lack of messages from the navigation built into the radio (the factory one), the sound from the phone radio, bluetooth works normally. I wonder what this could be at fault. The amplifier because I put on the subaru impreza sport 86221FL00A amplifier.
I set up the radio for the subaru forester MY18
lukikosa is offline   Reply With Quote
Old 02-20-2022, 07:05 PM   #46
RRATS
Scooby Newbie
 
Member#: 510835
Join Date: Jan 2020
Chapter/Region: MWSOC
Location: Chicago suburbs
Vehicle:
2017 STI Limited
Pure Red

Default

Quote:
Originally Posted by lukikosa View Post
Check the 8 pin cube. Until the 2019 version, the power supply was on the 5th pin. You probably have a 2020 usb port and need to switch pin 5 -> pin 6.
it is a white 8-pin cube
I have 86257VA130 USB port.
Tried moving pins, same thing doesnít recognize thereís something plugged in.
RRATS is offline   Reply With Quote
Old 02-21-2022, 01:37 AM   #47
lukikosa
Scooby Newbie
 
Member#: 528002
Join Date: Dec 2021
Default

Quote:
Originally Posted by RRATS View Post
I have 86257VA130 USB port.
Tried moving pins, same thing doesnít recognize thereís something plugged in.
I installed the same port and it had no power at the beginning.
Need to translate pin 5 to pin 6.
You need to remove pin 5 and put it in pin 6 in the white 8-pin cube that connects the usb port.

the pins need to be changed in places. It is not enough to move around.
pin 6 is free and you need to translate pin 5 to it
lukikosa is offline   Reply With Quote
Old 02-21-2022, 03:30 AM   #48
RRATS
Scooby Newbie
 
Member#: 510835
Join Date: Jan 2020
Chapter/Region: MWSOC
Location: Chicago suburbs
Vehicle:
2017 STI Limited
Pure Red

Default

Quote:
Originally Posted by lukikosa View Post
I installed the same port and it had no power at the beginning.
Need to translate pin 5 to pin 6.
You need to remove pin 5 and put it in pin 6 in the white 8-pin cube that connects the usb port.

the pins need to be changed in places. It is not enough to move around.
pin 6 is free and you need to translate pin 5 to it
I checked for power with test light on pin 5 (i think it was light blue wire), it had power. then i transferred to pin 6, and still does not work.
RRATS is offline   Reply With Quote
Old 02-21-2022, 04:12 AM   #49
lukikosa
Scooby Newbie
 
Member#: 528002
Join Date: Dec 2021
Default

Quote:
Originally Posted by RRATS View Post
I checked for power with test light on pin 5 (i think it was light blue wire), it had power. then i transferred to pin 6, and still does not work.
yes, the power supply is on pin 5 and you've checked and it's ok. Now remove this pin with the wire from the ankle and put it in the free space on pin 6. The port that you mount the power supply is on pin 6 and you have to install it on 5. So you have to to change it
lukikosa is offline   Reply With Quote
Old 02-21-2022, 04:19 PM   #50
S2000_Europe
Scooby Newbie
 
Member#: 297373
Join Date: Oct 2011
Chapter/Region: South East
Location: South East
Vehicle:
2018 STI Type RA
Black

Default

This is the 2019



This is the 2020




and now the question, which is the 5 pin an the 6 pin?

S2000_Europe is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 10:57 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2022 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.