Welcome to the North American Subaru Impreza Owners Club Sunday July 22, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 07-02-2018, 08:17 PM   #1
andyfb20
Scooby Newbie
 
Member#: 462200
Join Date: Jan 2017
Default Help with 2013 Crosstrek xv

While I was driving my abs,traction control, and hill assist lights came on. So I pulled over and looked it up and came across people saying it may be the brake light switch but my break lights still come on and when I turned it back on the lights are no longer on. Can someone tell me what this might be ?
* Registered users of the site do not see these ads.
andyfb20 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-03-2018, 09:49 AM   #2
DieselDorf
Scooby Newbie
 
Member#: 454773
Join Date: Sep 2016
Chapter/Region: MWSOC
Location: Traverse City, MI
Vehicle:
2012 Impreza Sport
Pearl White

Default

Check the fuses in the little panel under the traction control button. One of those controls most of what went out on yours can't remember which one.
DieselDorf is offline   Reply With Quote
Old 07-09-2018, 09:18 PM   #3
DryLyne
Scooby Newbie
 
Member#: 488150
Join Date: Jul 2018
Default

I recall it was the third fuse from the bottom in the fuse box below the steering wheel.
DryLyne is offline   Reply With Quote
Old 07-11-2018, 05:42 PM   #4
Jack
Add Lightness
Moderator
 
Member#: 13699
Join Date: Dec 2001
Chapter/Region: NESIC
Location: Hopkinton, MA
Vehicle:
not my president
(From General)

Default

Pull the codes. Is it a CVT? Sounds like the lights that came on in ours before we replaced the bad tranny.
Jack is offline   Reply With Quote
Old 07-13-2018, 02:44 PM   #5
andyfb20
Scooby Newbie
 
Member#: 462200
Join Date: Jan 2017
Default

It is a cvt, the lights come on and off. Haven't been on a few days now
andyfb20 is offline   Reply With Quote
Old 07-13-2018, 02:45 PM   #6
andyfb20
Scooby Newbie
 
Member#: 462200
Join Date: Jan 2017
Default

No check engine lights, just abs, hill assist, and traction control
andyfb20 is offline   Reply With Quote
Old 07-13-2018, 03:04 PM   #7
andyfb20
Scooby Newbie
 
Member#: 462200
Join Date: Jan 2017
Default

Quote:
Originally Posted by Jack View Post
Pull the codes. Is it a CVT? Sounds like the lights that came on in ours before we replaced the bad tranny.


Now you've got me worried about the tranny :/ that's an issue I can not afford to fix atm. Any other issues you experienced before it failed
andyfb20 is offline   Reply With Quote
Old 07-13-2018, 10:37 PM   #8
Elbert Bass
Scooby Specialist
 
Member#: 283429
Join Date: May 2011
Chapter/Region: South East
Location: Down yonder.
Vehicle:
2016 Fuji Sunfire 03
Silver

Default

If it was a CVT code/issue you would have a check engine light. ANY fault the TCM sees will automatically set a P0700 in the ECM to get your attention.

It could still be your brake light switch - they fail intermittently at first. Find out what the codes are - you will have some. You will need a scan tool that can read VDC codes, a basic scanner won't do it.
Elbert Bass is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 03:08 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.