Welcome to the North American Subaru Impreza Owners Club Thursday April 9, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 02-23-2020, 11:42 PM   #1
Powsurfer96
Scooby Newbie
 
Member#: 493872
Join Date: Nov 2018
Default Boost control problems 2003 wrx

I took a data log today because my car had been feeling weird. The log shows my boost climbing up to 18psi (target) then it would drop down to about 10psi and climb back up To 18 again. It does this over and over through my pull. I could hear it leaking out like a blow off valve when it would drop. Itís a bugeye on a Cobb stage 2 map with a catted downpipe and Cobb intake. Where should I start troubleshooting?
No obvious leaks that I could see. Can post up the log if anyone wants to see it.
* Registered users of the site do not see these ads.
Powsurfer96 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 02-25-2020, 01:34 PM   #2
Therumblebox
Scooby Newbie
 
Member#: 477751
Join Date: Nov 2017
Default

Are you running the stock boost controller?
Therumblebox is offline   Reply With Quote
Old 02-25-2020, 09:11 PM   #3
Powsurfer96
Scooby Newbie
 
Member#: 493872
Join Date: Nov 2018
Default

Quote:
Originally Posted by Therumblebox View Post
Are you running the stock boost controller?
Yes itís stock
Powsurfer96 is offline   Reply With Quote
Old 02-26-2020, 11:21 AM   #4
02hybridwrx
Scooby Newbie
 
Member#: 397139
Join Date: Jul 2014
Default

Get a Mac 3 port for cheap and get it tuned for it. Stock ones commonly go bad.
02hybridwrx is offline   Reply With Quote
Old 02-26-2020, 05:29 PM   #5
NicMonte
Scooby Newbie
 
Member#: 479655
Join Date: Dec 2017
Location: Omaha Ne
Vehicle:
2002 Impreza wrx
Black

Default

Or get the Cobb 3port and retune with their Stage2 ebcs map. Is the downpipe from Cobb?
NicMonte is offline   Reply With Quote
Old 02-28-2020, 11:29 AM   #6
kpm_777
Scooby Newbie
 
Member#: 492460
Join Date: Oct 2018
Chapter/Region: BAIC
Location: Bay Area, CA / Rapid City, SD
Vehicle:
2019 WRX
Lapis

Default

I would also check for boost leaks in your intake system, pull the intercooler and check the Y-pipe for sure. Sometimes leaks can do weird stuff like that.
kpm_777 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 03:33 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.