Welcome to the North American Subaru Impreza Owners Club Saturday December 15, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 09-22-2018, 05:59 PM   #1
WhippledSTi
Scooby Newbie
 
Member#: 425286
Join Date: Jul 2015
Chapter/Region: E. Canada
Location: St. Catharines, ON
Vehicle:
2007 Subaru WRX STi
Urban Grey Metallic

Question ID1000 Flow Test Results... Should I run these?

So I have a set of 4 ID1000 injectors that have been run for roughly the last 60k miles between myself and the previous owner. I've had them at ~60-65% IDC for like 35k miles now so never really pushed them, but I've also never run any injector cleaner or anything like that through them.

Previous owner ran 91 through them, I ran 94 octane.

I was having an intermittent cyl 2 misfire on a brand new OEM shortblock, swapped coils, put in new plugs, etc. Last thing to do was check injectors.

I just received my injector flow test back, with the following results.


Cyl 1 Injector: 130
Cyl 2 Injector: 115
Cyl 3 Injector: 130
Cyl 4 Injector: 115

Not sure what units the results came in but I'm worried about the 8.8% variation between banks.

The misfires came from Cylinder 2 and once in a while cylinder 4.

Problem is, the injector shop cleaned the injectors first then tested them, failing to give me a baseline to compare to.

So with the values like this, would it be too risky to run them at 60-65% IDC under the highest conditions in my STi?

Thanks!
* Registered users of the site do not see these ads.
WhippledSTi is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 09-22-2018, 06:33 PM   #2
bp05obxt
Scooby Newbie
 
Member#: 459799
Join Date: Dec 2016
Default

Honestly not a terrible difference. I would put the lower reading injectors closest to the feed side of either rail and don’t push the duty cycle too far. It is pretty normal for their to be a difference between injectors.

We’re these injectors cleaned as well?
bp05obxt is offline   Reply With Quote
Old 09-22-2018, 06:35 PM   #3
WhippledSTi
Scooby Newbie
 
Member#: 425286
Join Date: Jul 2015
Chapter/Region: E. Canada
Location: St. Catharines, ON
Vehicle:
2007 Subaru WRX STi
Urban Grey Metallic

Default

Quote:
Originally Posted by bp05obxt View Post
Honestly not a terrible difference. I would put the lower reading injectors closest to the feed side of either rail and don’t push the duty cycle too far. It is pretty normal for their to be a difference between injectors.

We’re these injectors cleaned as well?
Yeah this was after cleaning. I think the cyl 2 injector was the one that was clogged and causing issues but now that they failed to get me a baseline prior to cleaning I'll never know without putting them back on smh.

I'm not going to be pushing the duty cycle past 65% at peak boost, so not pushing them very far.

That is a good suggestion though, didn't think about keeping them close to the feed side of the rails.

Thanks!
WhippledSTi is offline   Reply With Quote
Old 09-23-2018, 02:24 AM   #4
WhippledSTi
Scooby Newbie
 
Member#: 425286
Join Date: Jul 2015
Chapter/Region: E. Canada
Location: St. Catharines, ON
Vehicle:
2007 Subaru WRX STi
Urban Grey Metallic

Default

Bump!
WhippledSTi is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 11:01 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.