Welcome to the North American Subaru Impreza Owners Club Monday July 4, 2022
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 01-15-2022, 02:38 PM   #1
e_navarre
Scooby Newbie
 
Member#: 524861
Join Date: Jun 2021
Default Rich at idle

Been having this issue for a while now
Car starts fine, but once it enters CL, the AFR will sit at 12-13 at IDLE, with -25% afr learning. Then it will bog super lean, then super rich again. At WOT the car will throw a p0103 (MAF Circuit High Input, likely due to colder weather)

I replaced my O2, MAF and IAT sensors, checked for obvious fuel leaks and checked all grounds. Had whole intake system smoke tested. Flow tested and cleaned injectors along with new o-rings. Compression tested with new plugs, all numbers came back strong and consistent.

Only other things I suspect could be an exhaust leak or some hidden electrical issues.

Any input would be appreciated. Im losing my mind and money.

Mod list (that pertains to this issue)
Aeromotive AFPR
Walbro 450 pump
DW hardwire kit
ID 1300cc
IAG braided fuel lines
COBB CAI
Catless DP
Perrin 3in turbo inlet

Last edited by e_navarre; 03-18-2022 at 07:16 PM. Reason: Update
e_navarre is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 05:34 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2022 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.