Welcome to the North American Subaru Impreza Owners Club Sunday April 18, 2021
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 03-07-2003, 07:15 PM   #1
NewSuby
Scooby Newbie
 
Member#: 15363
Join Date: Feb 2002
Location: Bay Area
Vehicle:
2002 WRX Sedan

Default Coolant Leak near Turbo on WRX

Hi All,

I haven't posted in a while. I've got a 2002 WRX with Catback, Uppipe and Intercooler. I've got some sort of coolant leak near or on the turbo. When the car gets good and warmed up the coolant leaks and instantly goes to steam (looks like the car is overheating as steam poors out of the passenger side of the hood and hood scoop). I can tell its burned coolant by the smell. I looked under the hood and can see the steam coming from the area near the turbo/downpipe. I assume its one of the coolant lines going to the turbo, but I can't tell from above.

Has anyone else experienced this problem? Any suggestions on where to start to fix this? My car has approximately 30,000 miles.

Thanks,

EJ
* Registered users of the site do not see these ads.
NewSuby is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-07-2003, 11:44 PM   #2
Hawk296
Scooby Specialist
 
Member#: 14555
Join Date: Jan 2002
Chapter/Region: MWSOC
Location: MI
Vehicle:
1995 Impreza L
Baja

Default

ide try tightening the the coolant lines on the turbo and i that didnt work then replaceing the gaskets. from there thats what ide try first from your description
Hawk296 is offline   Reply With Quote
Old 03-08-2003, 01:21 AM   #3
NewSuby
Scooby Newbie
 
Member#: 15363
Join Date: Feb 2002
Location: Bay Area
Vehicle:
2002 WRX Sedan

Default

Thanks, I'll give it a try.

EJ
NewSuby is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Coolant leak after turbo Install 855m0n0 South East Region Forum 5 03-27-2018 07:09 AM
Coolant Leaking from turbo deathskrye Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 03-26-2008 09:10 PM
coolant leak after turbo install preacher#1 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 3 10-12-2007 01:36 AM
coolant leak after turbo install Wookie768 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 10 10-02-2007 05:06 PM
06 oil leak near turbo NextCar Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 2 09-23-2006 08:45 PM

All times are GMT -4. The time now is 01:09 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.