Welcome to the North American Subaru Impreza Owners Club Saturday July 21, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 12-04-2011, 04:13 PM   #1
curly2k3
Scooby Newbie
 
Member#: 87614
Join Date: May 2005
Chapter/Region: MWSOC
Location: minnesnowda
Vehicle:
9698 GC8 & GF4
Black and White

Default '98 OBS 2.2 odd stutter at speed

So basically, this has now happened twice in the past year or so, but I'm still not convinced its not fuel-related (ie bad gas).

The car runs perfectly almost ALL year, slight hesitation or a stall here and there, but its extremely infrequent and happens at most, once a month. However, those small quirks are to be expected with 236,000 miles on a stock block and trans (IMO).

The issue yesterday, is far more annoying and concerning however. While driving (about 30 miles into a 65 mile trip) it'd begin to stutter, hesitate, and almost just become unresponsive to throttle input. That is, I'd maintain a constant pressure and rpm on the pedal and engine, but it'd freeze up and then surge to accelerating.

It has happened twice now, but in slushy road conditions and snow with temps roughly 30*f. I plan to replace my plugs, filter, ect... again and will be cleaning the MAF and Idle Air. It's beginning to get annoying, especially if it decides to happen again while I'm on the freeway like its done both times.

I've kind of ran out of ideas since last time it happened I tried a different knock and cam sensor even, but its happened twice, both with the same atmospheric conditions and same symptoms.

Thanks in advance for any ideas/help, normally I can sort things out on the 2.2's like its my job within an hour, but this one has evaded my mind for a year now.

Chris
* Registered users of the site do not see these ads.
curly2k3 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-14-2011, 01:32 AM   #2
AGTSTi7
Scooby Specialist
 
Member#: 303881
Join Date: Dec 2011
Location: norwalk
Vehicle:
2011 STi
Black

Default

Sounds like its bogging.. first option is to look at ur air filter and clean it.. I had the same problem with my old car... a mouse built its nest in my intake! /:
AGTSTi7 is offline   Reply With Quote
Old 12-14-2011, 12:03 PM   #3
typhoonk
Scooby Newbie
 
Member#: 259497
Join Date: Sep 2010
Location: Bowmanville, Ontario, Canada
Vehicle:
1998 legacy L Wagon
Green/Grey

Default

Idle air control thingy may be clogged up.
typhoonk is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Steering Stutter at Low Speeds smh0101 Brakes, Steering & Suspension 2 12-20-2010 12:52 AM
Will the instrument cluster from 2dr. 2.5RS fit a '98 OBS? RootUsr Electrical & Lighting 3 06-27-2005 09:01 PM
difference between '99L wagon to a '98 OBS? MGXsport North West Impreza Club Forum -- NWIC 12 12-26-2003 07:15 PM
Want to connect the hood scoop to the intake on my '98 OBS. RootUsr Normally Aspirated Powertrain 2 08-18-2003 03:46 PM
('93-'01) '98 obs starter problem geepondy Impreza Forum 2 07-01-2003 05:51 PM

All times are GMT -4. The time now is 02:17 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.