Welcome to the North American Subaru Impreza Owners Club Monday October 18, 2021
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 09-29-2021, 09:05 PM   #1
Massreefcare
Scooby Newbie
 
Member#: 440858
Join Date: Feb 2016
Default Wiring A/T to M/T 02-03 WRX

Ive already done the hard swap. The trans and motor are back in. I have the shop manual for diagrams but i cant seem to find ALL the definitive answers to my questions.

Where exactly is this manual ID pin i keep reading about?

how do i connect the NSS to the clutch?

ive already read IluvDrt's post and its very informative.
* Registered users of the site do not see these ads.
Massreefcare is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 09-30-2021, 06:46 AM   #2
snow_bound26
Scooby Specialist
 
Member#: 395793
Join Date: Jul 2014
Chapter/Region: Tri-State
Location: SLC and Lake Placid
Vehicle:
2005 92x Aero
Beige

Default

The pin was for the GC/BG/BH era ECUs. GD and newer don't have to worry about that pin on the ECU.

There's a very good and descriptive thread on one of the Forester forums I found when doing my swap. However, due to some chewed wires I ended buying a dash harness off eBay. iWire also sells an AT to MT wiring kit. I had bought that before finding the chewed wires. Might still have it kicking around if you want to buy it. PM if you do and I'll take a look for it.
snow_bound26 is offline   Reply With Quote
Old 10-01-2021, 06:38 PM   #3
Massreefcare
Scooby Newbie
 
Member#: 440858
Join Date: Feb 2016
Default

Update: I was using the wrong connector at the bulk head. Progress has been made.

The grey plug, not the black. I hooked up the Neutral position and brake lights to this. The car will turn over by the key... if its in gear. Still wont start tho.

Reverse lights work.

the fuel pump only seems to kick on if the the key it is any position but start/run.
fuel gauge reads empty ( its a full tank)

Ebrake light stays on all the time.
Massreefcare is offline   Reply With Quote
Old 10-01-2021, 06:38 PM   #4
Massreefcare
Scooby Newbie
 
Member#: 440858
Join Date: Feb 2016
Default

still wrapping up small bits on the manual swap.
I still have to connect the rear struts.
The fix i came up with for the cultch line failed so i ordered the OEM clutch pipe from Subaru, instead of a short brake line from oriley. it did fit but it has a small leak... go figure.

Last edited by Massreefcare; 10-02-2021 at 10:32 PM.
Massreefcare is offline   Reply With Quote
Old 10-02-2021, 09:56 PM   #5
Massreefcare
Scooby Newbie
 
Member#: 440858
Join Date: Feb 2016
Default

noticed i wasnt getting the cel to come on, the o2 isnt plugged in so i know it should kick on.

so i swapped ecu's. still nothing.

tried to plug in code reader and it had no power..

just ordered a new main relay, will update.
Massreefcare is offline   Reply With Quote
Old 10-02-2021, 10:37 PM   #6
Massreefcare
Scooby Newbie
 
Member#: 440858
Join Date: Feb 2016
Default

Unfortunately snow_bound26 had the DCCD IWire kit. I'm gonna order the one i need. At least to get the clutch safety back in action. I guess a speedo wouldnt hurt. Even tho i prefer to use GPS on the Radio. Not to mention clean it up and make it functional.
Massreefcare is offline   Reply With Quote
Old 10-03-2021, 07:57 PM   #7
Massreefcare
Scooby Newbie
 
Member#: 440858
Join Date: Feb 2016
Default

I'm making small bits of progress in my free time. I got the cobb sf airbox in. O2 sensor in. found a new way to route all the wires and hose for the gauges through the firewall. got the DP and AFR back on. Wired in the oil temp/pressure sensors for the gauges. I got the radiator in, just need a new clamp for the lower rad hose.
Massreefcare is offline   Reply With Quote
Old 10-03-2021, 07:59 PM   #8
Massreefcare
Scooby Newbie
 
Member#: 440858
Join Date: Feb 2016
Default

I think all that's holding me up is a main relay and a clutch pipe.
Not sure how i could have fried that relay, that's a concern.
Massreefcare is offline   Reply With Quote
Old 10-06-2021, 07:00 AM   #9
Massreefcare
Scooby Newbie
 
Member#: 440858
Join Date: Feb 2016
Default

After talking with Snow_bound26 i think we may have figured out how i blew the relay. I jumped the starter from the battery to the tab the trigger wire goes to. Makes sense now.
Massreefcare is offline   Reply With Quote
Old 10-07-2021, 01:34 PM   #10
Massreefcare
Scooby Newbie
 
Member#: 440858
Join Date: Feb 2016
Default

wasnt the main relay... i think the ecu isnt getting a signal from the ignition? Could the TCM be blocking the signal?
Massreefcare is offline   Reply With Quote
Old 10-11-2021, 10:26 PM   #11
Massreefcare
Scooby Newbie
 
Member#: 440858
Join Date: Feb 2016
Default

caved and bought a bulkhead harness for an mt
Massreefcare is offline   Reply With Quote
Old Yesterday, 06:51 AM   #12
Massreefcare
Scooby Newbie
 
Member#: 440858
Join Date: Feb 2016
Default

Removed the dash. This wasn't nearly as difficult as I had thought. Removed the old harness. I started feeding the new bulkhead harness throughout the car, it goes in a hell of a lot easier than it comes out! Going to finish up the rest of the wiring harness today and see if I can get it to start...
Massreefcare is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 10:32 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.