Welcome to the North American Subaru Impreza Owners Club Saturday January 18, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 11-12-2007, 03:21 AM   #1
simprezl25
Scooby Specialist
 
Member#: 71647
Join Date: Oct 2004
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2002 Bug iD

Default hesitation at full boost

hi guys i recently installed my turbo that i got rebuild at deadbolt and i also took off the straight pipe n1 catback and installed a stock sti catback.

i drove around for 200 miles since u have to break in the turbo. today i went wot after a proper warm up and it started hesitating and bogging. sounded like misfires but my check wasnt flashing.

i got it tuned by turboxs and then i had it tuned with the n1 catback.

is it because of the restrictive sti catback that its making my car do this?

i cant figure this out
* Registered users of the site do not see these ads.

Last edited by simprezl25; 11-12-2007 at 04:28 AM.
simprezl25 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-12-2007, 04:17 AM   #2
icslowmo
Scooby Newbie
 
Member#: 114667
Join Date: May 2006
Chapter/Region: SWIC
Location: Peoria, AZ
Vehicle:
00/5 Silver STi RS
FAT 40R kit w/ FMIC

Default

Need more info on car. Mod list??? And do you mean stock STI cat back???
icslowmo is offline   Reply With Quote
Old 11-12-2007, 04:27 AM   #3
simprezl25
Scooby Specialist
 
Member#: 71647
Join Date: Oct 2004
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2002 Bug iD

Default

Quote:
Originally Posted by icslowmo View Post
Need more info on car. Mod list??? And do you mean stock STI cat back???
yes stock sti catback

mod list td05 big 16g
utec
tial 38 ewg steup
ultimate racing up pipe
hks dp
ssautochrome fmic
oil catch can
knN intake
19psi 307whp 277 trq
simprezl25 is offline   Reply With Quote
Old 11-12-2007, 04:34 AM   #4
icslowmo
Scooby Newbie
 
Member#: 114667
Join Date: May 2006
Chapter/Region: SWIC
Location: Peoria, AZ
Vehicle:
00/5 Silver STi RS
FAT 40R kit w/ FMIC

Default

Why was the turbo in need of a re-build?? Most likly yes it's because of the Sti cat-back. Try taking cat-back off and run with no exhaust to see if problem goes away

Last edited by icslowmo; 11-12-2007 at 04:47 AM.
icslowmo is offline   Reply With Quote
Old 11-12-2007, 01:11 PM   #5
simprezl25
Scooby Specialist
 
Member#: 71647
Join Date: Oct 2004
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2002 Bug iD

Default

Quote:
Originally Posted by icslowmo View Post
Why was the turbo in need of a re-build?? Most likly yes it's because of the Sti cat-back. Try taking cat-back off and run with no exhaust to see if problem goes away
had to get it rebuilt because of end to end haft play

*****update*****
i replaced the sti catback with the n1 straight pipe catback.
but as i was disconnecting the sti a couple drops of coolant hit the ground. i made sure it wasnt water/steam.

where could this coolant be coming from?

Last edited by simprezl25; 11-12-2007 at 08:45 PM.
simprezl25 is offline   Reply With Quote
Old 11-12-2007, 10:40 PM   #6
simprezl25
Scooby Specialist
 
Member#: 71647
Join Date: Oct 2004
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2002 Bug iD

Default

bump for my problem please help
simprezl25 is offline   Reply With Quote
Old 11-12-2007, 11:10 PM   #7
04subyrex
Scooby Newbie
 
Member#: 144873
Join Date: Mar 2007
Chapter/Region: South East
Location: Jackson, MS
Vehicle:
2004 WRX evoIII/meth
66 Mustang 408w

Default

I have the same problem but i got a check engine light....It was saying cylinder 2 misfire. So i checked the plug and it was cracked. Maybe check your plugs...
04subyrex is offline   Reply With Quote
Old 11-12-2007, 11:13 PM   #8
simprezl25
Scooby Specialist
 
Member#: 71647
Join Date: Oct 2004
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2002 Bug iD

Default

Quote:
Originally Posted by 04subyrex View Post
I have the same problem but i got a check engine light....It was saying cylinder 2 misfire. So i checked the plug and it was cracked. Maybe check your plugs...
i have misfires in all four aswell...
simprezl25 is offline   Reply With Quote
Old 11-13-2007, 11:20 PM   #9
simprezl25
Scooby Specialist
 
Member#: 71647
Join Date: Oct 2004
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2002 Bug iD

Default

found the problem! turns out that the sti catback was really restrictive with my tune (utec) so i put the n1 catback on and there is zero hesitation.

turns out that a simple catback switch does make a big difference.
simprezl25 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird noise at full boost Johnny5 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 27 03-07-2016 08:22 PM
hesitating when full boost g-unit555 Legacy Forum 3 08-10-2008 02:44 AM
Whine at Full Boost-Boost Control line was cut. Bundyboyz Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 13 07-26-2005 09:29 AM
Door ajar light comes on at full boost! snvin Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 15 08-27-2004 03:56 PM
engine dies at full boost Andy V Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 16 05-31-2004 01:47 PM

All times are GMT -4. The time now is 02:45 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.