Welcome to the North American Subaru Impreza Owners Club Sunday October 21, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Open Source Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 09-20-2018, 10:25 PM   #1
Glentwenty
Scooby Newbie
 
Member#: 491714
Join Date: Sep 2018
Location: New Zealand
Vehicle:
2003 Legacy GTB
Blue

Default My test connector doesnt work?

Hey guys,

I'm new to the Subaru tuning scene, I seem to be having a very weird issue. First I'll start with what I drive.

2003 BP5 Legacy GTB wagon with an EJ20Y so it has a single td04 turbo.

I just got a tactrix cable today and got ecuflash and romraider. Programs downloaded and installed fine, definitions all installed fine too.

To begin with I didnt think the car needed the test connector as I couldnt find it so I proceeded to try reading the ecu and kept getting the error after "sending key" which either means its locked or the test connector isnt connected, so I spent like an hour looking for the test connector in the legacy. I finally found it under the carpet on the passengers side, but heres where it gets weird.. the connectors were already plugged in to each other which normally means the car is in test mode. I have never touched these meaning they have been like that since we bought it. The car runs fine like that and the engine light goes out like normal and doesn't flash.

Does this mean the test connector doesnt work at all??

Thanks,
Harry
* Registered users of the site do not see these ads.
Glentwenty is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 09-20-2018, 11:04 PM   #2
Airboy
Scooby Specialist
 
Member#: 72829
Join Date: Oct 2004
Chapter/Region: W. Canada
Location: Calgary, Canada
Vehicle:
2006 WRX
2015 WRX

Default

Most Subarus that I have looked at, has two sets of the green "test connectors". Check under the plastic panels on the driver or passenger side, just in front of the door hinges.
Airboy is offline   Reply With Quote
Old 09-20-2018, 11:06 PM   #3
Glentwenty
Scooby Newbie
 
Member#: 491714
Join Date: Sep 2018
Location: New Zealand
Vehicle:
2003 Legacy GTB
Blue

Default

Quote:
Originally Posted by Airboy View Post
Most Subarus that I have looked at, has two sets of the green "test connectors". Check under the plastic panels on the driver or passenger side, just in front of the door hinges.
Sweet I'll keep looking! 😫
Glentwenty is offline   Reply With Quote
Old 09-20-2018, 11:28 PM   #4
Glentwenty
Scooby Newbie
 
Member#: 491714
Join Date: Sep 2018
Location: New Zealand
Vehicle:
2003 Legacy GTB
Blue

Default

Quote:
Originally Posted by Airboy View Post
Most Subarus that I have looked at, has two sets of the green "test connectors". Check under the plastic panels on the driver or passenger side, just in front of the door hinges.
Thank you so much!! It was behind a plastic piece just below the hinge, plugged in and now I'm reading the ecu fine! You're a legend. Made my day
Glentwenty is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 10:15 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.