Welcome to the North American Subaru Impreza Owners Club Saturday July 4, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 04-18-2018, 04:37 PM   #1
TyranosaurusWRX
Scooby Specialist
 
Member#: 25731
Join Date: Oct 2002
Chapter/Region: MWSOC
Location: Ft Wayne, IN
Vehicle:
02 wrx(sold)/2005
Sti/ 93 Leg Wag

Default Issues: 2004 ECU swap in a 2005 ...STi

Thanks to an unstable laptop I bricked my ECU in my 05 STi flashing a map via Ecuflash. Turned out there was a burnt component on the circuit board anyways that was causing me fueling issues. I was able to obtain a 2004 STi ecu. Comparing notes on the pinout diagrams I rewired the harness to match the 5 different wires to feed the 04. I've went over the wiring a few times, it appears to be correct.
I'm still not getting any feedback from the ecu. I connect the flash mode connectors and it doesn't go into test mode. I'm wondering if there is some step I am missing? Seemed pretty straightforward but it's a no go as it sits now.
TyranosaurusWRX is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 07:42 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.