Welcome to the North American Subaru Impreza Owners Club Tuesday February 7, 2023
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 12-05-2022, 04:48 PM   #1
JR Belk
Scooby Newbie
 
Member#: 520375
Join Date: Nov 2020
Default 07 impreza power steering problem

I had to move my power steering pump for another repair. Now the power steering doesn't seem to work at all. The fluid is full of bubbles, which I expected due to removing the return line. I did not expect it to kill the power steering though. There is the typical high pressure "whine" when the wheels are turned fully locked to the right, but that's it. No other noise from the power steering. I think it could be excess air still in the system, but I'm reluctant to jump to conclusions and replace the pump for no reason if it's not the problem.
* Registered users of the site do not see these ads.
JR Belk is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-06-2022, 06:38 AM   #2
arse_sidewards
Scooby Newbie
 
Member#: 532328
Join Date: Dec 2022
Default

Probably air filled fluid in the rack. Jack the car up and turn the wheels from lock to lock a bunch of times with the system running in order to cycle the fluid through the rack a bunch of times and see if that solves it.
arse_sidewards is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 08:01 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2023, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2023 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.