Welcome to the North American Subaru Impreza Owners Club Saturday December 14, 2019
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 11-14-2019, 07:37 AM   #1
Chuma87
Scooby Newbie
 
Member#: 470383
Join Date: Jul 2017
Chapter/Region: International
Location: Argentina
Vehicle:
2002 Forester S-Turb
Grey

Default CEL diagnostic mode Problem?

Hello boys.

I have the following problem ... I did TGV delete, I canceled the two sensors and the two motors, obviously the check engine starts. The funny thing is that if I want to do self-diagnosis, with the green chips connected, the light flashes intermittently, without any pattern. So, I disconnect the MAF sensor to test the self-diagnosis ... all the same, without a blink pattern, so I can't know the error code. I also tried to jump the white connector, without any results.
The ECU is not burned, nor has anything weird, and not blocked.

Forester S-Turbo (SF5) MY 2002 EJ205 (Same engine BUGEYE, not swap and anything)
ECU ID A4SE700J (Forester S-Turbo 2002 SADM)

Anyone who knows?
* Registered users of the site do not see these ads.
Chuma87 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-14-2019, 05:07 PM   #2
sig
Scooby Newbie
 
Member#: 318247
Join Date: Apr 2012
Default

how are you planning on reflashing your ecu to not throw the codes that are attributed to the TGV delete? you need an opensource tuning connector whether its a tactrix or cobb and a program like romraider/ecuflash or a OBD reader to be able to diagnose whats going on, not by some random flashing pattern on the CEL. I think most people get tunes when they do the tgv deletion to get the most out of it which is something like 5 hp lol.

P2004, P2006, P2007, P2009, P2012, P2016, P2017, P2021 and P2022 these are the codes associated with the TGV delete mod that I found through a google search

Last edited by sig; 11-14-2019 at 05:17 PM.
sig is offline   Reply With Quote
Old 11-16-2019, 09:59 AM   #3
Chuma87
Scooby Newbie
 
Member#: 470383
Join Date: Jul 2017
Chapter/Region: International
Location: Argentina
Vehicle:
2002 Forester S-Turb
Grey

Default

When removing the TGV, it is necessary to make tuning. That is why I want to use ECUflash, but it does not connect me and I think it is because my Forester does not enter test mode. That's why I try to disconnect the MAF to see what to do. Other cars have self-diagnosis, this one should have it too, and it doesn't work.
Chuma87 is offline   Reply With Quote
Old 11-16-2019, 07:53 PM   #4
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 RAV4 MT
15 WRX/05 GTO

Default

This may or may not apply since you're outside the US and North America and I don't know if your cars are OBDII compliant, but over here all OBDII Subarus since 1996 do NOT have a self-diagnostic mode to flash out codes through the check engine light. To read trouble codes you need an OBDII scanner or Subaru Monitor device (what the dealers use) connected to the OBDII port under the dash, with the ECU NOT in test mode (green and white plugs disconnected).
Mulder is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 04:05 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.