Welcome to the North American Subaru Impreza Owners Club Sunday May 29, 2022
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 01-03-2022, 04:53 PM   #1
Ajokansas
Scooby Newbie
 
Member#: 468937
Join Date: Jun 2017
Location: KC Metro
Vehicle:
2002 WRX
Subaru Blue

Default 2009 WRX 5 Speed dog box transmission Issues

Hello All,

I have a little dilemma with my transmission.

I have a 2002 WRX with a 2.5 hybrid, big turbo, and a modified 2009 WRX 5 Speed dog box transmission. The unit was originally built by Andrewtech Automotive in Maryland. A few months back, I blew the rear diff and had a local company clean it up, replace the diff and other parts. He told me they took the transmission apart to remove the metal fragments and to clean everything. He said they did not disassemble either of the shafts, they just needed to be cleaned up and the trany reassembled. After getting it reinstalled a couple of months later, we drove it around town and it seemed to work fine. We didn't notice until we got out on the highway recently, that it would not go into 5th gear. It doesn't grind or make any noise when trying to get it into 5th, just seems like something is blocking it. It will go into 5th when the car is not running and it will go into reverse perfectly fine all the time. It seems to shift everywhere fine except for 5th. All of the linkage is the same and installed correctly (I have had it out many times). It ran amazingly well for a year and a half before this problem.

I would take it back to the guy who worked on it, but since I was away at school and didn't get it reinstalled quickly, the guy who worked on it won't honor the 30-day warranty for his labor.

I have reached out to Andrew Tech, they responded, but would not answer any direct questions. I have also reached out to a local company, Modified by KC, followed their instructions to get my car looked at, and have had no response, even after many follow-up calls.

Any ideas of what to do would be greatly appreciated.

Thank you,

Andrew
* Registered users of the site do not see these ads.
Ajokansas is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-04-2022, 07:26 PM   #2
Unabomber
👏 Big Ron 👏
Moderator
 
Member#: 18062
Join Date: Apr 2002
Chapter/Region: MAIC
Location: I can save you a ton of cash
Vehicle:
on car parts so PM
me b4 j00 buy

Default

The man who build your box is at https://www.facebook.com/AndrewYatesAutomotive and his name is Andrew. Holler at him, maybe he'll holler back.
Unabomber is offline   Reply With Quote
Old 01-04-2022, 07:32 PM   #3
K3rm1tth3fr0g
Scooby Specialist
 
Member#: 508105
Join Date: Nov 2019
Chapter/Region: NWIC
Location: Greater Seattle Area
Vehicle:
Link tuned 02 WRX
EJ205 20G-XTR JDM 6MT E85

Default

That's worth a bad review for the first shop forsure
K3rm1tth3fr0g is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 04:33 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2022, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2022 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.