Welcome to the North American Subaru Impreza Owners Club Sunday February 25, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Baja Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 11-19-2006, 05:58 PM   #1
canuck37
Scooby Newbie
 
Member#: 87491
Join Date: May 2005
Chapter/Region: International
Location: Seattle, WA
Vehicle:
03 Sport
Blk/Slvr

Unhappy Trailer harness - frustration level HIGH!

OK, so I finally am getting around to wiring up the trailer lights on my 2003 Sport, after installing the hitch some time back. I figured why mess around with after market generic harness and went with Subaru OEM Part #L1010SS030, which is what several on-line part suppliers assured was the right harness for this year/model. It was way expensive, but then I thought it was worth the extra $$ to avoid the hassles.

When I got it last week, it came with a half dozen instruction sheets (none of which said it was for a Baja) including the following: 2005 and later Outback, 2003 and newer Forester; 2002 and later Impreza; 2005 Legacy;and 2002 and later Forester and Legacy Outback models. I thought this a bit odd, but then it was the right part # and so.....

Anyway, after fiddling around for awhile today underneath the Baja and finally figuring out how to get the plastic blank "plug" out of the vehicle end of the harness, I discovered that there is no way the male plug on the trailer harness will fit into the female plug on the vehicle harness.

Has anyone else used this harness successfully on their unit? I am wondering what's up, since the suppliers assure it is the correct harness. There is just no way for it to work.

If anyone has used OEM harness for their 03 (or even later) can you advise me the correct part # to request when I call these guys in the AM tomorrow and complain?!

Geez, life was a lot simpler 25 years ago......at least I think I remember it like that...........

Thanks,
Fraser
* Registered users of the site do not see these ads.
canuck37 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-19-2006, 06:33 PM   #2
su-be3
Scooby Newbie
 
Member#: 78702
Join Date: Jan 2005
Location: Waterford, NY
Vehicle:
2017 Impreza Premium
Island Blue Pearl

Cool

I can't help with the part number, but when I installed the trailer hitch on my Baja, the wiring harness came with it. No problems installing the wiring or the hitch.
My Baja is a 2004, but I doubt that there is any major differences for the wiring. Good luck, and I hope you can get a better answer than mine.
Keep it under 90, folks!
su-be3 is offline   Reply With Quote
Old 11-19-2006, 10:34 PM   #3
bajawes
Scooby Newbie
 
Member#: 128015
Join Date: Oct 2006
Chapter/Region: South East
Location: VA
Vehicle:
03 baja
yellow

Default

the guy i dealt with in florida pulled up the schematics for me and i just used a harness i bought at uhaul. had the schematic so, no problems. you may want to try that. but if you paid the extra to get the correct stock one, i'd be on the phone and not in a good mood!
wes
bajawes is offline   Reply With Quote
Old 11-19-2006, 10:51 PM   #4
subeman90
Scooby Specialist
 
Member#: 65681
Join Date: Jul 2004
Chapter/Region: MAIC
Location: Akron PA
Vehicle:
13 XV Limited
gray

Default

my plug was on the pass side behind the rear wheel in a kinda odd location. Is this the plug you found?

I got all my stuff BTW with the hitch
subeman90 is offline   Reply With Quote
Old 11-20-2006, 10:33 PM   #5
bajawes
Scooby Newbie
 
Member#: 128015
Join Date: Oct 2006
Chapter/Region: South East
Location: VA
Vehicle:
03 baja
yellow

Default

yeah, the passenger side slightly in front the tire(spare) against the far side. i was able to have the wiring dagram of the vehicle, and just wired it using that. i have the wiring schematics at home. i'll try and remember to bring them tomorrow. well get this nipped!
bajawes is offline   Reply With Quote
Old 11-24-2006, 12:19 PM   #6
wrenchwoman
Scooby Newbie
 
Member#: 126445
Join Date: Sep 2006
Location: Rixeyville, Virginia
Vehicle:
2004 Turbo Baja
Obsidian Black/Gray

Default

<<I figured why mess around with after market generic harness and went with Subaru OEM Part #L1010SS030>>

That's not the part # I ordered. I got L1010LS210 and everything plugged right in. Wherever you got yours, just ask if they have the part # I just gave you, otherwise I'd go to the dealer and order it.

Last edited by wrenchwoman; 11-24-2006 at 12:20 PM. Reason: left something out
wrenchwoman is offline   Reply With Quote
Old 11-26-2006, 03:11 PM   #7
canuck37
Scooby Newbie
 
Member#: 87491
Join Date: May 2005
Chapter/Region: International
Location: Seattle, WA
Vehicle:
03 Sport
Blk/Slvr

Default Update.......

The supplier (which turns out to be dealer connected somehow...) is being really helpful sorting this out. Turns out that the VIN is required to determine the correct harness, regardless of year. Even within model years they can vary apparently. Anyway, they have ordered the correct one (hopefully) and will be sending it out next week with a pre-paid return slip for the original one.

Lesson learned: do your own research up front and don't depend on info from web sites......


Quote:
Originally Posted by wrenchwoman View Post
<<I figured why mess around with after market generic harness and went with Subaru OEM Part #L1010SS030>>

That's not the part # I ordered. I got L1010LS210 and everything plugged right in. Wherever you got yours, just ask if they have the part # I just gave you, otherwise I'd go to the dealer and order it.
canuck37 is offline   Reply With Quote
Old 12-09-2006, 10:27 PM   #8
canuck37
Scooby Newbie
 
Member#: 87491
Join Date: May 2005
Chapter/Region: International
Location: Seattle, WA
Vehicle:
03 Sport
Blk/Slvr

Default Harness update

Quote:
Originally Posted by wrenchwoman View Post
<<I figured why mess around with after market generic harness and went with Subaru OEM Part #L1010SS030>>

That's not the part # I ordered. I got L1010LS210 and everything plugged right in. Wherever you got yours, just ask if they have the part # I just gave you, otherwise I'd go to the dealer and order it.
Well, after a couple of weeks of going back and forth with the distributor, they finally got me the right harness. For future reference, if anyone wants to find one for an '03, it turns out to be the same part # as noted above (#L1010LS210). Plugged right in and works perfectly.

Only wrinkle is that the metal bracket and bolt that attaches the module to the frame was not included (instructions said it should be), so I am trying to get them to respond now and send it to me so I can do it right. At the moment it is tie-wrapped to the hitch, but I want it done right. So far they are ignoring my requests... Oh, well...........
canuck37 is offline   Reply With Quote
Old 12-10-2006, 10:01 AM   #9
wrenchwoman
Scooby Newbie
 
Member#: 126445
Join Date: Sep 2006
Location: Rixeyville, Virginia
Vehicle:
2004 Turbo Baja
Obsidian Black/Gray

Default

Quote:
Originally Posted by canuck37 View Post
Well, after a couple of weeks of going back and forth with the distributor, they finally got me the right harness. For future reference, if anyone wants to find one for an '03, it turns out to be the same part # as noted above (#L1010LS210). Plugged right in and works perfectly.

Only wrinkle is that the metal bracket and bolt that attaches the module to the frame was not included (instructions said it should be), so I am trying to get them to respond now and send it to me so I can do it right. At the moment it is tie-wrapped to the hitch, but I want it done right. So far they are ignoring my requests... Oh, well...........
Mine didn't come with a bracket either. I just made an "Z" bracket out of aluminum about 3 inches wide. Actually, I think it was an "Z" shaped bracket--it was a couple months ago and I forgot already. I'll have to look again. I'll take a pic and you can see and probably make one yourself.

Last edited by wrenchwoman; 12-10-2006 at 10:10 AM.
wrenchwoman is offline   Reply With Quote
Old 12-10-2006, 10:12 AM   #10
wrenchwoman
Scooby Newbie
 
Member#: 126445
Join Date: Sep 2006
Location: Rixeyville, Virginia
Vehicle:
2004 Turbo Baja
Obsidian Black/Gray

Default

Here's a picture of what I used. It was a bracket I had made to use on my MC to hold my MP3 player, but it just happened to work out perfectly for this, too.

wrenchwoman is offline   Reply With Quote
Old 12-10-2006, 02:07 PM   #11
canuck37
Scooby Newbie
 
Member#: 87491
Join Date: May 2005
Chapter/Region: International
Location: Seattle, WA
Vehicle:
03 Sport
Blk/Slvr

Thumbs up Gracias!

[quote=wrenchwoman;16272759]Here's a picture of what I used. It was a bracket I had made to use on my MC to hold my MP3 player, but it just happened to work out perfectly for this, too.

[/QUOTE

I guess that this must be a common deal then - I just thought it was me that got shortchanged. Wonder why the instructions say it's included when apparently it must be yet another "special" order deal.....
Ah, well, I will get to making something up once the rain stops! Thanks muchly, WW!
canuck37 is offline   Reply With Quote
Old 12-11-2006, 11:55 AM   #12
wrenchwoman
Scooby Newbie
 
Member#: 126445
Join Date: Sep 2006
Location: Rixeyville, Virginia
Vehicle:
2004 Turbo Baja
Obsidian Black/Gray

Default

I guess that this must be a common deal then - I just thought it was me that got shortchanged. Wonder why the instructions say it's included when apparently it must be yet another "special" order deal.....
Ah, well, I will get to making something up once the rain stops! Thanks muchly, WW![/quote]

I was under the impression when I read the instructions that the Baja should have been equiped with the bracket, but I really don't remember. But I really wish I had bought the OEM trailer hitch. I went to uhaul and again was under the impression that there would be no drilling required. I don't think the stock hitch requires drilling. They drilled something in, which you can see the bit shiny bolts in the picture. If I recall, the manual says something to the effect about not having a hitch that's drilled to the bumper for some reason. I can't remember if it's a safety thing, or a structural thing or what. Oh well, it's done now.
wrenchwoman is offline   Reply With Quote
Old 12-11-2006, 12:55 PM   #13
downhilbil
Scooby Newbie
 
Member#: 74675
Join Date: Nov 2004
Location: Las Vegas
Vehicle:
2005 subaru BAJA T
blue

Default

Mine is the OEM one and had everything. It should of been in the package with the wiring, thats how mine came. As well as the instructions to mount it. it isn't a real substantial piece so if you diddnt get it, it would prob be good secured with zip ties.
downhilbil is offline   Reply With Quote
Old 01-03-2017, 12:31 AM   #14
Bio_Baja
Scooby Newbie
 
Member#: 209088
Join Date: Apr 2009
Location: Sacramento, CA
Vehicle:
2003 Baja
Silver

Default Installation Instructions

Do any of you still have the installation instructions? I'm trying to create a go-to file of all of the accessories for future use. I have the one that came with mine (used) and the previous owner sent inside plastic bag with all the greasy bolts.

Thanks!

Carlos
Bio_Baja is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Street tuner and frustration levels 03WRX83 Engine Management & Tuning 8 03-10-2005 02:38 PM
WTB: EDM harness for leveling switch AND switch 1stgearsyncro Private 'Wanted' Classifieds 1 01-25-2004 04:00 PM
Trailer Harness Buellboy Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 11-10-2002 12:43 PM
('93-'01) trailer harness plug on Imp. wagon? avk Impreza Forum 0 10-13-2002 10:55 PM
trailer harness question avk Legacy Forum 2 05-02-2002 09:27 AM

All times are GMT -4. The time now is 10:01 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.