Welcome to the North American Subaru Impreza Owners Club Saturday February 22, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 01-27-2019, 11:48 PM   #1
Zachs02wrx
Scooby Newbie
 
Member#: 497003
Join Date: Jan 2019
Default JDM EJ205 Swap Issue

Ill try to make this short and sweet. Hopefully somebody out there can give me a good idea as to if i need a tune or if i have a drive ability issue.

STORY:
bought an 02 wrx with a popped engine for a steal of a deal

picked out my JDM EJ205 to swap and ordered one of these http://www.jdmflorida.com/index.php?...&product_id=79

I swapped everything
- intake manifold
- cam/crank gears
- cam/crank sensors
- knock sensor
- oil cooler, coolant crossover, intercooler brackets... etc (this part goes on and not important for driveability)

I got the engine in and the car started up and all went just fine until I began to get into boost. around 3,000RPM and 5-7PSI of boost, i get major hesitation until the engine feels to "catch" itself and then it builds up to 15PSI and pulls hard and fast.

I cannot figure out why i am having such issues with hesitation and cutting out.

I am worried that maybe this engine has a different compression ratio and i am leaning out? Any help would be great... im really at a loss of what this could be
Zachs02wrx is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 12:58 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.