Welcome to the North American Subaru Impreza Owners Club Monday February 17, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 11-01-2004, 12:32 PM   #1
metbluWRX
Scooby Newbie
 
Member#: 52760
Join Date: Jan 2004
Location: Allentown, PA
Vehicle:
02' Impreza wrx
black/blue mica

Default HELP PLEASE! shuttery car...

ok well heres the deal, on my car i have stock everything except IC hoses....now i WAS running a bov and catback, but decided stock was my best bet...well as some of u might have read in my earlier post, my Turbo inlet hose broke off at the connection where u clamp on the recirc. hose. I epoxyed it for a temp repair (its a daily driver) until my new TI comes in the mail. Well lately my car hasnt been running that great, i mean its sloppy when shifting and from my standards, is running like ****...do u guys think its because of my TI being busted??? am i loosing boost through that? also, i lost 2 bolts that bolt down those metal pipes onto the front of the IC and now its just hanging there w/ 1 bolt...am i loosing boost throught that too>>> let me know...alll comments are accpeciated, except the ones that call me a complete idiot, and yes i already know that lol, thanks guys, BRIAN
* Registered users of the site do not see these ads.
metbluWRX is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-01-2004, 02:10 PM   #2
zaxrex
Scooby Specialist
 
Member#: 9898
Join Date: Sep 2001
Chapter/Region: MAIC
Location: VA near MD
Vehicle:
2002 WRX
Water Injected Blue

Default

Well, not having bolts holding the bypass lines on the IC won't make you loose boost, but not having is firmly secured could cause the hoses to creep back and loose their seal.

I would take it and get an OBD-IIscan to see if there are any stored DTC that could point you in the right direction. Other than that it is pure speculation.
zaxrex is offline   Reply With Quote
Old 11-01-2004, 06:18 PM   #3
rugbywrx03
Scooby Newbie
 
Member#: 57703
Join Date: Mar 2004
Chapter/Region: SWIC
Location: Albuquerque
Vehicle:
08 STi
Aspen White

Default

reset the ecu yet?
rugbywrx03 is offline   Reply With Quote
Old 11-01-2004, 06:36 PM   #4
thetikler1
Scooby Specialist
 
Member#: 24096
Join Date: Sep 2002
Chapter/Region: MWSOC
Location: omaha nebraska
Vehicle:
2015 STi
Red/white

Default

well if he has boost escaping the non clamped down lines then the car will run like ****. i would bet money it is the hoses. My buddies Sti blew its INtercooler-TB hose and he would get extreme shutter and dark super rich exhaust smoke.
thetikler1 is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need some help please cel plus more!!!! thrasher679 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 1 06-04-2010 10:21 AM
Help please need in car video of Road Atlanta!! rsr911 Mid West Subaru Owners Club Forum -- MWSOC 2 07-05-2002 08:38 PM
HELP PLEASE - car injury Bauhaus Mid West Subaru Owners Club Forum -- MWSOC 12 02-28-2002 01:40 AM
Need help on choosing car for me...please help! CyberLogic General Forum Archive 3 01-26-2001 10:18 AM
please help me out, car hurt and need some q's answered on aftermarket parts 98mpreziveRS Technical Forum Archive 4 08-03-2000 06:50 PM

All times are GMT -4. The time now is 02:56 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.