Welcome to the North American Subaru Impreza Owners Club Monday November 12, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > FB Series Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 01-04-2018, 09:14 PM   #1
Doug71as
Scooby Newbie
 
Member#: 462129
Join Date: Jan 2017
Default Acceleration stumbling?

2017 Impreza 5MT having issues with full throttle acceleration from 2,000-6,200 rpms. Random stumbling on partial and full throttle. Less than 10,000 Miles. 3 updates done on ECM. Any thoughts?
* Registered users of the site do not see these ads.
Doug71as is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 05-30-2018, 05:33 PM   #2
Sailorman240
Scooby Newbie
 
Member#: 486600
Join Date: May 2018
Chapter/Region: MAIC
Location: Upstate NY
Vehicle:
2017 Impreza Sport
Island Blue

Default

I too have a 2017 Impreza 5MT with a stumbling during light to full throttle acceleration. Engine has virtually no power while stumbling is occurring. Going up a moderate hill the car actually slows down. Mine occurs between 1900 and 2800 rpm, only when ambient temperature is above 50 degrees F. About 13000 miles on my car. Happens about 75% of the time. Runs flawlessly in the winter. Computer shows no codes. Dealer can not find any cause. Had car for 3 days.
Sailorman240 is offline   Reply With Quote
Old 05-31-2018, 11:25 AM   #3
CFM56
Scooby Newbie
 
Member#: 460834
Join Date: Jan 2017
Chapter/Region: NWIC
Location: Northwest
Vehicle:
2011 STi
Dark Blue

Default

No torque coupled with the AC compressor cycling every now and then does that, its normal, my wrx did that and so does my STi.
CFM56 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 10:12 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.