Welcome to the North American Subaru Impreza Owners Club Wednesday July 8, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 08-03-2005, 06:20 AM   #1
RexSex
Scooby Newbie
 
Member#: 79088
Join Date: Jan 2005
Chapter/Region: W. Canada
Location: Edmonton, Canada
Vehicle:
2004 300hp WRX
Silver

Default Odd sound under high boost

Alright, I seriously did a lot of research on this site, so plz don't tell me this is a repost. I can't find anything that discusses my specific problem.

Basically, I have a boost controller on my 04 WRX. On low, it is at 6psi, and on high it is at about 16-16.5psi. I only ever use high if I need to launch through a busy intersection, pass someone at lower or higher speeds, or race someone at a traffic light. Other than those times, I am always on low. This is mainly out of precaution and hoping to save some gas as well.

Note: Im still a noob when it comes to performance modding. Taking it a little at a time.

So, the problem is that when I set the boost controller to high and floor it, the engine makes a sort of ticking sound, but as I said ONLY when I am flooring it and reaching around 4000-5000rpm. It is a faster ticking, that gets a little faster the harder I push the car.

The sound never happens on low boost setting no matter how hard I push the car, and never happened with stock boost settings before installing the boost controller, and never happens when decelerating, nor when accelerating normally...just to be clear.

I am going to take it in to my friend's shop in the coming few days, but for now I was wondering if anyone had any insight to what the problem may be, if any.

It could be nothing, but just in case. Thnx.

Thnx.
* Registered users of the site do not see these ads.
RexSex is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-03-2005, 07:55 AM   #2
BamBooI
Scooby Specialist
 
Member#: 10945
Join Date: Oct 2001
Chapter/Region: South East
Location: SC
Vehicle:
2006 Evolution IX

Default

detonation?
BamBooI is offline   Reply With Quote
Old 08-03-2005, 08:23 AM   #3
23b_Rex
Scooby Specialist
 
Member#: 79394
Join Date: Jan 2005
Location: reston
Vehicle:
02 gda
wrb

Default

it's the wastegate ticking

is this a mbc?
23b_Rex is offline   Reply With Quote
Old 08-03-2005, 08:46 AM   #4
-Kevlar-
Scooby Specialist
 
Member#: 82378
Join Date: Mar 2005
Chapter/Region: South East
Vehicle:
<--- Hot Donuts Now

Default

Quote:
Originally Posted by RexSex
Basically, I have a boost controller on my 04 WRX. On low, it is at 6psi, and on high it is at about 16-16.5psi. I only ever use high if I need to launch through a busy intersection, pass someone at lower or higher speeds, or race someone at a traffic light. Other than those times, I am always on low. This is mainly out of precaution and hoping to save some gas as well.

Note: Im still a noob when it comes to performance modding. Taking it a little at a time.

Thnx.

this entire paragraph scares me.....
-Kevlar- is offline   Reply With Quote
Old 08-03-2005, 09:13 AM   #5
RexSex
Scooby Newbie
 
Member#: 79088
Join Date: Jan 2005
Chapter/Region: W. Canada
Location: Edmonton, Canada
Vehicle:
2004 300hp WRX
Silver

Default

Yes its a manual boost controller. Is the ticking ok? And why does the paragraph scare you? lol...let me know if Im doing something too dangerous. Thnx.
RexSex is offline   Reply With Quote
Old 08-03-2005, 09:25 AM   #6
Bundyboyz
Scooby Specialist
 
Member#: 32764
Join Date: Feb 2003
Chapter/Region: MAIC
Vehicle:
2003 WRX with 91K
New Motor & Paint WRB

Default

launch through a busy intersection

I'd like to hear the answer to the ticking
Bundyboyz is offline   Reply With Quote
Old 08-03-2005, 09:39 AM   #7
JeffrWRX
Scooby Specialist
 
Member#: 48589
Join Date: Nov 2003
Chapter/Region: SCIC
Location: San Marcos, CA
Vehicle:
2016 WRX 6mt CWP
@thejeffruhl 387hp/350tq

Default

sounds like detonation. Isnt a MBC on an 04 bad juju?
JeffrWRX is offline   Reply With Quote
Old 08-03-2005, 04:26 PM   #8
RexSex
Scooby Newbie
 
Member#: 79088
Join Date: Jan 2005
Chapter/Region: W. Canada
Location: Edmonton, Canada
Vehicle:
2004 300hp WRX
Silver

Default

Anyone else have any feedback? Im getting worried...
RexSex is offline   Reply With Quote
Old 08-03-2005, 04:39 PM   #9
RexSex
Scooby Newbie
 
Member#: 79088
Join Date: Jan 2005
Chapter/Region: W. Canada
Location: Edmonton, Canada
Vehicle:
2004 300hp WRX
Silver

Default

Just spoke to Andy at Neetronics. He thinks it's detonation too. lol...WHEW...Im glad I found out about this sooner than later. I'm such a noob.
RexSex is offline   Reply With Quote
Old 08-03-2005, 07:13 PM   #10
23b_Rex
Scooby Specialist
 
Member#: 79394
Join Date: Jan 2005
Location: reston
Vehicle:
02 gda
wrb

Default

take the mbc off RIGHT NOW! detonation = bad... the 04/05s have a delay when switching from open loop to closed loop fueling... mbcs cause part throttle full boost.... ptfb + ol/cl delay = kab00m! if you don't take it off, you're going to blow your s**t up... seriously
23b_Rex is offline   Reply With Quote
Old 08-03-2005, 07:25 PM   #11
IronMedic
Scooby Newbie
 
Member#: 82122
Join Date: Feb 2005
Location: Puyallup, WA
Vehicle:
2005 WRX Premium
Blue

Default

if u want a MBC, use a UTEC to help it. i didnt have my ABC so i had to get a HPMBC from turboXS to use with my UTEC. works great and im running 14.5 psi of boost for now with my stage 2
IronMedic is offline   Reply With Quote
Old 08-03-2005, 10:11 PM   #12
RexSex
Scooby Newbie
 
Member#: 79088
Join Date: Jan 2005
Chapter/Region: W. Canada
Location: Edmonton, Canada
Vehicle:
2004 300hp WRX
Silver

Default

Alright, I set the MCB low to 6psi and the high to about 14psi (down from 16.5psi). Is this ok? Or should I take it off completely? Is even the 6psi ok or is the whole MCB a problem for the 04?

My mechanic said that I didn't do any serious damage, since if I did it would all be over right now. That is a relief. Im planning on getting the ECU tuned, but that is not for another month or two.

Plz let me know if even the 6psi is ok. Thnx.
RexSex is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Severe stuttering under high boost linsavy Pre-2002 Factory Turbo Powertrain 66 04-01-2020 03:00 PM
"creaking" or fluttering noise under high boost/throttle...?? vokalize770 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 7 04-06-2008 03:38 PM
Clutch slips under high boost gatts Transmission (AT/MT) & Driveline 6 03-19-2007 08:20 PM
Whistling sound at high boost STI8U Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 21 04-02-2005 05:44 AM
Annoying Two Stroke Sound under high boost SpooledRex Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 10 04-18-2002 09:30 PM

All times are GMT -4. The time now is 03:23 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.