Welcome to the North American Subaru Impreza Owners Club Friday September 24, 2021
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 07-09-2021, 01:48 AM   #1
JrodKC
Scooby Newbie
 
Member#: 518191
Join Date: Aug 2020
Chapter/Region: MWSOC
Vehicle:
2009 Legacy 2.5i
Gray

Default New rotor groove

Did brakes a week ago, pads and rotors on the front end. Havenít driven but a couple hundred miles I was inspecting them this evening when I got home. The passenger side in the middle of the rotor had a groove going all the way around already. First thing I thought how could debris just get in there so quick thatís my luck or could it possibly be the bracket needs to be pushed outward more. It was too late to rip it apart so Iím gonna look at it in the morning. You guys had any issues like this before or any ideas what the cause could be please let me know thanks have a good one.
* Registered users of the site do not see these ads.
JrodKC is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-17-2021, 09:33 PM   #2
Patrick Olsen
Scooby Guru
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
1996 Impreza coupe

Default

Could be debris got caught in there. Or I've had what seemed to be a "hard spot" in the brake pad material itself that caused a groove. I don't recall what I did about it, this was years and years ago.
Patrick Olsen is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 11:19 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.