Welcome to the North American Subaru Impreza Owners Club Monday July 22, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 03-17-2019, 02:46 AM   #1
Ranvier
Scooby Newbie
 
Member#: 499178
Join Date: Mar 2019
Default I'm New!

Hey guys!

I'm new to the forums and I just traded my Big Money Waste for an amazing 19' XV Limited.

I haven't hit my 1k break in yet and will be posting questions and photos soon!

By the way, is there an Arkansas chapter? I'm located in Little Rock.

Thanks!
* Registered users of the site do not see these ads.
Ranvier is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 03-17-2019, 11:52 AM   #2
cluster5
Scooby Newbie
 
Member#: 499184
Join Date: Mar 2019
Chapter/Region: E. Canada
Location: Québec
Default

Hi there. How are you liking it so far? Did you get it manual? I'm looking to buy my first Subaru, a Crosstrek like you.
cluster5 is offline   Reply With Quote
Old 03-17-2019, 03:48 PM   #3
Ranvier
Scooby Newbie
 
Member#: 499178
Join Date: Mar 2019
Default

Quote:
Originally Posted by cluster5 View Post
Hi there. How are you liking it so far? Did you get it manual? I'm looking to buy my first Subaru, a Crosstrek like you.
I love it so far, the main complaints I read about is the low power. I came from a 300hp BMW and I thought I would be disappointed in the Crosstrek, but it surprised me and it feels snappy and strong.

I went with the automatic because I haven't driven manual in years and didn't want to relearn on a new car. It does have the paddle shifters to mimick a manual but I haven't used it yet

The cabin space is comfortable with plenty of leg room. The trunk is a good size too I was able to load it up with a few medium sized suitcases and backpacks and still have room for more.

It's easier on gas, I filled up with premium for about $35. Gas mileage is accurate to the specs. It's very smooth and quiet, smoother and quieter than the BMW.

I would recommend test driving both transmissions and sitting in one with cloth seats and one with leather.

So far I'm happy with it. I installed the apps and paired my phone up. I ran into a few issues with the apps which sorted themselves out or just required some work around to get them working.

The eyesight equipment is pretty incredible and works really well, I got the 8" screen and it is worth it.

I have Harmon kardon option and that's probably the only thing I wish was a bit better, although it may just take some getting used to and proper setup.

I'll try to post some pictures when I get off work tonight. If you have any questions, feel free to ask!
Ranvier is offline   Reply With Quote
Old 03-24-2019, 12:37 PM   #4
cluster5
Scooby Newbie
 
Member#: 499184
Join Date: Mar 2019
Chapter/Region: E. Canada
Location: Québec
Default

Back in september, I tried the manual. What I liked the most was the soft suspension. Going over a rail road crossing, I thought, "Yep, I like that". Lots of roads here are not well maintain and I go to a locations where ground clearance can be an issue. Not to mention the snow...

I found it much slower and less stable on the highway than what I drive at the moment. The fuel economy is another point which seems to favor the Sonata. Anyways, my whole point of wanting to change car was to move a bit away from a boring appliance. For that, absolutely, the Crosstrek is more engaging

So, I ordered a 2019 Crosstrek Touring 6MT yesterday. There's an 8-12 weeks wait.

My only fear atm is the reliability and warranty. The closest dealer to my place is not really good. The one where I ordered the car is 50Km away and it takes an little over an hour to get there. Also, 2 of my friends who have Subbies have had several problems (bearing, rear brakes and AC failling 3x).

Last edited by cluster5; 03-24-2019 at 12:42 PM.
cluster5 is offline   Reply With Quote
Old 03-24-2019, 07:58 PM   #5
Jakez104
Scooby Newbie
 
Member#: 499488
Join Date: Mar 2019
Default 2008 subaru impreza exhuast

hi, i got my subie just over a year ago and i have had a weird noise coming from my exhaust every time i hit the accelerator. i think i might have an idea of what it is and i also have a solution to the noise. my solution is too clear out my cat so its basically like a straight pipe. buuuuut.... my car is going to throw a code for a bad 02 sensor, does anybody know a way around that.
Jakez104 is offline   Reply With Quote
Old 03-24-2019, 08:17 PM   #6
Blackop555
Scooby Newbie
 
Member#: 499506
Join Date: Mar 2019
Default

Hello. New here as well. Great source of information
Blackop555 is offline   Reply With Quote
Old 03-25-2019, 04:20 AM   #7
Harry13wrx
Scooby Newbie
 
Member#: 499524
Join Date: Mar 2019
Chapter/Region: SCIC
Location: North Hollywood
Vehicle:
2013 Impreza wrx
Grey

Default Please help me out

Hi I’m new to the Subaru scene, but I just recently picked up a 2013 wrx premium from a used car dealer. Car is stock and never modified from what they say and has 91k on the odometer. The first drive from the dealer home it was perfect up until i down shifted into third and started to accelerate. All was going normal till I was about to go into 4th gear, the car suddenly loss almost what seemed like all power for a split second and went away and I continued normally. When I looked at my dash again a split second later, my cel was on along with the what I think is the traction light and the cruise light is blinking. Can anyone explain to me what this could be by? I didn’t mis shift or anything it happened the first time While accelerating hard in 3rd gear. And has done the same thing in almost any gear at hard acceleration. But doesn’t happen all the time it’s random. Please help me out. I’m taking it into the dealer tomorrow for inspection
Harry13wrx is offline   Reply With Quote
Old 03-26-2019, 11:49 PM   #8
learningthewrx
Scooby Newbie
 
Member#: 443128
Join Date: Mar 2016
Default

Welcome to the community!
learningthewrx is offline   Reply With Quote
Old 03-27-2019, 11:00 AM   #9
eteran4
Scooby Newbie
 
Member#: 499642
Join Date: Mar 2019
Default

Im new here too! Welcome
eteran4 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 09:24 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.