Welcome to the North American Subaru Impreza Owners Club Sunday October 20, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 07-05-2019, 01:32 PM   #1
alexise88
Scooby Newbie
 
Member#: 496777
Join Date: Jan 2019
Location: Walla Walla, WA
Vehicle:
2011 Impreza WRX STI
Blue

Default Passenger window wonít work

My passenger window on the driver side of my 2011 sti wonít work with the passenger controls. If I use the driver controls the passenger window will go up and down. Does anyone have any solutions to this?

Thank you.
* Registered users of the site do not see these ads.
alexise88 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 07-05-2019, 01:52 PM   #2
oichan
Scooby Specialist
 
Member#: 492327
Join Date: Oct 2018
Location: A garage in the Midwest
Vehicle:
2019 WRX / 16 STI
2017 Golf-R, etc

Default

Have you tried re-setting the switch? It's also possible the switch went bad from water/rain getting inside.
oichan is offline   Reply With Quote
Old 07-05-2019, 02:15 PM   #3
alexise88
Scooby Newbie
 
Member#: 496777
Join Date: Jan 2019
Location: Walla Walla, WA
Vehicle:
2011 Impreza WRX STI
Blue

Default

Quote:
Originally Posted by oichan View Post
Have you tried re-setting the switch? It's also possible the switch went bad from water/rain getting inside.


How do I reset the switch? Thanks.
alexise88 is offline   Reply With Quote
Old 07-05-2019, 02:18 PM   #4
oichan
Scooby Specialist
 
Member#: 492327
Join Date: Oct 2018
Location: A garage in the Midwest
Vehicle:
2019 WRX / 16 STI
2017 Golf-R, etc

Default

You would hit the down button and hold for several seconds, your window should roll down. (if not, hit the button in the up position and hold for 10 seconds).

Then once all the way down, hit the button in the up position and continue to hold after the window rolls all the way up for 5 seconds.

Try this on the passenger door control first and verify if it awakens your driver side passenger window switch.
oichan is offline   Reply With Quote
Old 07-05-2019, 04:15 PM   #5
alexise88
Scooby Newbie
 
Member#: 496777
Join Date: Jan 2019
Location: Walla Walla, WA
Vehicle:
2011 Impreza WRX STI
Blue

Default

Quote:
Originally Posted by oichan View Post
You would hit the down button and hold for several seconds, your window should roll down. (if not, hit the button in the up position and hold for 10 seconds).

Then once all the way down, hit the button in the up position and continue to hold after the window rolls all the way up for 5 seconds.

Try this on the passenger door control first and verify if it awakens your driver side passenger window switch.


So the window works when using the driver controls, itís when I use the passenger controls when the passenger window doesnít work.
alexise88 is offline   Reply With Quote
Old 07-05-2019, 06:37 PM   #6
Gallo2011
Scooby Guru
 
Member#: 268310
Join Date: Dec 2010
Chapter/Region: SCIC
Location: So Kali
Vehicle:
2011 SSM STI saloon
Church!

Default

Quote:
Originally Posted by alexise88 View Post
So the window works when using the driver controls, itís when I use the passenger controls when the passenger window doesnít work.
You can test what oichan has suggested using the passenger switch.
Gallo2011 is offline   Reply With Quote
Old 07-08-2019, 05:31 PM   #7
AliBenn
NASIOC Supporter
 
Member#: 487
Join Date: Nov 1999
Chapter/Region: TXIC
Location: Greatwood/Sgrlnd
Vehicle:
1998 /2005 STunIcorn
Acadia Green RS-T

Default

same thing happened to me after the vehicle was at a shop.

after some investigating
found that shop did not plug in the driver side control switch pigtail(connector) in all the way. (until the pigtail 'clicks')

did this and both sides worked correctly
AliBenn is offline   Reply With Quote
Old 07-10-2019, 07:39 PM   #8
Aallgire
Scooby Newbie
 
Member#: 489481
Join Date: Aug 2018
Location: Stryker Ohio
Vehicle:
2008 Impreza WRX STI
Lightning red

Default

My rear left was super slow. I found some corrosion, weak connection made it slow
Aallgire is offline   Reply With Quote
Old 07-25-2019, 11:32 PM   #9
Bikelok
Scooby Specialist
 
Member#: 254851
Join Date: Aug 2010
Chapter/Region: BAIC
Location: Nor-Cal Bay Area
Vehicle:
2002 WRX wagon 5mt
PSM

Default

This is for an older model but the principal is the same.

How to fix a window switch
http://forums.nasioc.com/forums/show...php?p=44430449
Bikelok is offline   Reply With Quote
Old 08-21-2019, 11:15 PM   #10
iDaHuy
Scooby Newbie
 
Member#: 505548
Join Date: Aug 2019
Default

Did you disconnect your battery? If so maybe you have to reset the window limit? Im probably reading your post wrong.
iDaHuy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 08:19 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.