Welcome to the North American Subaru Impreza Owners Club Monday August 10, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Open Source Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 04-26-2017, 05:52 PM   #276
mikeyPSF
Scooby Newbie
 
Member#: 236475
Join Date: Jan 2010
Chapter/Region: BAIC
Location: San Francisco
Vehicle:
2002 WRX
Black

Default

If those buttons are grayed out in EcuFlash, then EcuFlash isn't detecting the Openport. That problem is independent of the OBD2 port. You could be sitting inside your house far from the car with Openport only connected to the laptop via USB and you should see those buttons active.

What does it say in the lower right hand corner of EcuFlash? It should say "Openport 2.0 USB" but if it says "no vehicle interface" then you need to work on that. It could be an issue with the install of the Windows device driver or could be even simpler, a bad USB cable. If you have another mini-USB cable handy, try that first as it only takes a few seconds. If you need help troubleshooting the Windows device driver, just make sure you're using the current version of EcuFlash and if you are, then send me an email to support at tactrix . com

By the way, Java is needed by RomRaider but EcuFlash doesn't use it at all.

-Mike
Tactrix
* Registered users of the site do not see these ads.
mikeyPSF is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-29-2017, 09:52 PM   #277
Ghostdriver22
Scooby Newbie
 
Member#: 376197
Join Date: Dec 2013
Chapter/Region: SWIC
Location: Southwest
Vehicle:
2014 WRX
Pearl white

Default 1.3u communicating with laptop

Quote:
Originally Posted by mikeyPSF View Post
If those buttons are grayed out in EcuFlash, then EcuFlash isn't detecting the Openport. That problem is independent of the OBD2 port. You could be sitting inside your house far from the car with Openport only connected to the laptop via USB and you should see those buttons active.

What does it say in the lower right hand corner of EcuFlash? It should say "Openport 2.0 USB" but if it says "no vehicle interface" then you need to work on that. It could be an issue with the install of the Windows device driver or could be even simpler, a bad USB cable. If you have another mini-USB cable handy, try that first as it only takes a few seconds. If you need help troubleshooting the Windows device driver, just make sure you're using the current version of EcuFlash and if you are, then send me an email to support at tactrix . com

By the way, Java is needed by RomRaider but EcuFlash doesn't use it at all.

-Mike
Tactrix
--
--Thank you for reply, Mike! I sent an email to "[email protected]"

Bottom right of ecuflash displays [No vehicle selected] OpenPort 1.3 Universal
Ghostdriver22 is offline   Reply With Quote
Old 05-01-2017, 09:08 AM   #278
superevilkeith
Scooby Newbie
 
Member#: 455950
Join Date: Oct 2016
Location: MI, USA
Vehicle:
2005 OBXT L

Default

I'm just finishing up a build on an OBXT. I have a Tactrix open port 2.0. Can anyone refer some E tuners? I have been poking around and it seems everyone wants a COBB. I would like to avoid buying one if I can.
superevilkeith is offline   Reply With Quote
Old 05-01-2017, 11:51 AM   #279
mikeyPSF
Scooby Newbie
 
Member#: 236475
Join Date: Jan 2010
Chapter/Region: BAIC
Location: San Francisco
Vehicle:
2002 WRX
Black

Default

Quote:
Originally Posted by Ghostdriver22 View Post
--
--Thank you for reply, Mike! I sent an email to "[email protected]"
Sounds good. Monday are my busy days so it might not be until late today before I get back to you but I will.


Quote:
Originally Posted by superevilkeith View Post
I'm just finishing up a build on an OBXT. I have a Tactrix open port 2.0. Can anyone refer some E tuners? I have been poking around and it seems everyone wants a COBB. I would like to avoid buying one if I can.
I'm a little hesitant to weigh in here as there are just so many tuners to choose from but Cameron Dawes is a popular one that does e-tunes for what seems to be a really reasonable rate. camtuning.com

-Mike
Tactrix
mikeyPSF is offline   Reply With Quote
Old 05-17-2017, 12:58 PM   #280
Ghostdriver22
Scooby Newbie
 
Member#: 376197
Join Date: Dec 2013
Chapter/Region: SWIC
Location: Southwest
Vehicle:
2014 WRX
Pearl white

Default

Quote:
Originally Posted by mikeyPSF View Post
Sounds good. Monday are my busy days so it might not be until late today before I get back to you but I will.




I'm a little hesitant to weigh in here as there are just so many tuners to choose from but Cameron Dawes is a popular one that does e-tunes for what seems to be a really reasonable rate. camtuning.com

-Mike
Tactrix
Thanks Mike. Im all set now and have been experimenting with the tables. I have been previously tuned my Wingz in AZ when I owned an Evo8 and will probably stick with him or the folks over at STM tuned. Thanks again for your help!


-F
Ghost
Ghostdriver22 is offline   Reply With Quote
Old 08-15-2017, 10:50 PM   #281
Black94Snake
Scooby Specialist
 
Member#: 274499
Join Date: Feb 2011
Chapter/Region: NESIC
Location: RI
Vehicle:
1994 5.8T Cobra
755rwhp @ 16psi

Default

Quote:
Originally Posted by Ghostdriver22 View Post
Hi! Trying to get ecuflash to communicate with 06 wrx. Previous owner had removed obd2 from dash location, possibly to connect aftermarket system or tuner. I have some experianc using ecuflash and evoscan on previous car"evo8". Current problem is my ecuflash will not display the *read, write,test write to ecu. I have java, I have reloaded ecuflash, and I have tried different laptop. Anyone ready to kick my ecu in the toosh and help me pull the
Gonna bump this up, because I just had the same issue.

You need to go in the device manager and update the driver for the OP2.0. Windows assigns it as a "Vehicle Pass Through" and ECUFlash won't work with it.
You need to update the driver with the FTDIBUS driver in the ECUFlash folder. Once I did this, it was assigned as a comm port, and immediately worked.
Black94Snake is offline   Reply With Quote
Old 09-03-2017, 11:21 AM   #282
GioB18
Scooby Newbie
 
Member#: 456767
Join Date: Oct 2016
Default

Hi guys, have a question about the cable. To read/write ecu roms is it mandatory to use tactrix openport or any other obd cable will do the job?
GioB18 is offline   Reply With Quote
Old 09-03-2017, 11:23 AM   #283
Black94Snake
Scooby Specialist
 
Member#: 274499
Join Date: Feb 2011
Chapter/Region: NESIC
Location: RI
Vehicle:
1994 5.8T Cobra
755rwhp @ 16psi

Default

I managed with a $10 Vag-Com cable off eBay. Now I have the OP2.0.

It's a small price to pay, to ensure you actually get something that works right out of the box.
Black94Snake is offline   Reply With Quote
Old 09-03-2017, 12:13 PM   #284
GioB18
Scooby Newbie
 
Member#: 456767
Join Date: Oct 2016
Default

Thanks Black94Snake
The fact is that this flashing is a one off episode, i've not the knowledge for build my custom rom but have received one from a friend and want to try without going to the tuner, given that there are no code issues. But for 160$ or so i think it's better to go for the safety of a tuner
GioB18 is offline   Reply With Quote
Old 09-03-2017, 12:14 PM   #285
Black94Snake
Scooby Specialist
 
Member#: 274499
Join Date: Feb 2011
Chapter/Region: NESIC
Location: RI
Vehicle:
1994 5.8T Cobra
755rwhp @ 16psi

Default

If you have no intentions to use the device on a regular basis, go see a tuner.
Black94Snake is offline   Reply With Quote
Old 03-10-2018, 03:43 PM   #286
SubeN'Siren
Scooby Newbie
 
Member#: 151171
Join Date: Jun 2007
Chapter/Region: MWSOC
Location: Siren, WI
Vehicle:
02 Subaru WRX
Blue

Default Bad connection, or bad o2 sensor

First time trying to log with Openport 2.0

appears to connect, but stops at densoO2_bootloader_cmd_start
Tries 5 times, then,
kernal get version
followed by,
interface close
interface close.

I have other reasons to suspect the O2 sensor is bad, is that the issue, is the connection bad, or am I doing it wrong?
SubeN'Siren is offline   Reply With Quote
Old 05-11-2018, 01:45 PM   #287
tsilo
Scooby Newbie
 
Member#: 485842
Join Date: May 2018
Default

cant find ecu map for 2.0 2004 n/a. is it possable to remap this engine ? jdm ej20
tsilo is offline   Reply With Quote
Old 10-27-2018, 07:16 PM   #288
ubareddition
Scooby Newbie
 
Member#: 265374
Join Date: Nov 2010
Location: c-town RI
Vehicle:
2003 2.5x
pacifica blue pearl

Default

Apologize for apparently being an idiot but I bought a open port 2.0 installed ECU flash and rom raider. I believe I downloaded the proper definitions. Running on Windows 8. ECU flash I get an error j2534 err timeout.
I can't get ROM raider to work at all but then again I have no idea even where to start. Any quick tips to at least get me started so I can try to learn how to use it?
ubareddition is offline   Reply With Quote
Old 11-19-2018, 11:49 AM   #289
Smurftastic
Scooby Guru
 
Member#: 243697
Join Date: Apr 2010
Chapter/Region: MAIC
Location: Virginia
Vehicle:
17.4 PSI ECUtuned 02
BLOD Cofounder|TopScoob31

Default

Honestly, best bet is to find someone who successfully set everything up and ask they setup your stuff -- it can be really finicky.
Smurftastic is offline   Reply With Quote
Old 02-06-2019, 01:08 PM   #290
Scoobiidoo
Scooby Newbie
 
Member#: 496440
Join Date: Jan 2019
Location: So Cal
Vehicle:
2006 OBXT

Default

Is Learning View still available for download? Or is everyone using something else now? If so, which software? Thanks
Scoobiidoo is offline   Reply With Quote
Old 06-25-2019, 03:53 PM   #291
eustacer
Scooby Newbie
 
Member#: 416465
Join Date: Mar 2015
Chapter/Region: NESIC
Location: Vermont
Vehicle:
2009 Impreza 2.5i
DGM

Default

Quote:
Originally Posted by Scoobiidoo View Post
Is Learning View still available for download? Or is everyone using something else now? If so, which software? Thanks
learning view doesnt work for me (09 2.5i) but romraider learning tables does in the logger section. Hit F6 when in the logging section to get the learning tables.
eustacer is offline   Reply With Quote
Old 08-16-2019, 12:01 PM   #292
Jonypool
Scooby Newbie
 
Member#: 505345
Join Date: Aug 2019
Default Can read, can modifie, can test write but no write

Hi Guys sorry about the inconvenience, but right now, I'm really annoyed. I'm French, excuse for my languages. I ecuflash, I managed to read and write about Legacy, etc... But on my WRX 8.5 EUDM 2005 it's a mess.
Let me explain.
I can read (no prob), I can modifie with Ecuflash, I can save, I can test write, but at the moment to write, it's not possible in .bin or .srf

[17:41:37.187] -- comparing ECU flash memory pages to image file --
[17:41:37.187] seg start len ecu CRC32 img CRC32 same?
[17:41:37.496] FB01 00000000 00004000 2704DDB8 2704DDB8 YES
[17:41:37.824] FB02 00004000 00004000 862709CE 862709CE YES
[17:41:38.144] FB03 00008000 00004000 CB5E50A5 CB5E50A5 YES
[17:41:38.450] FB04 0000C000 00004000 8AB48FA7 8AB48FA7 YES
[17:41:38.781] FB05 00010000 00004000 BE2F4B4B BE2F4B4B YES
[17:41:39.100] FB06 00014000 00004000 3EE3B929 3EE3B929 YES
[17:41:39.419] FB07 00018000 00004000 51000881 51000881 YES
[17:41:39.738] FB08 0001C000 00004000 DB44117B DB44117B YES
[17:41:40.057] FB09 00028000 00004000 7C115463 7C115463 YES
[17:41:40.362] FB10 0002C000 00004000 601ED51F E7EEE9C1 NO
[17:41:40.703] reading ecu programming voltage
[17:41:40.706] programming voltage is 13.81 volts
[17:41:40.706] programming voltage is out of range!
[17:41:40.706] interface close
[17:41:40.713] interface close

I don't know what to do or where to look on the forum, thank you for helping me.

Thank you so much
Jonypool is offline   Reply With Quote
Old 08-17-2019, 12:53 PM   #293
NSFW
Scooby Guru
 
Member#: 140444
Join Date: Feb 2007
Chapter/Region: NWIC
Location: Near Seattle, WA
Vehicle:
05 Stage Free LGT
ATP 3076, 6MT, AVO FMIC

Default

I think this is your problem:

Quote:
[17:41:40.703] reading ecu programming voltage
[17:41:40.706] programming voltage is 13.81 volts
[17:41:40.706] programming voltage is out of range!
I don't know what the required voltage range is, but 13.81 seems high.
If the engine was running, turn it off.
NSFW is offline   Reply With Quote
Old 08-19-2019, 05:00 AM   #294
Jonypool
Scooby Newbie
 
Member#: 505345
Join Date: Aug 2019
Default

Thx NFSW. But Engine turned off, yet on the battery I only had 12.4v , but I read somewhere that turning on the headlights helped to be able to lower the voltage to write
Jonypool is offline   Reply With Quote
Old 08-25-2019, 09:50 PM   #295
Rymar
Scooby Newbie
 
Member#: 310672
Join Date: Feb 2012
Vehicle:
2012 Impreza Ltd 5Dr
Dark Gray Metallic

Default

(this seems like the right thread...)

For 2019 Subaru ECUs, are there any new processor architectures or encryption types which need to be selected in ECUFlash?

I have successfully used my Tactrix Openport 2.0 and ECUFlash to modify the ECU of my 2012 Impreza:

https://forums.nasioc.com/forums/sho...ve+accelerator

I recently bought a 2019 Outback (yes, I know the "I" in NASIOC is for Impreza). Anyway, I upgraded ECUFlash to version 1.44.4799, and it installed fine, and updated the Tactrix Openport 2.0 hardware.

There are 3 processor families listed for Subarus after 2007:

Hitachi SH7058 (for 2007+; this worked with my 2012 Impreza)
Hitachi SH7059
Hitachi SH72543

There are also now 10 types of encryption selectable under options:
SSMCAN0
SSMCAN1 (default)
...
SSMCAN9

No matter what combination I try, the ECUFlash log looks like:

[17:53:21.289] using metadata XML ID read_subaruhitachish7059 from file C:/apps/eng/EcuFlash/rommetadata/read templates/read_subaruhitachish7059.xml
[17:53:21.304] J2534 API Version: 04.04
[17:53:21.304] J2534 DLL Version: 1.02.4798 Jun 13 2016 17:17:10
[17:53:21.304] Device Firmware Version: 1.16.4769
[17:53:21.304] Device Serial Number: TAz*p$0l
[17:53:31.071] reading vehicle info...
[17:53:31.133] CALID : EB4V000C
[17:53:31.149] CVN : EFCE58E1
[17:53:31.149] VIN : *******************
[17:53:31.289] starting programming session...
[17:53:31.305] unlocking ECU...
[17:53:31.305] Requesting Seed...
[17:53:31.321] interface close
[17:53:31.321] interface close

Note that communication is fine, because the CALID and VIN can be read (I starred out the VIN). But then the download doesn't start after the request for a seed, which looks to me like an encryption unlock failure.

It seems likely that the Gen5 Outback (2015-2019) would have the same ECU processor (and maybe even hardware) as the latest generation Impreza/Crosstrek.

Any advice for a successful connection and download? I also have keyless start, and I know timing and mode selection can be important. In my 2012 Impreza, I needed to connect within about 5 seconds of ignition on.

Thanks for any suggestions.
Rymar is online now   Reply With Quote
Old 08-27-2019, 01:27 AM   #296
schuere
Scooby Newbie
 
Member#: 505704
Join Date: Aug 2019
Default

Can I flash an ECU from a 2018 EDM WRX STI?
schuere is offline   Reply With Quote
Old 10-05-2019, 11:20 PM   #297
X2jones3x
Scooby Newbie
 
Member#: 507105
Join Date: Oct 2019
Default Hoping someine can help me

I have an 04 saabaru ive been flashing for months now with no issues. I went through my normal routine flash block test mode long story short i got a programming voltage too low error but the log shows programming voltage at 12.17 i dont understand left me stranded and by a stroke of luck i found an 02 ecu in the area but would like to try and get my orig back. Ecu never made it to the erase procedure as the voltage error shut me down. My question obviously is WTH
X2jones3x is offline   Reply With Quote
Old 11-07-2019, 08:32 AM   #298
Chuma87
Scooby Newbie
 
Member#: 470383
Join Date: Jul 2017
Chapter/Region: International
Location: Argentina
Vehicle:
2002 Forester S-Turb
Grey

Default

I have a problem with EcuFlash, I suppose...
When I want to read the ROM, select the type of car (in my case, wrx 2002, although it is a 2002 forester that does not appear in the ECU definitions) and turn ON the key...
after "get kernel version", an error appears


Windows 7 Professional 64bits
OBD2 VAG cable FTDI FT232RL
ECUflash 1.28, 1.29, 1.30, 1.42, etc
Subaru Forester S-Turbo MY 2002 (wrx engine, individual coils)

Is the driver? Is the ECU?
Chuma87 is offline   Reply With Quote
Old 06-28-2020, 04:48 PM   #299
Tatenda Stb
Scooby Newbie
 
Member#: 516205
Join Date: Jun 2020
Default Sf5 Tuning

ls there a way to tune a sf5 stb forester using ecu flash or romraider?
Tatenda Stb is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
romraider/ecuflash? weaponstroop Open Source Reflashes 14 03-23-2020 08:27 PM
reading logs - FAQ or getting started guide? jmc9809 Newbies & FAQs 2 08-05-2005 06:40 PM
I want to get started racing! Where to start? wayne_rx Motorsports 27 12-23-2004 03:00 AM
Auto-Xing Newbe, How to get started? Ed_RS New England Impreza Club Forum -- NESIC 7 01-31-2001 11:34 AM
how to get started jjp New England Impreza Club Forum -- NESIC 5 11-09-2000 06:26 AM

All times are GMT -4. The time now is 02:47 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.