Welcome to the North American Subaru Impreza Owners Club Friday April 10, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 08-03-2013, 06:28 PM   #1
twoolverton06
Scooby Newbie
 
Member#: 357363
Join Date: May 2013
Chapter/Region: NWIC
Location: Great Falls, MT
Vehicle:
2007 WRX Limited
Silver

Default HELP! Loss of boost and CEL P2433 NS P2431..

Hey guys, I recently threw a CEL of P2433 and P2431, both relating to the secondary air injection system. I tried to clear them using my AP, but it wont clear. I have checked the connections to the valves but nothing. Now, my car wont run over 3.5 lbs of boost, when normally it hits 15. I own a 2007 WRX Limited 4EAT. Mods are just catless invidia DP and COBB Accesport V2, with stage 2 oct 91 OTS Map. Any suggestions will be appreciated. THanks!
* Registered users of the site do not see these ads.
twoolverton06 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-03-2013, 07:18 PM   #2
twoolverton06
Scooby Newbie
 
Member#: 357363
Join Date: May 2013
Chapter/Region: NWIC
Location: Great Falls, MT
Vehicle:
2007 WRX Limited
Silver

Default

Anybody deal with this before? Im at my wits end with this
twoolverton06 is offline   Reply With Quote
Old 08-03-2013, 07:25 PM   #3
Napalm3nema
*** Banned ***
 
Member#: 263954
Join Date: Nov 2010
Location: Houston, TX
Vehicle:
2014 EVO X / 05 WRX
Wicked White / Blue

Default

Well you are already running a tune that isn't supported by the parts you have on the car. The OTS Cobb map is for a CATTED downpipe.

Depending on how long you've been running like that = guessing the cause of the issues you face now is where I would start.
Napalm3nema is offline   Reply With Quote
Old 08-03-2013, 07:37 PM   #4
Vinnie
Scooby Newbie
 
Member#: 7869
Join Date: Jun 2001
Chapter/Region: MWSOC
Location: MPLS, MN
Vehicle:
2011 STi
TheUrbanRallyProject.com

Default

Try flashing the OEM map and see if you are still getting low boost. If not then its the map
Vinnie is offline   Reply With Quote
Old 08-03-2013, 08:24 PM   #5
twoolverton06
Scooby Newbie
 
Member#: 357363
Join Date: May 2013
Chapter/Region: NWIC
Location: Great Falls, MT
Vehicle:
2007 WRX Limited
Silver

Default

Quote:
Originally Posted by Vinnie View Post
Try flashing the OEM map and see if you are still getting low boost. If not then its the map
Ok ill try that. Idk why it would suddenly drop boost, I've been running that map for about 5k miles now without anything going wrong.
twoolverton06 is offline   Reply With Quote
Old 08-03-2013, 08:34 PM   #6
twoolverton06
Scooby Newbie
 
Member#: 357363
Join Date: May 2013
Chapter/Region: NWIC
Location: Great Falls, MT
Vehicle:
2007 WRX Limited
Silver

Default

Quote:
Originally Posted by twoolverton06 View Post

Ok ill try that. Idk why it would suddenly drop boost, I've been running that map for about 5k miles now without anything going wrong.
Definitely not the map. Still running low boost.
twoolverton06 is offline   Reply With Quote
Old 08-03-2013, 08:56 PM   #7
SubieStiGal
Scooby Newbie
 
Member#: 362014
Join Date: Jul 2013
Chapter/Region: NWIC
Location: Bothell, WA
Vehicle:
11 STi Stage 2
Lightning Red

Default

I'm curious to know if it has anything to do with running the catless DP. I was just on the phone with Cobb Tuning Surgeline because I have a catless Invidia DP and catback exhaust and intake that I haven't installed yet on my 2011 STI due to thinking I needed to get an opensource tune afterward to prevent boost creep. I was told by surgeline that the boost creep is a mechanical issue and that it can only actually be eliminated by doing an external wastegate, uppipe with dump pipe, new fuel pump, injectors and then a pro tune. He also told me it would be ok to flash a Stage 2 map with the catless DP temporarily as long as I monitor my boost levels (same as what you're doing).
Now I'm thinking I'll just wait to do my exhaust until I get my ewg and other goodies if you find out the Stage 2 map is the cause of your issue
SubieStiGal is offline   Reply With Quote
Old 08-03-2013, 08:58 PM   #8
SubieStiGal
Scooby Newbie
 
Member#: 362014
Join Date: Jul 2013
Chapter/Region: NWIC
Location: Bothell, WA
Vehicle:
11 STi Stage 2
Lightning Red

Default

And I just saw you posted that it wasn't the map lol. Sorry. Guess you can disregard my other post.
SubieStiGal is offline   Reply With Quote
Old 08-03-2013, 09:00 PM   #9
twoolverton06
Scooby Newbie
 
Member#: 357363
Join Date: May 2013
Chapter/Region: NWIC
Location: Great Falls, MT
Vehicle:
2007 WRX Limited
Silver

Default

Quote:
Originally Posted by SubieStiGal View Post
I'm curious to know if it has anything to do with running the catless DP. I was just on the phone with Cobb Tuning Surgeline because I have a catless Invidia DP and catback exhaust and intake that I haven't installed yet on my 2011 STI due to thinking I needed to get an opensource tune afterward to prevent boost creep. I was told by surgeline that the boost creep is a mechanical issue and that it can only actually be eliminated by doing an external wastegate, uppipe with dump pipe, new fuel pump, injectors and then a pro tune. He also told me it would be ok to flash a Stage 2 map with the catless DP temporarily as long as I monitor my boost levels (same as what you're doing).
Now I'm thinking I'll just wait to do my exhaust until I get my ewg and other goodies if you find out the Stage 2 map is the cause of your issue
Ya idk my tuner told me that running a catless dp with the stage 2 setup would be totally fine....now i have two hard cels that wont clear and cant hit boost, so basically my car is in limp mode. This is bs cause i gotta drive 1200 miles to go to my wedding in two weeks lol
twoolverton06 is offline   Reply With Quote
Old 08-03-2013, 09:05 PM   #10
twoolverton06
Scooby Newbie
 
Member#: 357363
Join Date: May 2013
Chapter/Region: NWIC
Location: Great Falls, MT
Vehicle:
2007 WRX Limited
Silver

Default

whats throwing me off is the hard cels of p2433 and p2431...both of which have to do with that stupid Secondary Air Injection System. I have the blockoff plates for it, i was just wondering if anyone else experienced a loss of boost when the cels were thrown.
twoolverton06 is offline   Reply With Quote
Old 03-25-2020, 11:08 PM   #11
Birdherpzfishing
Scooby Newbie
 
Member#: 511268
Join Date: Feb 2020
Location: Miami, Fl
Vehicle:
2011 Sti hatchback
Satin Pearl white

Default

hey man i know its been a minute since this post but i want to know what in the end you resorted doing with this issue because i too have now put block off plates and deleted thge system which now throws those same p2431 and p2433 codes. i ran an accessport reflash stage2 map since i have a whole cobb set with dp, exhaust, bv, and air induction with the maf and boost control solenoids... i dont know if i should dish out the $600 it may take to do a pro tune or if i can still save the car and some $$$ myself... please help me thank you
Birdherpzfishing is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 02:13 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.