Welcome to the North American Subaru Impreza Owners Club Saturday May 8, 2021
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 04-04-2021, 11:24 AM   #1
FujiLightIndustries
Scooby Newbie
 
Member#: 479768
Join Date: Dec 2017
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2018 Impreza
Silver

Default Key getting stuck in ignition (after replacing automatic shifter)

I replaced my automatic shifter with another OEM part from the same model range. The shifter itself works fine, but now my key gets stuck in the ignition a lot of the time. I assume it's the sensor that detects the car is in park.


Is there something tricky to swapping out this part?
* Registered users of the site do not see these ads.
FujiLightIndustries is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-04-2021, 04:05 PM   #2
DieselDorf
Scooby Specialist
 
Member#: 454773
Join Date: Sep 2016
Chapter/Region: MWSOC
Location: Traverse City, MI
Vehicle:
2012 Impreza Sport
Pearl White

Default

Itís super common, until you fix it just shift out of park and back until it works thatís what Iíve been doing, mine finally started doing it occasionally at 111k
DieselDorf is offline   Reply With Quote
Old 04-08-2021, 02:29 AM   #3
FujiLightIndustries
Scooby Newbie
 
Member#: 479768
Join Date: Dec 2017
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2018 Impreza
Silver

Default

How am I supposed to fix it? Is it something to do with the shifter install, or was that random? Is the sensor adjustable? Does it need replacing?
FujiLightIndustries is offline   Reply With Quote
Old 04-10-2021, 11:05 AM   #4
Elbert Bass
Scooby Specialist
 
Member#: 283429
Join Date: May 2011
Chapter/Region: South East
Location: Down yonder.
Vehicle:
2016 Fuji Sunfire 03
Silver

Default

If you got that electrical connector on the shifter fully engaged then you probably have a bad "P" switch in the shifter itself (not to be confused with the gear selector switch on the transmission). These are a know issue and I would say I have put at minimum one hundred of those in Outbacks, Foresters, Imprezas, Crosstreks...
That part has about as much reliability as a Yugo.

The official name is "Guide plate B" and for a 2018 it should be part 35122FL00B - have your dealer check the VIN or use the VIN when looking up on line to order. It is a real PIA - it is in the middle of the shifter and the shifter slides back and forth over it. If I were a DIY and had never taken complicated spring loaded mechanical mechanisms apart I would pay a mechanic or buy a whole new shifter assembly. Lots of things you can break while disassembling the shifter that can't be fixed if you don't know what you are doing.
I would not waste money buying another used shifter knowing that part is so unreliable.

Or, as mentioned, move the shifter until you can remove the key - until that no longer works.
Elbert Bass is offline   Reply With Quote
Old 04-10-2021, 09:13 PM   #5
FujiLightIndustries
Scooby Newbie
 
Member#: 479768
Join Date: Dec 2017
Chapter/Region: Tri-State
Location: New Jersey
Vehicle:
2018 Impreza
Silver

Default

A gazillion thanks!
FujiLightIndustries is offline   Reply With Quote
Old 04-11-2021, 01:25 PM   #6
Elbert Bass
Scooby Specialist
 
Member#: 283429
Join Date: May 2011
Chapter/Region: South East
Location: Down yonder.
Vehicle:
2016 Fuji Sunfire 03
Silver

Default

https://static.nhtsa.gov/odi/tsbs/20...53178-9999.pdf
This link is to a TSB showing you the part location. I forgot you need those two clamps as well.
Elbert Bass is offline   Reply With Quote
Old 04-19-2021, 03:27 PM   #7
vintage42
Scooby Newbie
 
Member#: 505426
Join Date: Aug 2019
Vehicle:
2016 Impreza 2.0 CVT

Default

In August 2019 we bought a 2016 Impreza from CarMax. We had the dealer replace the shifter guide plate to fix the key getting stuck in ignition switch per Svc Bulletin 16-112-18R. It cost $432 and CarMax reimbursed us for it under their 90d/4k warranty.
vintage42 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 06:45 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.