Welcome to the North American Subaru Impreza Owners Club Tuesday October 23, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 05-24-2013, 07:11 PM   #101
cheddle
Scooby Newbie
 
Member#: 357384
Join Date: May 2013
Default

lmao, my father-in-law couldn't figure this out and used to disconnect the battery each night because he didnt want it going flat... he did this for about 3 months until he finally mentioned it to me... lol
* Registered users of the site do not see these ads.
cheddle is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-09-2013, 01:22 PM   #102
Nahtanojon
Scooby Newbie
 
Member#: 364890
Join Date: Aug 2013
Default

This happened to me. Didnt realized it until i cleaned my dash.
Nahtanojon is offline   Reply With Quote
Old 08-21-2013, 08:50 PM   #103
belchfire
Scooby Newbie
 
Member#: 67098
Join Date: Jul 2004
Location: near Portland, Or.
Vehicle:
2000 impreza OBsport
green

Default

I will never live this down. 10 years of ownership, 234K miles. First time.
belchfire is offline   Reply With Quote
Old 10-06-2013, 06:01 PM   #104
99screwbaru
Scooby Newbie
 
Member#: 332912
Join Date: Sep 2012
Chapter/Region: NESIC
Location: kingston , RI
Vehicle:
2002 stage 2 wrx
rally blue

Default

HAHAHAHA thats f****** awsome omg
99screwbaru is offline   Reply With Quote
Old 03-06-2014, 10:16 PM   #105
Tha Chakal
Scooby Specialist
 
Member#: 372100
Join Date: Oct 2013
Location: D.C.
Vehicle:
2013 Premium 5dr CVT
DGM

Default

I'd like to add that the new gen soobies do not have the switch. If you turn the car off before cutting the lights off, they automatically turn off.

You can turn them on without the keys, but you will get a warning buzz with the door open.
Tha Chakal is offline   Reply With Quote
Old 03-14-2014, 07:12 PM   #106
zombiez07
Scooby Specialist
 
Member#: 335919
Join Date: Oct 2012
Chapter/Region: MWSOC
Vehicle:
2004 wrx
wrb

Default along the lines

so my parking lights/tail lights/dash lights will NOT turn off. and it's NOT the parking switch, i've tried. the only way i'm able to get them to turn off is to pull the clock/room fuse in the engine bay. is there a relay somewhere that could be bad? seemed to start happening after an ecu tune... but can't see how?

04 wrx
zombiez07 is offline   Reply With Quote
Old 03-19-2014, 11:33 PM   #107
Dito14411
Scooby Newbie
 
Member#: 362966
Join Date: Jul 2013
Location: FL
Vehicle:
2004 Wrx STI
Black

Default

For my 04 it is not the all the lights but just the parking lights. And i did actually just recently get an ecu tune. Any ideas for the bad relay switch or an easy fix??
Dito14411 is offline   Reply With Quote
Old 03-20-2014, 12:15 AM   #108
zombiez07
Scooby Specialist
 
Member#: 335919
Join Date: Oct 2012
Chapter/Region: MWSOC
Vehicle:
2004 wrx
wrb

Default

Wish I knew. Mine fixed itself. I jiggled some wires, there was a puff of smoke, then everything worked again . My problem spot seemed to come from behind the stereo for whatever reason. Check for crossed wires or errant grounds.
zombiez07 is offline   Reply With Quote
Old 03-20-2014, 12:16 AM   #109
zombiez07
Scooby Specialist
 
Member#: 335919
Join Date: Oct 2012
Chapter/Region: MWSOC
Vehicle:
2004 wrx
wrb

Default

And make sure your parking switch isnt flipped on top of steering column
zombiez07 is offline   Reply With Quote
Old 03-21-2014, 04:14 PM   #110
Dito14411
Scooby Newbie
 
Member#: 362966
Join Date: Jul 2013
Location: FL
Vehicle:
2004 Wrx STI
Black

Default

It is not the parking switch, that was the first thing that i checked...
Dito14411 is offline   Reply With Quote
Old 04-02-2014, 09:23 PM   #111
05rshatch
Scooby Newbie
 
Member#: 386530
Join Date: Apr 2014
Default 2005 impreza rs issue (no running lights or dash lights)

the lights worked fine the first day after having this car, then i cleaned the interior and now there are no running lights or dash lights. headlights work, turn signals work. Checked all the fuses, they are good. When you turn the headlight switch to first position (running lights) you can hear a click under rh side of dash but no lights (dash/running). They also don't come on from the switch on top of the column. Has anyone had this isssue or have access to running light wiring diagram?
05rshatch is offline   Reply With Quote
Old 10-23-2014, 08:52 AM   #112
Gnudoll
Scooby Newbie
 
Member#: 262823
Join Date: Nov 2010
Default

I'm on my third Subaru. (Two Legacy wagons that each bested 350k miles, and now my Impreza wagon is about to hit 300k) I learned about this switch very early on, but then it was called the "Subaru virgin switch" I even heard about a guy that claimed to have bought a few Subarus really cheaply (due to the "electrical problems), only to then turn the switch off after driving a few blocks... (seems dishonest to me)


As for why these lights would not turn ON... That may likely be a completely different problem. Unless, of course, the Previous Owner had hacked into something to get them to turn off... (?)
Gnudoll is offline   Reply With Quote
Old 10-23-2014, 09:44 AM   #113
left footed whooten
Scooby Specialist
 
Member#: 44652
Join Date: Oct 2003
Chapter/Region: BAIC
Location: Truckee, CA
Vehicle:
16 Colorado diesel
ATC Bobcat Pop-up

Default

Quote:
Originally Posted by 05rshatch View Post
the lights worked fine the first day after having this car, then i cleaned the interior and now there are no running lights or dash lights. headlights work, turn signals work. Checked all the fuses, they are good. When you turn the headlight switch to first position (running lights) you can hear a click under rh side of dash but no lights (dash/running). They also don't come on from the switch on top of the column. Has anyone had this isssue or have access to running light wiring diagram?
Your dash lights could have had the brightness knob turned during cleaning. Have you checked that? For the running lights, you mean the parking lights? Daytime running lights? Does your year even have DRLs? I doubt its an issue that would require a wiring diagram. Go check everything you touched when cleaning, I bet the dashlights are turned down to all the way dim after cleaning.

Was surprised to see that my 15 forester no longer has the column parking light switch.....
left footed whooten is offline   Reply With Quote
Old 02-05-2015, 11:20 PM   #114
Steve2015
Scooby Newbie
 
Member#: 412793
Join Date: Feb 2015
Default

I just had this same problem! haha golly gosh new toys and all there buttons
Steve2015 is offline   Reply With Quote
Old 05-24-2015, 01:15 PM   #115
dieckhoff
Scooby Newbie
 
Member#: 420827
Join Date: May 2015
Chapter/Region: MAIC
Location: Fredericksburg
Vehicle:
02 Legacy
Pearl White

Default

God.. Glad to see I'm not the only one who had issues with this. Got a call from the neighbor that my lights were still on and me and him sat out there for 30 minutes until we figured it out. Must've hit the little switch on the column when I cleaned it earlier that day. Felt brilliant.
dieckhoff is offline   Reply With Quote
Old 05-26-2015, 12:06 AM   #116
DsB
Scooby Newbie
 
Member#: 379896
Join Date: Jan 2014
Default

i have an Rsti and just last night this started. my parking lights, hvac, and glovebox light are all stuck on. i checked the switch first and that isnt doing anything. i also checked all the fuses i could think of. does anyone have any ideas???? thanks.....I got angry and was hitting my dash. Turns out I had a lose wire on my clock pod. So problem fixed.

Last edited by DsB; 05-27-2015 at 09:50 PM.
DsB is offline   Reply With Quote
Old 09-06-2016, 01:10 PM   #117
inxsible
Scooby Newbie
 
Member#: 454018
Join Date: Sep 2016
Default

I have a different problem though.

My driver side tail light/brake light won't come on when the headlights are off. When the headlight is on, the driver side tail light is very dim compared to the passenger side.

When applying brakes (with headlights on), both brake lights seem to be about equally bright.

Where do I start looking? Would it be one of the fuses or the bulbs itself? The fact that it turns on (although dim) makes me believe that its not drawing enough power on the driver side instead of the bulb being bad. Do driver side and passenger side tail lights have different circuits altogether ?
inxsible is offline   Reply With Quote
Old 07-11-2017, 11:03 PM   #118
vic2340
Scooby Newbie
 
Member#: 469934
Join Date: Jun 2017
Default

Does anybody know how to get the light to shut off entirely while driving? I have a 2002 Impreza ts and would like to know if their is a way to get them to go off. I noticed if I pull the e brake up one notch they go off but I would like to just be able to turn the knob off on the signal indicator and have the lights go away on command for stealth mode reasons. My lights are Always ON!!!!
vic2340 is offline   Reply With Quote
Old 07-11-2018, 11:46 PM   #119
ImOnTheWrongForum
Scooby Newbie
 
Member#: 383247
Join Date: Mar 2014
Default

This damn thing almost cost me my job haha! I was replacing the steering column cover on a 06 WRX at work (used car dealership) and hit the switch in the process. Not a single person there could figure out why the lights wouldn't turn off and assumed I must have f*cked some wiring up. This thread saved my job lol.
ImOnTheWrongForum is offline   Reply With Quote
Old 10-19-2018, 08:10 PM   #120
g77
Scooby Newbie
 
Member#: 492809
Join Date: Oct 2018
Default the parking light switch

Quote:
Originally Posted by munkis View Post
Q. Why wont my parking lights shut off?

A. Turn the parking light switch on top of the steering colulm off.



http://www.scoobymods.com/forums/sho...=&threadid=448

Jay
g7[/the positive + power contact in the switch may be touching do to the plastic being broken]
g77 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My parking lights won't turn off?... Sharky Service & Maintenance 29 03-19-2010 03:55 PM
question of the day: why does my earphones.. iRick. Off-Topic 13 02-03-2009 03:20 AM
Computer guys, why won't my comp. shut off???? Eric SS Off-Topic 36 08-29-2002 03:53 AM
My parking lights won't go off LiquidForce General Community 22 01-06-2002 10:18 PM

All times are GMT -4. The time now is 01:54 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.