Welcome to the North American Subaru Impreza Owners Club Sunday January 20, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 01-16-2019, 02:18 AM   #1
Saichisubie
Scooby Newbie
 
Member#: 446858
Join Date: May 2016
Chapter/Region: HIIC
Location: Hawaii
Vehicle:
2008 WRX Sedan
Obsidian Black Pearl

Default Stock Radiator Cap on Mishimoto Radiator - Doesn't fit/seal

Not sure if this is the right place for this thread, and I apologize if it isn't... but I don't really know where to go.

I've searched and searched everywhere for an answer but I keep getting nothing about this.

Anyway, I replaced my stock radiator with an all aluminum "Performance" radiator from Mishimoto (Not the X-Line one). Stock one was splitting from old age. I decided not to use the radiator cap that comes with the Mishi rad, instead bought OEM ones, for both the expansion tank and the radiator.

I know the cap with the ears go on the expansion tank, and the round one is supposed to go on the radiator, but problem I'm having is, the round one does not properly seat or twist into place and seal like it should.

I'm waiting on a reply from Mishimoto about this, but I'm trying to see if anyone else came across this problem.

The S/N for the caps I got are 599777 (with ears) and 599778 (round) if that helps...

Did I purchase the wrong caps???
* Registered users of the site do not see these ads.
Saichisubie is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-16-2019, 02:02 PM   #2
Jedi03
Scooby Newbie
 
Member#: 491095
Join Date: Sep 2018
Chapter/Region: SWIC
Location: New Mexico
Vehicle:
2009 STi Blue
Blue

Default

it was hard to put on the first few times...i have same 2 row mishi rad. after a few times on and off its easier, i had to really push mine down to get over the locking part of the neck
Jedi03 is offline   Reply With Quote
Old 01-16-2019, 10:22 PM   #3
Saichisubie
Scooby Newbie
 
Member#: 446858
Join Date: May 2016
Chapter/Region: HIIC
Location: Hawaii
Vehicle:
2008 WRX Sedan
Obsidian Black Pearl

Default

Quote:
Originally Posted by Jedi03 View Post
it was hard to put on the first few times...i have same 2 row mishi rad. after a few times on and off its easier, i had to really push mine down to get over the locking part of the neck
Thank you for that! I thought something was wrong or bought the wrong ones... lol
Saichisubie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 08:03 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.