Welcome to the North American Subaru Impreza Owners Club Saturday December 14, 2019
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Built Motor Discussion

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 09-20-2019, 02:41 PM   #51
smoky
Scooby Newbie
 
Member#: 221439
Join Date: Aug 2009
Chapter/Region: E. Canada
Location: Quebec, Canada
Vehicle:
2004 STI
Blue

Default

Quote:
Originally Posted by subaru_gc8 View Post
have you tried like water wetter?
I'm running some in the system. You need to add some every events when using ice.
* Registered users of the site do not see these ads.
smoky is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 09-20-2019, 06:27 PM   #52
BattleTuned
Scooby Newbie
 
Member#: 506581
Join Date: Sep 2019
Vehicle:
97 GC8

Default

I love your car man, great setup! Hope you can solve that IAT issue soon
BattleTuned is offline   Reply With Quote
Old 09-21-2019, 11:48 PM   #53
vicious_fishes
Scooby Guru
 
Member#: 158864
Join Date: Sep 2007
Location: Aussieland
Vehicle:
2003 SOHC destroker

Default

You can also go full baller like some of the drag racers do and fill the system with a combination of alcohol and dry ice...

It is a little dangerous though >_>
vicious_fishes is offline   Reply With Quote
Old 09-24-2019, 08:19 PM   #54
tsrapophis
Scooby Newbie
 
Member#: 434904
Join Date: Nov 2015
Location: Spokane, WA
Vehicle:
2002 Impreza WRX
WRB

Default

I'm running an A2W setup on a similar build, except running pump gas for now at about 17psi. I'm running the Type 14 top mounted, which has less HP rating than the Type 26 that smoky is running. I have a trunk mounted 1 gal reservoir, the same radiator but front mounted and I'm using a 33% coolant, 66% water Plus a bottle of water wetter on a closed loop, no ice. My autocross datalogs are show my IAT's are under 140 degrees on an 80 degree sunny dry day. The coolant itself is much cooler but the intercooler is a little undersized and so heat exchange is limited. The highest I've seen is during a 5th gear pull to redline and that was 152 degrees.
tsrapophis is offline   Reply With Quote
Old 10-01-2019, 09:59 AM   #55
CEEBEE
Scooby Newbie
 
Member#: 420458
Join Date: May 2015
Location: Australia
Vehicle:
07 WRX STI
Urban Grey

Default

Quote:
Originally Posted by smoky View Post
A few updates on the build:
- Oil pressure is dropping (to 60psi @ 8000rpm) when oil is reaching around 230 with both Gulf racing 5w50 and Motul 300v 15w50. Uprading to a 11mm pump over winter.
- Still haven't found what's limiting the tune at 8000rpm. A few tuners have confirmed that it should be possible with 04 ECU, could be the tune itself. Also had another theory on cam sensor gap, need to investigate further on that side
- Decided to try A2W intercooler to reduce IAT. In discussion with Frozenboost for the setup
- Might upgrade the injectors to 1700 and have the tune adjusted for a few more psi in spring
Talk to Plazmaman in Australia about their pro series W2A setups! They made a custom setup for ma and I'm making just shy of 600whp. Super stable intake temps always within a few degrees of ambient in warmer weather and below ambient in the colder months.

https://forums.nasioc.com/forums/sho...ht=xona&page=2

Click on the image and it will link you to a clear image. Photobucket does this garbage now...

[IMG][/IMG]
CEEBEE is offline   Reply With Quote
Old 10-14-2019, 03:58 PM   #56
tsrapophis
Scooby Newbie
 
Member#: 434904
Join Date: Nov 2015
Location: Spokane, WA
Vehicle:
2002 Impreza WRX
WRB

Default

Hey smoky, it's been awhile but I finished my 2.5L G25-660 build. Similar engine specs. I'm impressed with this turbo, made 400whp and 350 ftlbs on pump gas with a nice fat torque band. Still happy with everything?

https://forums.nasioc.com/forums/sho...1#post46147501
tsrapophis is offline   Reply With Quote
Old 10-26-2019, 01:04 AM   #57
sub9lulu
Scooby Specialist
 
Member#: 36946
Join Date: May 2003
Location: CFL
Default

"type 100 radiator in the back"

How u mounting it ? Pics pls
sub9lulu is offline   Reply With Quote
Old 10-28-2019, 11:56 AM   #58
smoky
Scooby Newbie
 
Member#: 221439
Join Date: Aug 2009
Chapter/Region: E. Canada
Location: Quebec, Canada
Vehicle:
2004 STI
Blue

Default

Quote:
Originally Posted by sub9lulu View Post
"type 100 radiator in the back"
How u mounting it ? Pics pls
Take a look at my album:
https://photos.app.goo.gl/jxYyhW7itFwMbkBY6
smoky is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 06:12 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.