Welcome to the North American Subaru Impreza Owners Club Thursday December 14, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 11-05-2003, 01:52 PM   #1
kitbar
Scooby Newbie
 
Member#: 41411
Join Date: Aug 2003
Location: Kansas City, MO
Vehicle:
2004 WRX Sedan
Java Black No Spoiler!

Default help: Strange boost levels

I have the HKS turboback, and samco hoses on my 04

tonight it was really cold and I did some testing.

1st, 2nd and 3rd all hit max PSI (about 14-15psi) at 3.2k rpm and it stays there till near fuelcut. It drops 1 or 2 psi around 6800rpm. I did several runs and I'm realy sure about this too.

Is that normal? I just installed my samco intercooler hoses a week ago. It used to taper off a lot before. If I did not install my intercooler hoses correctly could it cause this to happen?

much thanks!

PS: I have a UTEC waiting to be installed, I can prob get some logs to verify.
* Registered users of the site do not see these ads.
kitbar is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-05-2003, 02:06 PM   #2
Zackbo
Scooby Specialist
 
Member#: 43151
Join Date: Sep 2003
Chapter/Region: South East
Location: Charlotte, NC
Vehicle:
04 STI
Kinda Silver-ish

Default

Kit, you haven't got that UTEC installed YET?!?! I had mine in before the FedEx truck got out of my driveway. I'm not very patient.
Zackbo is offline   Reply With Quote
Old 11-05-2003, 02:16 PM   #3
mbiker97
Scooby Guru
 
Member#: 7922
Join Date: Jun 2001
Chapter/Region: MWSOC
Location: Tucson
Vehicle:
04 CTS-V b/b/b
99 GMC Highrider

Default

Yes it's normal for the stock turbo to taper at redline. It in not big enough to push that much air. The hoses certainly help out, but the only real fix is a larger turbo.
mbiker97 is offline   Reply With Quote
Old 11-05-2003, 02:39 PM   #4
kitbar
Scooby Newbie
 
Member#: 41411
Join Date: Aug 2003
Location: Kansas City, MO
Vehicle:
2004 WRX Sedan
Java Black No Spoiler!

Default

How'd you know I got a UTEC? hehe

I'm afraid to put it in until I understand how it works exactly. I will do it soon!

Quote:
Originally posted by Zackbo
Kit, you haven't got that UTEC installed YET?!?! I had mine in before the FedEx truck got out of my driveway. I'm not very patient.
kitbar is offline   Reply With Quote
Old 11-05-2003, 02:42 PM   #5
kitbar
Scooby Newbie
 
Member#: 41411
Join Date: Aug 2003
Location: Kansas City, MO
Vehicle:
2004 WRX Sedan
Java Black No Spoiler!

Default

hmm mine barely tapers if any.
I will get UTEC logs tonight or tomorrow. I'm now thinking, my boost guage might suck.

Quote:
Originally posted by mbiker97
Yes it's normal for the stock turbo to taper at redline. It in not big enough to push that much air. The hoses certainly help out, but the only real fix is a larger turbo.
kitbar is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
safe boost level/levels for an 02 stage 2 WRX madmax02 Newbies & FAQs 2 04-07-2009 01:32 AM
Questions about boost level and oil pressure level wrx2k4blue Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 15 05-09-2007 01:26 PM
Strange boost problem with a strange dealer diagnosis. Help? Computergeek24 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 12 10-09-2006 01:34 PM
Strange boost levels with AP Stage 2 Schleppy Engine Management & Tuning 8 05-11-2004 04:19 AM
What's maximum boost level in 1st and 2nd level with Unichip? WRXVII Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 04-06-2002 02:16 PM

All times are GMT -4. The time now is 04:26 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.