Welcome to the North American Subaru Impreza Owners Club Tuesday January 23, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 12-30-2007, 12:52 AM   #1
whtwrx91
Scooby Newbie
 
Member#: 91506
Join Date: Jul 2005
Question Alarm lights not working

When I turn my alarm on and off on my STI the Audio portion works but the head light and tail light flashers aren't working. I've looked in the manual on page 2-11 but that is for the audio portion. Any help would be greatly appreciated!
* Registered users of the site do not see these ads.
whtwrx91 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-30-2007, 09:05 PM   #2
whtwrx91
Scooby Newbie
 
Member#: 91506
Join Date: Jul 2005
Default

I've looked through the entire manual and can't find anything on turning the lights on and off with the remote, just the audible portion. Anyone else had this problem. This is for a 05 STI
whtwrx91 is offline   Reply With Quote
Old 12-30-2007, 10:55 PM   #3
BillJC
Scooby Specialist
 
Member#: 31002
Join Date: Dec 2002
Location: Sonoma, CA
Vehicle:
2002 WRX
Blue

Default

Any chance that you don't have the alarm but, just keyless entry? I know with my 02 WRX, I just have the keyless entry feature with no alarm and my horn chirps but the lights don't flash. Did it used to flash the lights and now it doesn't?
BillJC is offline   Reply With Quote
Old 12-31-2007, 12:40 AM   #4
whtwrx91
Scooby Newbie
 
Member#: 91506
Join Date: Jul 2005
Default

Yeah, they used to flash but don't now. I know that I have the factory alarm because I have the flashing security on the dash. Good thing I still have warranty.
whtwrx91 is offline   Reply With Quote
Old 12-31-2007, 12:59 AM   #5
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

This is the wrong forum, we do have a Stereo and Security forum where this should have been posted. But anyway, there's a good chance it's just in valet mode, this would be confirmed if the security light on the dash is constantly flashing twice/second. If that's all it is you can "fix" it by holding down the lock button on the remote for a few seconds with the drivers door open.
Mulder is offline   Reply With Quote
Old 01-01-2008, 12:28 PM   #6
whtwrx91
Scooby Newbie
 
Member#: 91506
Join Date: Jul 2005
Default

I'll give it a try, thanks. Didn't see the stereo "security" forum.
whtwrx91 is offline   Reply With Quote
Old 01-01-2008, 05:19 PM   #7
whtwrx91
Scooby Newbie
 
Member#: 91506
Join Date: Jul 2005
Default

My most humble apology for not being in the correct forum area. Technically, however, this could be considered a service issue since I will be taking it to the "service" dept. if I can't get the situation corrected. Why the converse address for such a minimal "mistake"? I have always found this site to be mostly user friendly.
whtwrx91 is offline   Reply With Quote
Old 01-01-2008, 08:35 PM   #8
Scooby-Doode
Scooby Specialist
 
Member#: 28976
Join Date: Nov 2002
Location: New York
Vehicle:
2016 Step 2 Push
Buggy GT

Default

You have somehow managed to put your security system in Valet mode. Have you used the key to unlock the car recently? In other words unlocked the car using the key in the key hole and not the Key Fob to unlock the car?

You should have a "Security" pamphlet or a quick guide, it should show you how to take it out of that mode, if its not there its definitely in the manual.
Scooby-Doode is offline   Reply With Quote
Old 01-01-2008, 08:37 PM   #9
Scooby-Doode
Scooby Specialist
 
Member#: 28976
Join Date: Nov 2002
Location: New York
Vehicle:
2016 Step 2 Push
Buggy GT

Default

Try this:

Open the driver's side door and hold down the disarm button for approx. three seconds.
Scooby-Doode is offline   Reply With Quote
Old 01-02-2008, 12:59 AM   #10
whtwrx91
Scooby Newbie
 
Member#: 91506
Join Date: Jul 2005
Default

Awesome! That worked. Thanks Scooby-Doode, and thanks for not giving me that hey this belongs in another forum!!
whtwrx91 is offline   Reply With Quote
Old 01-02-2008, 08:59 AM   #11
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 WRX
15 WRX/05 GTO

Default

Glad you got it straightened out, but-
It does belong in another forum, and I also gave you the same advice in post #5.
Mulder is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
05 wrx stock alarm is not working. Diagnosis? doobyscooby Car Audio, Video & Security 3 01-10-2008 12:58 AM
Car alarms do not work StuBeck Off-Topic 22 10-30-2005 06:08 AM
Alarm keyfobs not working - new car 05 sti mjlandy Car Audio, Video & Security 7 05-03-2005 06:55 PM
alarm lights not working PhatAsiankid03 Electrical & Lighting 0 03-28-2004 05:40 AM
('93-'01) taillight fuse blew twice within three weeks and alarm sys. not working? scootr Impreza Forum 3 07-11-2001 12:29 AM

All times are GMT -4. The time now is 01:08 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.