Welcome to the North American Subaru Impreza Owners Club Monday January 20, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 11-25-2019, 09:47 PM   #1
DJBunyan
Scooby Newbie
 
Member#: 322304
Join Date: Jun 2012
Vehicle:
2019 STI

Default 2019 STI - New wheels/tires, now it's darty/wobbly under acceleration

Hey guys,

Like the title says, I (and by "i" I mean costco lol) just put my winter setup on my '19 STI today and now the car seems to be "wobbly" or unstable under acceleration.

If I had to pick a side it was pulling to, I'd say right, because the one time I actually let my hands off the wheel and hit the gas, it pulled right. but it's not a clear cut "pulling to one side" issue overall, It's just more that under hard acceleration, the front end now seems to almost "float" a little bit and get a little wobbly and I need to keep a firm grip on the wheel and keep adjusting. This is my first performance car btw so my lack of other experience may be making explaining this extra difficult. Hopefully everything I'm saying is making sense.

The car felt rock solid under acceleration in its stock form. This is a new issue that was apparent immediately after I put the new tires and wheels on today.


Car in its current state seems rock solid on the hwy, not really getting any bad vibrations or anything like that


Wheels: 18x8.5 +44 Rota Titan

Tires: Blizzak WS90 245/40r18



Any ideas guys? I tend to be on the anxious side so I'm really hoping I'm just overthinking things. However, I noticed it immediately as I pulled out of the shop and have since done about 50 miles of test driving tonight and I really don't think I'm just being paranoid. It's minor overall but definitely drives different than it did this morning.

Bad Alignment?

Just a different feeling with the winter tires that are softer and have a taller sidewall?

the wheels that are an inch smaller and nearly 10lbs each lighter than the stocks making things feel less stable?

Last edited by DJBunyan; 11-25-2019 at 09:56 PM.
DJBunyan is offline   Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 01:44 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.