Welcome to the North American Subaru Impreza Owners Club Monday January 27, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 12-03-2019, 06:10 PM   #1
Dadsquatch
Scooby Specialist
 
Member#: 458140
Join Date: Nov 2016
Chapter/Region: BAIC
Location: Shingletown Ca
Vehicle:
1995 Impreza
White, green,

Default Rs-t misfire after install

Edit.. I found the thread and have ordered a selection of diodes
* Registered users of the site do not see these ads.

Last edited by Dadsquatch; 12-08-2019 at 10:49 PM.
Dadsquatch is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-18-2019, 07:09 PM   #2
Dadsquatch
Scooby Specialist
 
Member#: 458140
Join Date: Nov 2016
Chapter/Region: BAIC
Location: Shingletown Ca
Vehicle:
1995 Impreza
White, green,

Default

The diodes will not work. In fact they just make the map high circuit code come up faster. I gotta get the split second voltage clamp.
Dadsquatch is offline   Reply With Quote
Old 01-10-2020, 11:02 PM   #3
Dadsquatch
Scooby Specialist
 
Member#: 458140
Join Date: Nov 2016
Chapter/Region: BAIC
Location: Shingletown Ca
Vehicle:
1995 Impreza
White, green,

Default

Split second voltage clamp works very well. Still needs a little bit of fine tuning and a better boost controller but we are running about 7psi and initial spike at 10. Excellent power. Has more power than the WRX with mods.
Dadsquatch is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 03:14 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.