Welcome to the North American Subaru Impreza Owners Club Saturday January 25, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Subaru Conversions

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 02-13-2019, 08:32 PM   #3576
guitarsurgeon
Scooby Newbie
 
Member#: 290509
Join Date: Aug 2011
Location: Troy Oh
Vehicle:
2000 Impreza

Default

I have pictures on my Instagram @mechanical_advantage_racing
* Registered users of the site do not see these ads.
guitarsurgeon is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 02-13-2019, 08:51 PM   #3577
Kito818
Scooby Newbie
 
Member#: 480045
Join Date: Jan 2018
Chapter/Region: South East
Location: Murfreesboro, TN
Vehicle:
2009 3.0R Impreza
Dark grey/light black?

Default

Quote:
Originally Posted by guitarsurgeon View Post
Aem infinity
Do you still have your wiring pinout? I'm pretty sure I only have my pedal left, but I would love to look over someone elses proven wiring before I screw something up lol.
Kito818 is offline   Reply With Quote
Old 02-13-2019, 08:54 PM   #3578
guitarsurgeon
Scooby Newbie
 
Member#: 290509
Join Date: Aug 2011
Location: Troy Oh
Vehicle:
2000 Impreza

Default

It's in a folder hidden somewhere.... I used the factory service manual and duplicated pedal wiring from it
guitarsurgeon is offline   Reply With Quote
Old 02-13-2019, 09:42 PM   #3579
Kito818
Scooby Newbie
 
Member#: 480045
Join Date: Jan 2018
Chapter/Region: South East
Location: Murfreesboro, TN
Vehicle:
2009 3.0R Impreza
Dark grey/light black?

Default

Quote:
Originally Posted by guitarsurgeon View Post
It's in a folder hidden somewhere.... I used the factory service manual and duplicated pedal wiring from it
https://photos.app.goo.gl/ZsTxJEW3PDET1pks8
I'm wondering if I'm just stupid at this point. To me, the shielded wire is probably main signal, I know pins 1 and 2 go to ground[E/G(NA)], but then I'm supposed to have a sub signal and two 5v inputs right? How do I know which. The reference to connector location only has the stupid * for wire colors but no breakdown for what each wire is for. But I keep seeing people say they referenced the FSM, is there something I'm missing? I've not seen a breakdown of every connector's pinout like I'm used to seeing in other FSMs.
Kito818 is offline   Reply With Quote
Old 02-13-2019, 09:43 PM   #3580
guitarsurgeon
Scooby Newbie
 
Member#: 290509
Join Date: Aug 2011
Location: Troy Oh
Vehicle:
2000 Impreza

Default

There's a +12, and a ground to power the throttle body. And a +5v, ground, signal 1 and signal 2 for the sensors
guitarsurgeon is offline   Reply With Quote
Old 02-14-2019, 03:16 AM   #3581
Kito818
Scooby Newbie
 
Member#: 480045
Join Date: Jan 2018
Chapter/Region: South East
Location: Murfreesboro, TN
Vehicle:
2009 3.0R Impreza
Dark grey/light black?

Default

Quote:
Originally Posted by guitarsurgeon View Post
There's a +12, and a ground to power the throttle body. And a +5v, ground, signal 1 and signal 2 for the sensors
Okay, so I have a better understanding of where I messed up, for part of it (wires 1 and 2), and how to fix it, this friday when I get to work on it again, however, I'm still lost for the rest. Pin 6, the shielded yellow wire is probably main signal. I still have pins 3, 4, and 5. One is signal 2, 5v, and then the ground, is there a way to test or know for sure? The diagram just shows it going to the ECU, do I just mix the last three until I get a good combination or am I going to burn out something? I want to understand this more than I do and that's frustrating. I really wish this manual had a nice, "This is Connector B135 pin 1 is green up O2 htr, pin 2 is yellow up O2 sig, pin 3 is blue dw O2 htr, blah blah blah". That would be too easy I guess lol.
Kito818 is offline   Reply With Quote
Old 02-22-2019, 04:45 PM   #3582
Kito818
Scooby Newbie
 
Member#: 480045
Join Date: Jan 2018
Chapter/Region: South East
Location: Murfreesboro, TN
Vehicle:
2009 3.0R Impreza
Dark grey/light black?

Default

Ordered a 6MT drive shaft for an 08-14 STI, we'll see when it shows up if it's correct or not. Still on hold for an exhaust, but I'm in talks with a third possible local source. Really trying to avoid the OBX at 550$ a set, but I can't find anything cheaper, AND it might be a better long term option anyway.

Last edited by Kito818; 02-22-2019 at 04:50 PM.
Kito818 is offline   Reply With Quote
Old 02-24-2019, 12:27 AM   #3583
lodown1
Scooby Newbie
 
Member#: 200596
Join Date: Jan 2009
Vehicle:
98 Forester 3.0R

Default

Have you contacted Wiles driveshafts?

they are in Paris TN.

https://www.wilesracingdriveshafts.com

I used them for the custom 1 piece steel drive shaft that i needed for my forester to mate up to a BRZ 6 speed. I am pretty sure it was about $350-400, the only issue I had was that the rear flange bolt pattern will only fit the larger r180 version.


lodown1 is offline   Reply With Quote
Old 02-24-2019, 08:08 AM   #3584
Kito818
Scooby Newbie
 
Member#: 480045
Join Date: Jan 2018
Chapter/Region: South East
Location: Murfreesboro, TN
Vehicle:
2009 3.0R Impreza
Dark grey/light black?

Default

Quote:
Originally Posted by lodown1 View Post
Have you contacted Wiles driveshafts?

they are in Paris TN.

https://www.wilesracingdriveshafts.com

I used them for the custom 1 piece steel drive shaft that i needed for my forester to mate up to a BRZ 6 speed. I am pretty sure it was about $350-400, the only issue I had was that the rear flange bolt pattern will only fit the larger r180 version.

I've wanted to try to stay away from the one piece drive shafts, but if this one doesn't work out, I'm going to feel like there really isn't another option so we'll see.
Kito818 is offline   Reply With Quote
Old 03-13-2019, 09:31 PM   #3585
vicious_fishes
Scooby Guru
 
Member#: 158864
Join Date: Sep 2007
Location: Aussieland
Vehicle:
2003 SOHC destroker

Default

Just had the brown EZ30R injectors flow tested - they're 240cc.
vicious_fishes is offline   Reply With Quote
Old 03-13-2019, 10:09 PM   #3586
Kito818
Scooby Newbie
 
Member#: 480045
Join Date: Jan 2018
Chapter/Region: South East
Location: Murfreesboro, TN
Vehicle:
2009 3.0R Impreza
Dark grey/light black?

Default

Quote:
Originally Posted by vicious_fishes View Post
Just had the brown EZ30R injectors flow tested - they're 240cc.
good to know, actually.
Kito818 is offline   Reply With Quote
Old 03-16-2019, 08:16 PM   #3587
Kito818
Scooby Newbie
 
Member#: 480045
Join Date: Jan 2018
Chapter/Region: South East
Location: Murfreesboro, TN
Vehicle:
2009 3.0R Impreza
Dark grey/light black?

Default

Well bit of a mixed bag of news this weekend. OBX headers came in so thats good, 08-14 STI drive shaft is the right length, so that is also good, however, drive shaft doesnt mate with the differential, and the U-joint barrings are different sizes. The pictures do a better job of telling the story, but seems like I'm not going to be driving the car this weekend.


https://photos.app.goo.gl/Zn2BGENKrD87fcd86
Kito818 is offline   Reply With Quote
Old 03-18-2019, 08:08 PM   #3588
Kito818
Scooby Newbie
 
Member#: 480045
Join Date: Jan 2018
Chapter/Region: South East
Location: Murfreesboro, TN
Vehicle:
2009 3.0R Impreza
Dark grey/light black?

Default

https://photos.app.goo.gl/LsKa3HYDYbCw6APr5 exhaust headers are installed, turned the engine over and it basically barked at me before dying, but it does "start". In the short time of 2 seconds, the engine turns over, ignites, spins up to 1200-1300rpm and dies with a backfire. I'm not sure where the issue is just yet, but its getting closer.
Kito818 is offline   Reply With Quote
Old 03-21-2019, 08:25 AM   #3589
H6Bugeye
Scooby Newbie
 
Member#: 499357
Join Date: Mar 2019
Default 2006 Gen4 EZ30 Auto wiring diagram.

Hey guys.

I've just purchased a EZ30 conversion package to install into my GDA (bugeye). The GDA is originally a EJ205/5MT and I am moving to a EZ30/5AT combo.

The items I have purchased. Engine (complete) with 5AT still attached, gearbox x member, tailshaft and rear R180 diff, rear drive shafts, front drive shafts, radiator, Engine ECU and complete wiring loom, shifter, pedal box, accelerator pedal (because DBW lol).

Does anyone have a copy of the factory 06 Liberty repair manual. I need detailed wiring diagrams so I can marry the EZ30 ECU to the existing wiring in my vehicle.

I have a copy of the GDA factory repair manual and the wiring schematics are excellent and well laid out. Being able to hunt down the factory repair manual for the Liberty would be an absolute god send!

Thanks lads.
H6Bugeye is offline   Reply With Quote
Old 03-21-2019, 08:49 AM   #3590
choover1101
Scooby Newbie
 
Member#: 459742
Join Date: Dec 2016
Default

Go to legacygt.com and check in the 3rd gen section.
choover1101 is offline   Reply With Quote
Old 03-21-2019, 03:16 PM   #3591
Kito818
Scooby Newbie
 
Member#: 480045
Join Date: Jan 2018
Chapter/Region: South East
Location: Murfreesboro, TN
Vehicle:
2009 3.0R Impreza
Dark grey/light black?

Default

Quote:
Originally Posted by H6Bugeye View Post
Hey guys.

I've just purchased a EZ30 conversion package to install into my GDA (bugeye). The GDA is originally a EJ205/5MT and I am moving to a EZ30/5AT combo.

The items I have purchased. Engine (complete) with 5AT still attached, gearbox x member, tailshaft and rear R180 diff, rear drive shafts, front drive shafts, radiator, Engine ECU and complete wiring loom, shifter, pedal box, accelerator pedal (because DBW lol).

Does anyone have a copy of the factory 06 Liberty repair manual. I need detailed wiring diagrams so I can marry the EZ30 ECU to the existing wiring in my vehicle.

I have a copy of the GDA factory repair manual and the wiring schematics are excellent and well laid out. Being able to hunt down the factory repair manual for the Liberty would be an absolute god send!

Thanks lads.
http://jdmfsm.info/Auto/Japan/Subaru..._Outback/2006/

if you click the folder icon you'll have a guided manual with wiring diagrams, or you can click the PDF and just download the whole book.

Just a heads up, the factory ECU likely will not work for you since the BCU won't want to be nice, you may want to prepare for a standalone ECU. That said there's no reason not to try so do let us know if you can get them talking.
Kito818 is offline   Reply With Quote
Old 03-22-2019, 07:25 AM   #3592
H6Bugeye
Scooby Newbie
 
Member#: 499357
Join Date: Mar 2019
Default

Quote:
Originally Posted by Kito818 View Post
http://jdmfsm.info/Auto/Japan/Subaru..._Outback/2006/

if you click the folder icon you'll have a guided manual with wiring diagrams, or you can click the PDF and just download the whole book.

Just a heads up, the factory ECU likely will not work for you since the BCU won't want to be nice, you may want to prepare for a standalone ECU. That said there's no reason not to try so do let us know if you can get them talking.
Thanks for the link mate. I've been in contact with a company here in Australia that specializes in merging looms from CAN BUS/non CAN BUS subaru vehicles including the CAN BUS emulator required to delete the Liberty instrument cluster and ABS/VSC systems.

I'll post up some details once I have spoken them in depth about costs and which of the factory components needs to be retained.

Cheers
H6Bugeye is offline   Reply With Quote
Old 03-22-2019, 07:29 AM   #3593
H6Bugeye
Scooby Newbie
 
Member#: 499357
Join Date: Mar 2019
Default

Here is a link to the company here in Australia.

http://www.agtengineering.com.au/canbus.html

I'll ask them if they would be willing to deal with overseas customers.
H6Bugeye is offline   Reply With Quote
Old 03-22-2019, 08:21 AM   #3594
Kito818
Scooby Newbie
 
Member#: 480045
Join Date: Jan 2018
Chapter/Region: South East
Location: Murfreesboro, TN
Vehicle:
2009 3.0R Impreza
Dark grey/light black?

Default

Quote:
Originally Posted by H6Bugeye View Post
Here is a link to the company here in Australia.

http://www.agtengineering.com.au/canbus.html

I'll ask them if they would be willing to deal with overseas customers.
Good luck with the build and keep us posted. Hoping to have mine idle this weekend.
Kito818 is offline   Reply With Quote
Old 04-09-2019, 12:07 PM   #3595
vicious_fishes
Scooby Guru
 
Member#: 158864
Join Date: Sep 2007
Location: Aussieland
Vehicle:
2003 SOHC destroker

Default

I used the guys in sydney to emulate the dash cluster signal and my wiring guy, after 100+ successful merges, could not get it to play nice. I had the first car he's ever not been able to merge.

The only guys I've even heard of doing it successfully are gotitrex (they have a facebook page), and that's only a claim, I haven't actually seen the car.
vicious_fishes is offline   Reply With Quote
Old 04-09-2019, 12:30 PM   #3596
Kito818
Scooby Newbie
 
Member#: 480045
Join Date: Jan 2018
Chapter/Region: South East
Location: Murfreesboro, TN
Vehicle:
2009 3.0R Impreza
Dark grey/light black?

Default

Quote:
Originally Posted by vicious_fishes View Post
The only guys I've even heard of doing it successfully are gotitrex (they have a facebook page), and that's only a claim, I haven't actually seen the car.
As they say, 'Pics or it didn't happen', right?
Kito818 is offline   Reply With Quote
Old 04-09-2019, 03:46 PM   #3597
Kito818
Scooby Newbie
 
Member#: 480045
Join Date: Jan 2018
Chapter/Region: South East
Location: Murfreesboro, TN
Vehicle:
2009 3.0R Impreza
Dark grey/light black?

Default

I have a question, I've only been idling the car, I have to bleed the clutch before I can take it for a drive, but I don't seem to be moving water. The upper radiator hoses are hot but the lower hose is only hot close to the thermostat housing and cold at the radiator. I'm also not getting hot air in the cabin. I've kind of written off the heater core hoses being backwards, as this shouldn't even be a issue if they were, but I'll be honest I've not tried swapping them. Is there a one way valve for the heater core? The water pump is chain driven and the engine seems to run pretty well, ish since there's no exhaust after the headers and thus the wideband sensors have just been unpluged, but widebands installed or not shouldn't have an affect on water movement. Have I just not reved the engine enough to actually move the water, again it's only idled, or is there something I'm missing?
Kito818 is offline   Reply With Quote
Old 04-09-2019, 03:54 PM   #3598
choover1101
Scooby Newbie
 
Member#: 459742
Join Date: Dec 2016
Default

What brand Thermostat? With the 4 cyl motors putting a non Subaru thermostat can cause this. The non OEM thermostats dont open as far as the Subaru ones and they often wont clear the metal lip inside the thermostat housing when opened.
choover1101 is offline   Reply With Quote
Old 04-09-2019, 04:07 PM   #3599
Kito818
Scooby Newbie
 
Member#: 480045
Join Date: Jan 2018
Chapter/Region: South East
Location: Murfreesboro, TN
Vehicle:
2009 3.0R Impreza
Dark grey/light black?

Default

Quote:
Originally Posted by choover1101 View Post
What brand Thermostat? With the 4 cyl motors putting a non Subaru thermostat can cause this. The non OEM thermostats dont open as far as the Subaru ones and they often wont clear the metal lip inside the thermostat housing when opened.
autozone's ultrastat or something like that. The one that is supposed to stick open if it fails.
Kito818 is offline   Reply With Quote
Old 04-10-2019, 12:48 AM   #3600
choover1101
Scooby Newbie
 
Member#: 459742
Join Date: Dec 2016
Default

That is one of the few Subaru only areas. I would switch it.
choover1101 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Vag-Com cable resource thread cooleys04 Open Source Reflashes 283 04-03-2018 02:04 PM
The Impreza @$$ Thread - The Beautiful Impreza Backside! PICS! Upscale_Automotive Member's Car Gallery 8 10-03-2007 05:56 AM
The 2008 Impreza Photoshop thread...post them here adizon Member's Car Gallery 307 09-20-2007 12:36 AM
The 2006 Impreza/Impreza WRX/Impreza WRX-STi thread (merged thread) wrxpeed News & Rumors 938 05-17-2005 12:11 AM
Photo - Anders "loving on" the H6 Impreza Fred South East Region Forum 8 02-23-2004 06:04 PM

All times are GMT -4. The time now is 04:50 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.