Welcome to the North American Subaru Impreza Owners Club Saturday January 18, 2020
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 08-08-2011, 02:44 PM   #1901
Kean
Scooby Guru
 
Member#: 25187
Join Date: Sep 2002
Location: So. CA
Vehicle:
'08 Foz Prem TGM
'10 Challenger R/T Blk

Default

Quote:
Originally Posted by carstenhpr View Post
Current Milage: 12,050~ on the higher end of that I think.

Most current update I got today is that the general manager of the dealership I purchased the vehicle from it getting involved now. He's speaking with the dealership that has my car and also his regional SOA rep. Wish we luck guys :|
....that sounds like your best bet. btw, did they sell you the car under an official Subaru used car program?
* Registered users of the site do not see these ads.
Kean is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-08-2011, 03:21 PM   #1902
carstenhpr
Scooby Newbie
 
Member#: 290805
Join Date: Aug 2011
Location: KY
Vehicle:
2011 WRX STi Limited
Silver

Default

I will be the first to admit when I'm wrong and I know I've made mistakes. My previous cars that I owned didn't require nearly as much maitence or attention(to the oil level and other fluids). I didn't do my research before the purchase or immediately afterwards either. That was a rough month for me and my job. My schedule was not flexable enough to get it to the dealership as early as I should of. In restrospect I really could of taken the time to do it, had I known what I know now but I didn't for see any big problems like this.
carstenhpr is offline   Reply With Quote
Old 08-08-2011, 03:31 PM   #1903
SpamBot
Scooby Specialist
 
Member#: 287534
Join Date: Jul 2011
Default

If SOA is already denying coverage, it's quite possible that this VIN was flagged for abuse under the first owner. Any subsequent failure, despite a change of ownership, would not be covered.

If you have any beef, it's with the dealership that sold you the car. Unless you're not being completely upfront with your driving habits, the dealership should have known there were issues with the car when they performed the used vehicle inspection (they are a joke, by the way). If the VIN had already been flagged, a simple check online would have told them that.
SpamBot is offline   Reply With Quote
Old 08-10-2011, 12:30 AM   #1904
carstenhpr
Scooby Newbie
 
Member#: 290805
Join Date: Aug 2011
Location: KY
Vehicle:
2011 WRX STi Limited
Silver

Default

Newest update on issue: Got a call from the dealership I purchased the vehicle from. They are going to cover everything. Subaru is going to pay 1500 of the repairs as a goodwill gesture (honestly was expecting more). Subaru told me they would pay for a small block before the dealership stepped up. I'm very grateful for my current situation right now because it was looking quite grim for a few weeks.

I hope this vehicle isn't a lemon and I won't be a regular in this thread.
carstenhpr is offline   Reply With Quote
Old 08-13-2011, 02:31 PM   #1905
Boostpw
Scooby Newbie
 
Member#: 145513
Join Date: Apr 2007
Chapter/Region: South East
Location: Orlando
Vehicle:
07 STI
SWP

Default

deleted

Last edited by Boostpw; 09-13-2011 at 07:02 AM. Reason: getting lawyerd up..
Boostpw is offline   Reply With Quote
Old 08-17-2011, 11:18 AM   #1906
hoeser
Scooby Newbie
 
Member#: 290350
Join Date: Aug 2011
Location: Ontario, Canada
Vehicle:
2011 STi Sedan
White

Default

Name: Hoeser

Make: 2011 STi

Mileage: 6500km (not a typo, six five zero zero)

Time Out Of Use: total should be around 10 weeks...

Problem And Likely Cause: Ringland failure, cylinder 4 - likely cause: terrible 08+ pistons.

Modifications: COBB Stage 2+, Catted invidia downpipe, Q300 catback, Cobb intake.

Submitted For Warranty Work (Yes/No): Yes

Reason Given For Denial: Modifications caused failure, TSB given around ringland failure "not caused by weak material"

Your Story: http://forums.nasioc.com/forums/show...php?p=34775290
hoeser is offline   Reply With Quote
Old 08-22-2011, 09:33 PM   #1907
09WRXNE
Scooby Newbie
 
Member#: 291962
Join Date: Aug 2011
Location: North East NY
Vehicle:
13 WRX
ICM

Default

Name :09WRXNE

Make: 2009 WRX Premium

Milage: 13,500

Time out of use : three weeks and counting.

Problem: spun bearing

Mods: none that I knew of

Submitted for warranty work : yes / denied. Will provide good faith repairs. But I need to buy new ECM.

Reason given : ECM was modified.

I haven't modded or done anything but drive to and from work in traffic since I purchased the car.
09WRXNE is offline   Reply With Quote
Old 08-22-2011, 09:58 PM   #1908
Kean
Scooby Guru
 
Member#: 25187
Join Date: Sep 2002
Location: So. CA
Vehicle:
'08 Foz Prem TGM
'10 Challenger R/T Blk

Default

Quote:
Originally Posted by 09WRXNE View Post
Name :09WRXNE

Make: 2009 WRX Premium

Milage: 13,500

Time out of use : three weeks and counting.

Problem: spun bearing

Mods: none that I knew of

Submitted for warranty work : yes / denied. Will provide good faith repairs. But I need to buy new ECM.

Reason given : ECM was modified.

I haven't modded or done anything but drive to and from work in traffic since I purchased the car.
....did you buy it used? ...and if so, was it from a private party or dealer?
Kean is offline   Reply With Quote
Old 08-22-2011, 10:12 PM   #1909
blackfang
Scooby Guru
 
Member#: 131347
Join Date: Nov 2006
Chapter/Region: MAIC
Location: Richmond Va
Vehicle:
2007 Legacy 2.5i SE
98 Z/28, VN 900 custom

Default

He bought it via private party.
blackfang is offline   Reply With Quote
Old 08-22-2011, 10:16 PM   #1910
09rexwagon
Scooby Specialist
 
Member#: 216135
Join Date: Jul 2009
Vehicle:
2011

Default

Was that car in the 'bad' range of VINs/mfg dates?
09rexwagon is offline   Reply With Quote
Old 08-22-2011, 10:39 PM   #1911
09WRXNE
Scooby Newbie
 
Member#: 291962
Join Date: Aug 2011
Location: North East NY
Vehicle:
13 WRX
ICM

Default

Yeah 7/21/08 build date. SOA felt because of the ECM mod they would only good will repair it. Said there engineers reviewed it and found the cause to be the mod.
09WRXNE is offline   Reply With Quote
Old 08-22-2011, 10:40 PM   #1912
09WRXNE
Scooby Newbie
 
Member#: 291962
Join Date: Aug 2011
Location: North East NY
Vehicle:
13 WRX
ICM

Default

Yes private party purchase.

SOA could have totally denied it or they could have authorized the long block. They good willed it, and the dealer will start with the small block and work through the repair. Hopefully it all gets done and I have no more issues.

Last edited by 09WRXNE; 08-22-2011 at 10:45 PM.
09WRXNE is offline   Reply With Quote
Old 08-22-2011, 10:43 PM   #1913
09rexwagon
Scooby Specialist
 
Member#: 216135
Join Date: Jul 2009
Vehicle:
2011

Default

Quote:
Originally Posted by 09WRXNE View Post
Yeah 7/21/08 build date. SOA felt because of the ECM mod they would only good will repair it. Said there engineers reviewed it and found the cause to be the mod.
Haha, so the other 900 cars they did NOT goodwill due to a manufacturing flaw and fixedn under warranty instead, they randomly found one car that they could *definitively* say was a modification that resulted in the spun bearing?!!!??!?!?
09rexwagon is offline   Reply With Quote
Old 08-22-2011, 10:55 PM   #1914
09WRXNE
Scooby Newbie
 
Member#: 291962
Join Date: Aug 2011
Location: North East NY
Vehicle:
13 WRX
ICM

Default

Guess so.
09WRXNE is offline   Reply With Quote
Old 08-31-2011, 08:28 AM   #1915
09WRXNE
Scooby Newbie
 
Member#: 291962
Join Date: Aug 2011
Location: North East NY
Vehicle:
13 WRX
ICM

Default

Still havent gotten the car back. Stopped by the dealership last night, service writer pulled up my info an told me he didn't know anything about my car. Drove around back and it's sitting there with a catch can under the car. Doesn't look like it's moved in a while.

How can he not know what's going on? Isn't almost everything they do logged?

I'm in a loaner, but the cars been there about a month now. WTF?
09WRXNE is offline   Reply With Quote
Old 09-14-2011, 10:01 PM   #1916
TDOVEL
Scooby Newbie
 
Member#: 278239
Join Date: Mar 2011
Default 2011 wrx prem

Is anyone else having an issue with getting car into reverse?!?! And also downshifting from 5 to 4??? I have taken the car to the dealership twice. First time they changed the transmission fluid, which didn't help and this was when the downshifting issue started, the second attempt was with the sabaru field rep, which he said he could not reproduce the issue. Even though I was able to and even the service manager. I then recd a call with a Subaru rep from NJ, stating that this happens to all subaru with manual transmission.... This is my first Subaru but not my first manual. Is this normal for Subaru?!?!?
TDOVEL is offline   Reply With Quote
Old 09-14-2011, 10:32 PM   #1917
JamesWilson2
ForumWars Winner!
 
Member#: 196948
Join Date: Dec 2008
Chapter/Region: TXIC
Location: Kyle, TX
Vehicle:
2003 Forester
Silver

Default

My '11 has been having problems going into reverse this week, may take it in this weekend. Very strange.
JamesWilson2 is offline   Reply With Quote
Old 09-14-2011, 11:17 PM   #1918
CosmoTheCat
Scooby Newbie
 
Member#: 3409
Join Date: Jan 2001
Chapter/Region: NWIC
Location: Oly
Vehicle:
98 My FMIC
Is bigger than yours.

Default

Quote:
Originally Posted by 09WRXNE View Post
Still havent gotten the car back. Stopped by the dealership last night, service writer pulled up my info an told me he didn't know anything about my car. Drove around back and it's sitting there with a catch can under the car. Doesn't look like it's moved in a while.

How can he not know what's going on? Isn't almost everything they do logged?

I'm in a loaner, but the cars been there about a month now. WTF?
So what was modded in your ECM? Did someone put an open source tune in it? If so, why would that require you buying a new ECM?

So SOA decided to goodwill the engine, pending you buying the ECM - did you buy the ECM? It usually doesn't take that long for an engine to show up in a crate, but your service advisor may have to actually order the engine for it to show up.
CosmoTheCat is offline   Reply With Quote
Old 09-15-2011, 01:18 PM   #1919
Scooby207
Scooby Specialist
 
Member#: 255687
Join Date: Aug 2010
Chapter/Region: NESIC
Location: Maine
Vehicle:
11 WRX DGM

Default

Name: Scooby207

Make: 2009 Impreza Outback Sport

Mileage: 59,217 miles

Time Out Of Use: 1 day and counting

Problem And Likely Cause: Blown engine

Modifications: None

Submitted For Warranty Work (Yes/No): Yes

Reason Given For Denial: None yet

Your Story: Car died unexpectedly / towed to subaru dealer/ diagnosis was a blown engine/ service records under review

more to come...

Last edited by Scooby207; 09-15-2011 at 01:43 PM.
Scooby207 is offline   Reply With Quote
Old 09-15-2011, 09:03 PM   #1920
TDOVEL
Scooby Newbie
 
Member#: 278239
Join Date: Mar 2011
Default

Good luck with that SOA stating that is normal on all their manuals... Keep us posted on the outcome...
TDOVEL is offline   Reply With Quote
Old 09-15-2011, 11:08 PM   #1921
Scooby207
Scooby Specialist
 
Member#: 255687
Join Date: Aug 2010
Chapter/Region: NESIC
Location: Maine
Vehicle:
11 WRX DGM

Default

Quote:
Originally Posted by Scooby207 View Post
Name: Scooby207

Make: 2009 Impreza Outback Sport

Mileage: 59,217 miles

Time Out Of Use: 1 day and counting

Problem And Likely Cause: Blown engine

Modifications: None

Submitted For Warranty Work (Yes/No): Yes

Reason Given For Denial: None yet

Your Story: Car died unexpectedly / towed to subaru dealer/ diagnosis was a blown engine/ service records under review

more to come...
service manager couldn't tell me anything about what happened. Said they would get the technician(s) who worked on it to make sure they were specific in their findings. All i know at this point is "your engine is blown". They did say my oil was almost non existent (even though no light ever came on and i have followed my service schedule for the entire (2 1/2 year) life of the car. Obviously the engine needs oil or it will seize up so is this what happened????why didn't a light come on if i was dangerously low on oil????? not even a check engine light except for about 2 seconds before it clunked out. I want to understand what happened so i can have some piece of mind....is this something i will ever know? If it is something i did wrong, i can accept that but i would just like to know what it could have been that i did or didn't do...

on a happier note they are relacing my engine since it is still under warranty and i got a loaner
Scooby207 is offline   Reply With Quote
Old 09-15-2011, 11:21 PM   #1922
jonklein611
Scooby Specialist
 
Member#: 117776
Join Date: Jun 2006
Chapter/Region: MAIC
Location: Moon Twp, PA
Vehicle:
2011 WRX Limited 5dr
WR Blue Pearl

Default

How often do you check your oil??
jonklein611 is offline   Reply With Quote
Old 09-16-2011, 10:16 AM   #1923
09rexwagon
Scooby Specialist
 
Member#: 216135
Join Date: Jul 2009
Vehicle:
2011

Default

Quote:
Originally Posted by Scooby207 View Post
service manager couldn't tell me anything about what happened. Said they would get the technician(s) who worked on it to make sure they were specific in their findings. All i know at this point is "your engine is blown". They did say my oil was almost non existent (even though no light ever came on and i have followed my service schedule for the entire (2 1/2 year) life of the car. Obviously the engine needs oil or it will seize up so is this what happened????why didn't a light come on if i was dangerously low on oil????? not even a check engine light except for about 2 seconds before it clunked out. I want to understand what happened so i can have some piece of mind....is this something i will ever know? If it is something i did wrong, i can accept that but i would just like to know what it could have been that i did or didn't do...

on a happier note they are relacing my engine since it is still under warranty and i got a loaner
There is no oil level warning light. You have to check it proactively.

There is an oil pressure light. But when that comes on your engines is basically done for anyway.
09rexwagon is offline   Reply With Quote
Old 09-16-2011, 10:20 AM   #1924
jonklein611
Scooby Specialist
 
Member#: 117776
Join Date: Jun 2006
Chapter/Region: MAIC
Location: Moon Twp, PA
Vehicle:
2011 WRX Limited 5dr
WR Blue Pearl

Default

Quote:
Originally Posted by 09rexwagon
There is no oil level warning light. You have to check it proactively.

There is an oil pressure light. But when that comes on your engines is basically done for anyway.
Bingo. We should all be in the habit of checking every fuel stop. Seriously, you can pop the hood, wipe, dip, check, and close the hood before the tank fills up. For those that don't, you have no excuse when your engine goes boom.
jonklein611 is offline   Reply With Quote
Old 09-17-2011, 01:07 AM   #1925
Scooby207
Scooby Specialist
 
Member#: 255687
Join Date: Aug 2010
Chapter/Region: NESIC
Location: Maine
Vehicle:
11 WRX DGM

Default

i check my oil before i head to Massachusetts from Maine which i do about once a month for business and whenever else know i will be driving a long distance but certainly not every fill up... i guess i learned my lesson but there must have been some problem that lead to me running out of oil right? I mean i couldn't have possibly just burnt through all my oil? how many miles would that take? (normal daily driving, car has never seen a track and has no mods????) i am in for an oil change ever 3,000 miles!!!??? I was surprised to hear that no warning light would have come on... if i had a leak and lost a lot of oil fast would the oil pressure light come on?
Scooby207 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble/Warranty Denial Report Thread: Electrical (Lighting, ECU, Sensors, Etc.) North Ursalia Warranty Issues & SOA Problems 141 10-26-2019 01:59 PM
Trouble/Warranty Denial Report Thread: Suspension North Ursalia Warranty Issues & SOA Problems 58 10-19-2019 05:03 PM
Trouble/Warranty Denial Report Thread: Braking System North Ursalia Warranty Issues & SOA Problems 97 09-27-2019 01:46 PM
Trouble/Warranty Denial Report Thread: Body/Exterior of Vehicle North Ursalia Warranty Issues & SOA Problems 146 03-02-2019 01:31 PM
Trouble/Warranty Denial Report Thread: Interior North Ursalia Warranty Issues & SOA Problems 71 11-14-2018 09:18 AM

All times are GMT -4. The time now is 12:56 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2020 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.