Welcome to the North American Subaru Impreza Owners Club Thursday July 18, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
South West Impreza Club
Go Back   NASIOC > NASIOC Chapters > South West Impreza Club Forum -- SWIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 06-24-2019, 05:32 PM   #1
Switters922
Scooby Newbie
 
Member#: 464538
Join Date: Mar 2017
Default Vegas Mechanic?

Anyone know a good shop/mecahnic in Vegas? Just recently moved to the area and I took drove my car to L.A. and back this past weekend. While I was there we went to a dodger game and while waiting to get thru the line to the parking lot my car started producing white smoke. We were on a pretty steep hill and I was constantly going from a dead stop to moving like 1 car length for about 45 mins before the smoke started showing up.

After getting thru and parking I popped the hood and everything looked fine, oil level was good and fluid levels were fine. Now when I shift into 1st there is a vibration that happens before it fully gets into gear (sort of like the vibration that happens before stalling) but it only occurs sometimes.

My car is a '16 WRX with only 38K miles on it. Any help would be greatly appreciated!
* Registered users of the site do not see these ads.
Switters922 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 06-24-2019, 10:03 PM   #2
DrD
Scooby Guru
 
Member#: 22412
Join Date: Aug 2002
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2012 Legacy 2.5GT
Ice Silver Metallic

Default

sounds like maybe you rode the clutch a bit and now it's chattering?
DrD is offline   Reply With Quote
Old 06-24-2019, 10:54 PM   #3
AZ-GT
NASIOC Supporter
 
Member#: 192
Join Date: Aug 1999
Chapter/Region: SWIC
Location: Las Vegas, NV.
Vehicle:
2011 WRB WRX
2000 Impreza 2.5RS

Default

Local Subaru mechanic/shop...

http://www.route69racing.com/
AZ-GT is offline   Reply With Quote
Old 06-25-2019, 01:38 PM   #4
Switters922
Scooby Newbie
 
Member#: 464538
Join Date: Mar 2017
Default

Quote:
Originally Posted by DrD View Post
sounds like maybe you rode the clutch a bit and now it's chattering?
I made sure to disengage the clutch every time I stopped, but yeah it does seem to be chattering. Or at least it did seem to be that way since now the vibration has almost completely gone away.
Switters922 is offline   Reply With Quote
Old 06-25-2019, 01:38 PM   #5
Switters922
Scooby Newbie
 
Member#: 464538
Join Date: Mar 2017
Default

Quote:
Originally Posted by AZ-GT View Post
Local Subaru mechanic/shop...

http://www.route69racing.com/
Thank you!
Switters922 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 07:09 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.