Welcome to the North American Subaru Impreza Owners Club Wednesday September 20, 2017
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid Atlantic Impreza Club
Mid Atlantic Impreza Club Forum sponsored by Annapolis Subaru
Go Back   NASIOC > NASIOC Chapters > Mid Atlantic Impreza Club -- MAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 09-07-2017, 10:55 PM   #4026
carnz-pj-410
Scooby Specialist
 
Member#: 110994
Join Date: Mar 2006
Chapter/Region: MAIC
Location: Atlantic
Vehicle:
2017 Chevy SS 6MT
Heron White

Default

My 95 Impreza IG switch did what you are describing. Replaced it with a new unit and all was well!
* Registered users of the site do not see these ads.
carnz-pj-410 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 09-08-2017, 09:25 AM   #4027
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
1996 Impreza coupe

Default

Quote:
Originally Posted by carnz-pj-410 View Post
My 95 Impreza IG switch did what you are describing. Replaced it with a new unit and all was well!
Good to know. Were you able to get it keyed to your old key (so the door locks and trunk still match), did you change out all the locks, or did you just end up with 2 different keys?
Patrick Olsen is offline   Reply With Quote
Old 09-08-2017, 09:57 AM   #4028
carnz-pj-410
Scooby Specialist
 
Member#: 110994
Join Date: Mar 2006
Chapter/Region: MAIC
Location: Atlantic
Vehicle:
2017 Chevy SS 6MT
Heron White

Default

Quote:
Originally Posted by Patrick Olsen View Post
Good to know. Were you able to get it keyed to your old key (so the door locks and trunk still match), did you change out all the locks, or did you just end up with 2 different keys?
I was able to buy the ignition switch from Subaru and i swapped my key lock cylinder to the new IG switch. No key change required
carnz-pj-410 is offline   Reply With Quote
Old 09-08-2017, 10:31 AM   #4029
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
1996 Impreza coupe

Default

Ahhh, got it. I was thinking the entire cylinder, not just the switch. Cool, thanks.

Edit: Looks like my '97 Legacy uses the same part. Since it's dead in the garage, I could cannibalize the part from the Legacy to see if that fixes the problem on the Impreza.
Patrick Olsen is offline   Reply With Quote
Old 09-11-2017, 06:22 PM   #4030
corona672
Scooby Newbie
 
Member#: 262902
Join Date: Nov 2010
Location: Arlington, VA
Vehicle:
'04 WRX Hybrid
It's a wrap!

Default

T9 at summit point flagger called out 'we just witnessed a hell of an event' as I stumbled off track hot into the pits formula D style.

How did this happen??? Checked torques before event, no other warning signs/vibrations. Hub is broken missing about a half inch of spindle - the rest is still on the axle, wheel bearing shot, and the axle sheared at the chamfer between the spline and the thread.

The bearing and hub were new this season, unsure on axle age.



corona672 is online now   Reply With Quote
Old 09-11-2017, 11:59 PM   #4031
Lagunagreen
Scooby Newbie
 
Member#: 410537
Join Date: Jan 2015
Chapter/Region: MAIC
Location: 25401
Vehicle:
2002 Wrx Sedan
Wrb

Default

too much powaa or because racecar.
Lagunagreen is offline   Reply With Quote
Old 09-12-2017, 12:10 AM   #4032
corona672
Scooby Newbie
 
Member#: 262902
Join Date: Nov 2010
Location: Arlington, VA
Vehicle:
'04 WRX Hybrid
It's a wrap!

Default

Way too much racecar
corona672 is online now   Reply With Quote
Old 09-12-2017, 09:02 PM   #4033
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
1996 Impreza coupe

Default

Quote:
Originally Posted by corona672 View Post


Could you post some smaller pictures? I prefer to not be able to see any details at all.

Seriously, though, I've never seen/heard of that happening.
Patrick Olsen is offline   Reply With Quote
Old 09-12-2017, 10:07 PM   #4034
corona672
Scooby Newbie
 
Member#: 262902
Join Date: Nov 2010
Location: Arlington, VA
Vehicle:
'04 WRX Hybrid
It's a wrap!

Default

I blame my phone

http://i.imgur.com/gAeFaTi.jpg
http://i.imgur.com/xz68piS.jpg

Quote:
Originally Posted by Patrick Olsen View Post
Seriously, though, I've never seen/heard of that happening.
Man those hoosiers have some grip!

It is frustrating, because until I know the cause of failure - I can't scope how much replacement or preventive maintenance on the other side I need to do.. I'll have to tear-down and investigate more soon

I'm leaning towards an out of spec knuckle. I had a tech help push out a race with his press a few events ago, but I failed to mention he should probably take out the lock ring first.. very suspect.

Last edited by corona672; 09-12-2017 at 10:25 PM.
corona672 is online now   Reply With Quote
Old 09-15-2017, 01:22 PM   #4035
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
1996 Impreza coupe

Default

Quote:
Originally Posted by Patrick Olsen View Post
Quote:
Originally Posted by carnz-pj-410 View Post
I was able to buy the ignition switch from Subaru and i swapped my key lock cylinder to the new IG switch. No key change required
Ahhh, got it. I was thinking the entire cylinder, not just the switch. Cool, thanks.

Edit: Looks like my '97 Legacy uses the same part. Since it's dead in the garage, I could cannibalize the part from the Legacy to see if that fixes the problem on the Impreza.
Just pulled the switch out of the Legacy and installed it in the Impreza. Good to go. (Well, at least it gave proper indications and started the first time. Hopefully it continues to do that with some more cycles.) Thanks for pointing me in the right direction, carnz-pj.

- Dug through my spare nuts 'n' bolts bins and found some replacement fasteners for ones that I discovered were missing while I was replacing the ignition switch. Not sure what it's called exactly, but the metal cover plate on the bottom of the steering column had only 1 of the 4 screws holding it in place. Now it has 4.

- Replaced the positive battery terminal.
Patrick Olsen is offline   Reply With Quote
Old 09-17-2017, 02:14 PM   #4036
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
1996 Impreza coupe

Default

- Reconnected the speedo cable in the Impreza. It had popped off the back of the speedo the other day. I guess I inadvertently tugged on it or something while I was digging around under the dash during the brake switch troubleshooting. Went for a quick spin and verified the speedo is operational again.

Doesn't seem like the cable has anything in the way of a clip to keep it in position. The speedo cable on my Fox Mustang has a plastic clip that you have to press down to disengage the cable from the back of the speedo, kind of like a wiring harness connector.
Patrick Olsen is offline   Reply With Quote
Old 09-17-2017, 02:19 PM   #4037
2slofouru
NASIOC Supporter
 
Member#: 90539
Join Date: Jul 2005
Chapter/Region: South East
Location: Lake Charles
Vehicle:
My BOV goes
COVFEFE!

Default

Attempted to "Wipe New" the dashboard and all plastic pieces I removed from the impreza yesterday...and the wipe new was hardened in the bottle. Apparently I will be driving to town and buying another bottle shortly, since all of the parts are now in my way.
2slofouru is offline   Reply With Quote
Old 09-18-2017, 01:18 PM   #4038
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
1996 Impreza coupe

Default

Hmmm, I have a bottle of that stuff somewhere in the garage, not sure I've ever used it. Wonder if the bottle I've got is also dead?
Patrick Olsen is offline   Reply With Quote
Old 09-18-2017, 01:30 PM   #4039
Loya1ty
Scooby Newbie
 
Member#: 383680
Join Date: Mar 2014
Chapter/Region: MAIC
Location: NOVA
Vehicle:
2008 Impreza 2.5i
Newport Blue Pearl

Default

Bought new Car Wash and Polishing kit.. didn't wash my car.
Loya1ty is offline   Reply With Quote
Old 09-18-2017, 03:30 PM   #4040
carnz-pj-410
Scooby Specialist
 
Member#: 110994
Join Date: Mar 2006
Chapter/Region: MAIC
Location: Atlantic
Vehicle:
2017 Chevy SS 6MT
Heron White

Default

Ordered some more parts for my 2nd 95 Impreza Coupe, hopefully i'll have it road ready soon

simple 1.8L 4EAT FWD car, just a beater
carnz-pj-410 is offline   Reply With Quote
Old 09-18-2017, 03:30 PM   #4041
carnz-pj-410
Scooby Specialist
 
Member#: 110994
Join Date: Mar 2006
Chapter/Region: MAIC
Location: Atlantic
Vehicle:
2017 Chevy SS 6MT
Heron White

Default

Ordered some more parts for my 2nd 95 Impreza Coupe, hopefully i'll have it road ready soon

simple 1.8L 4EAT FWD car, just a beater
carnz-pj-410 is offline   Reply With Quote
Old 09-18-2017, 09:16 PM   #4042
2slofouru
NASIOC Supporter
 
Member#: 90539
Join Date: Jul 2005
Chapter/Region: South East
Location: Lake Charles
Vehicle:
My BOV goes
COVFEFE!

Default

Quote:
Originally Posted by Patrick Olsen View Post
Hmmm, I have a bottle of that stuff somewhere in the garage, not sure I've ever used it. Wonder if the bottle I've got is also dead?
If you had it for several months, possibly hardened. I bought another bottle and did all of the dash, console, steering pieces, etc. It basically made them have super gloss and darkened some a little.

The dash has only been faded for maybe six months, it was nice and dark before. The Wipe New didn't do any type of miracle on the dash, it had lots of dry looking areas after coating it last night. I coated it again tonight and it seems to have helped a little, but won't know until tomorrow.

I used something similar a few years ago on my other impreza and remember it lasting a few months then fading again. If this stuff only lasts a few months, after all of the bragging they do about going through a car wash hundreds of times, I will be just slightly pissed. It also has VERY strong ammonia + mothball scent, I suggest doing it in the garage. They claim it needs to be done in a cool dry area, which makes it almost impossible for most people with the smell being so bad. Sucks I didn't end up with the house I wanted several years back, had a separate large air conditioned workshop/garage. :/

Taking the dash out wasn't fun at all, with all of the extra wiring I've added having to be disconnected. I may install quick disconnects on all of them in case.
2slofouru is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 07:48 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2017 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.