Welcome to the North American Subaru Impreza Owners Club Monday December 9, 2019
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 11-15-2019, 11:24 PM   #1
mEmENT0m0RI
Scooby Newbie
 
Member#: 365299
Join Date: Aug 2013
Default 2019 STI Smell from the vents

Non-exhaust like smell coming from the vents. Comes and goes, most often happens after starting the car up.
Took to the dealer several times. Last time made the dealer perform pressure test on the cooling system.
What else could it be?

Thanks!
* Registered users of the site do not see these ads.
mEmENT0m0RI is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 11-16-2019, 07:55 AM   #2
Mulder
Trust no one
Moderator
 
Member#: 11170
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: NYC
Vehicle:
02 RAV4 MT
15 WRX/05 GTO

Default

Non-exhaust doesn't tell us much. What does it smell like? Old socks, strawberries? More info would help here.
A 2019 is probably too new for mold/mildew buildup in the evaporator but anything's possible. Pull the cabin filter and see if there's anything there.
Mulder is offline   Reply With Quote
Old 11-16-2019, 11:28 AM   #3
CoronaWRX
Scooby Newbie
 
Member#: 431618
Join Date: Oct 2015
Chapter/Region: SWIC
Location: Tucson, AZ
Vehicle:
2019 STI
CWP

Default

Are you using your AC when getting these smells?
CoronaWRX is offline   Reply With Quote
Old 11-16-2019, 06:05 PM   #4
Big-E
NASIOC Supporter
 
Member#: 123843
Join Date: Aug 2006
Chapter/Region: NESIC
Location: Connecticut
Vehicle:
2016 STI LTD CWP
Let LED's light your way!

Default

The ventilation system is designed to automatically cycle the a/c compressor, even though the controls and/or notification (mode setting display) do not say/state that the a/c is on and/or in use.

Therefore, depending on the outside and inside atmospheric conditions, when the a/c cycles, you will get an odor, whether or not it definitely smells like mold or mildew.
Big-E is offline   Reply With Quote
Old 11-18-2019, 07:02 PM   #5
mEmENT0m0RI
Scooby Newbie
 
Member#: 365299
Join Date: Aug 2013
Default

Quote:
Originally Posted by Mulder View Post
Non-exhaust doesn't tell us much. What does it smell like? Old socks, strawberries? More info would help here.
A 2019 is probably too new for mold/mildew buildup in the evaporator but anything's possible. Pull the cabin filter and see if there's anything there.
Definitely more like strawberries than old socks . I replaced cabin filter (nothing weird on it) - did not help. Hard to describe smells with words, If I were to guess, it smells like car-wash detergent.
I normally wash the car myself, only took it through the car wash once about a year ago. Is it possible for that stuff to accumulate somewhere for such a long time?

Last edited by mEmENT0m0RI; 11-18-2019 at 07:11 PM.
mEmENT0m0RI is offline   Reply With Quote
Old 11-18-2019, 07:04 PM   #6
mEmENT0m0RI
Scooby Newbie
 
Member#: 365299
Join Date: Aug 2013
Default

It did smell a bit in the summer too with A/C on, not nearly as much though as when the heat is on.

Last edited by mEmENT0m0RI; 11-18-2019 at 07:12 PM.
mEmENT0m0RI is offline   Reply With Quote
Old 11-18-2019, 07:07 PM   #7
mEmENT0m0RI
Scooby Newbie
 
Member#: 365299
Join Date: Aug 2013
Default

One other thing, I had custom audio put in. Anything that those ppl could've messed up with wiring that would impact the ventilation subsystem in this way?
mEmENT0m0RI is offline   Reply With Quote
Old 11-19-2019, 03:01 PM   #8
Shinji N
Scooby Specialist
 
Member#: 3987
Join Date: Feb 2001
Location: Los Angeles, CA
Vehicle:
1998 2.5RS
Blue

Default

Does it matter if you have the system on external air or recirculating?
Have you tested every single different combination of settings to see if they have smell or don’t have smell?

Be methodical. Understand what you’re testing.
Shinji N is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 07:54 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.