Welcome to the North American Subaru Impreza Owners Club Saturday November 16, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Mid Atlantic Impreza Club
Mid Atlantic Impreza Club Forum sponsored by Annapolis Subaru
Go Back   NASIOC > NASIOC Chapters > Mid Atlantic Impreza Club -- MAIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 01-10-2014, 04:00 PM   #1726
Smurftastic
Scooby Guru
 
Member#: 243697
Join Date: Apr 2010
Chapter/Region: MAIC
Location: Virginia
Vehicle:
17.4 PSI ECUtuned 02
BLOD Cofounder|TopScoob31

Default

Continue preparations for the engine bay overhaul, ordered some custom fabricated stuff, preparing to go under the knife
* Registered users of the site do not see these ads.
Smurftastic is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 01-10-2014, 04:15 PM   #1727
Iggy1361
Scooby Newbie
 
Member#: 377264
Join Date: Dec 2013
Chapter/Region: MAIC
Location: Delaware
Vehicle:
2013 Crosstrek
Desert Khaki

Default

Changed the oil in the corsstrek... also ordered a fumoto oil drain... which i should have done first lol.
Iggy1361 is offline   Reply With Quote
Old 01-10-2014, 07:14 PM   #1728
EvileyeZ88
Scooby Specialist
 
Member#: 233501
Join Date: Dec 2009
Chapter/Region: MAIC
Location: Fairfax Va
Vehicle:
07AD 337/335SAXWAGON
99 outback sport

Default

Just bought a power steering pump for my 07 wrx, 87xxx and it finally decided to let go with all this bitter cold.

Now time to.go pick it up and install it.
EvileyeZ88 is offline   Reply With Quote
Old 01-10-2014, 07:35 PM   #1729
infinite012
Scooby Specialist
 
Member#: 74392
Join Date: Nov 2004
Chapter/Region: MAIC
Location: Virginia
Vehicle:
15 Foz
SWP

Default

State inspection complete.
infinite012 is offline   Reply With Quote
Old 01-11-2014, 07:10 PM   #1730
wilk489
Scooby Newbie
 
Member#: 368293
Join Date: Sep 2013
Chapter/Region: MAIC
Location: Mineral, VA
Vehicle:
2016 Focus RS
Black

Default

Swapped out my 2006 radio with one from a 2007 sti that has an aux port so I can finally listen to Spotify.
wilk489 is offline   Reply With Quote
Old 01-12-2014, 09:36 PM   #1731
WorldRallyRedneck
Scooby Specialist
 
Member#: 6506
Join Date: May 2001
Chapter/Region: MAIC
Location: Wardensville, WV
Vehicle:
2005 WRX Wagon
Aspen White

Default

installed all new door speakers front and rear, then found out my passenger side rear window wont open.
WorldRallyRedneck is offline   Reply With Quote
Old 01-13-2014, 10:52 AM   #1732
bluemax189
Scooby Specialist
 
Member#: 137405
Join Date: Jan 2007
Chapter/Region: MAIC
Location: Baltimore
Vehicle:
2011 WRX 6spd
GTX3076r

Default

just finished installing my walbro pump.
bluemax189 is offline   Reply With Quote
Old 01-13-2014, 11:25 AM   #1733
Neysa
Scooby Newbie
 
Member#: 268694
Join Date: Dec 2010
Chapter/Region: AKIC
Location: Eagle River, AK
Vehicle:
2008 WRX
OBP

Default

Quote:
Originally Posted by wilk489 View Post
Swapped out my 2006 radio with one from a 2007 sti that has an aux port so I can finally listen to Spotify.
Ooo, good idea
Neysa is offline   Reply With Quote
Old 01-13-2014, 01:48 PM   #1734
Borjaq
Scooby Specialist
 
Member#: 4812
Join Date: Mar 2001
Chapter/Region: MAIC
Location: S.Korea
Vehicle:
04 STi
JBP

Default

I stood in front of my car and listened to the bad bearring in my a/c tentioner pully for about 3 minutes at lunch while smoking a cigg.

Was deciding if I should go order a new one now or just pull off the belt and worry about it when I want a/c again.

:shrug:
Borjaq is offline   Reply With Quote
Old 01-13-2014, 02:02 PM   #1735
ThatGy
Scooby Newbie
 
Member#: 137791
Join Date: Jan 2007
Chapter/Region: RMIC
Location: Holly Ridge, NC
Vehicle:
2002 Impreza WRX
WR Blue

Default

Quote:
Originally Posted by Borjaq View Post
I stood in front of my car and listened to the bad bearring in my a/c tentioner pully for about 3 minutes at lunch while smoking a cigg.

Was deciding if I should go order a new one now or just pull off the belt and worry about it when I want a/c again.

:shrug:
You may want to fix it since the defroster uses A/C and will not work very well without it.
ThatGy is offline   Reply With Quote
Old 01-13-2014, 02:19 PM   #1736
RavensFan7
Scooby Specialist
 
Member#: 346388
Join Date: Feb 2013
Chapter/Region: MAIC
Location: PA
Vehicle:
2001 Ej205 Impreza L
SRP

Default

Quote:
Originally Posted by ThatGy View Post

You may want to fix it since the defroster uses A/C and will not work very well without it.
I don't believe that whole thing....when I had a/c I never used it for defrosters....and now that I have no a/c system the defrosters still work 100%.

Quote:
Originally Posted by Borjaq View Post
I stood in front of my car and listened to the bad bearring in my a/c tentioner pully

:shrug:
Same thing happened to mine a while ago....after a few minutes of listening to it like you, I ran inside and grabbed a pair of scissors to cut the belt.
Then I later deleted the whole system for teh weight savingz.

Last edited by RavensFan7; 01-13-2014 at 02:24 PM.
RavensFan7 is offline   Reply With Quote
Old 01-13-2014, 02:24 PM   #1737
ThatGy
Scooby Newbie
 
Member#: 137791
Join Date: Jan 2007
Chapter/Region: RMIC
Location: Holly Ridge, NC
Vehicle:
2002 Impreza WRX
WR Blue

Default

Quote:
Originally Posted by RavensFan7 View Post
I don't believe that whole thing....when I had a/c I never used it for defrosters....and now that I have no a/c system the defrosters still work 100%.
Well, when you turn on the defroster for the windshield, it turns on the A/C automatically. The A/C system removes moisture from the air which helps to prevent the inside of the windows from fogging up. Sure, it will still work without it (espically to defrost ice on the outside of the windows), but it works better with the A/C.
ThatGy is offline   Reply With Quote
Old 01-13-2014, 04:10 PM   #1738
RavensFan7
Scooby Specialist
 
Member#: 346388
Join Date: Feb 2013
Chapter/Region: MAIC
Location: PA
Vehicle:
2001 Ej205 Impreza L
SRP

Default

..and you're probably right. I just don't agree when people say it like this:

Quote:
Originally Posted by ThatGy View Post
The defroster uses A/C and WILL NOT work very well without it.
Not trying to jump down your back about it, I've actually read that tons of times and I think it's just how people word it....
I'd be OK with:
"It MAY NOT work as well"


Only reason I said anything, is so that person with the bad a/c pulley doesn't go out of their way trying to fix it just for the defrosters.
RavensFan7 is offline   Reply With Quote
Old 01-14-2014, 09:46 AM   #1739
Borjaq
Scooby Specialist
 
Member#: 4812
Join Date: Mar 2001
Chapter/Region: MAIC
Location: S.Korea
Vehicle:
04 STi
JBP

Default

Yeah, went and got a new pulley/bearring piece, just waiting to put it on.

Defrost, hah!
Borjaq is offline   Reply With Quote
Old 01-14-2014, 09:58 AM   #1740
colin edge
Scooby Newbie
 
Member#: 97648
Join Date: Oct 2005
Chapter/Region: MAIC
Location: Richmond, VA
Default

So tired. Front and rear upgraded pads and rotors. Front kyb struts. Short shifter and bushings. Trans mount. Pitch mount. Turbo back. Re flash.

Oh and assembled the heads for my 351 cleveland.

Someone pass the Advil and alcohol.
colin edge is offline   Reply With Quote
Old 01-14-2014, 10:05 AM   #1741
slayer44wagon
Scooby Specialist
 
Member#: 300834
Join Date: Nov 2011
Chapter/Region: MAIC
Vehicle:
03 wrx wagon
silver

Default

Logged my first data
slayer44wagon is offline   Reply With Quote
Old 01-15-2014, 05:14 PM   #1742
NowDatsG
Scooby Newbie
 
Member#: 364933
Join Date: Aug 2013
Location: Owings mills, Md
Vehicle:
08 Wrx sedan
Silver

Default

First time installing overlays/vinyl, I think I did an ok job.

NowDatsG is offline   Reply With Quote
Old 01-15-2014, 09:32 PM   #1743
yuephoria
Scooby Specialist
 
Member#: 64624
Join Date: Jun 2004
Chapter/Region: MAIC
Location: Kensington, MD
Vehicle:
2008 FS XT
WR Blue Pearl

Default

I bought a Zero/Sports oil cap on clearance from FastWRX.com.

Yesterday, I had Andrewtech Automotive open up a lightly used R160 case with rear Carbonetics Carbon 1.5 way LSD that I bought off the Forester forum for inspection and service. Everything checked out and I can't wait to have this installed next week!
yuephoria is offline   Reply With Quote
Old 01-15-2014, 09:45 PM   #1744
DavC825
Scooby Specialist
 
Member#: 201736
Join Date: Feb 2009
Chapter/Region: MAIC
Location: On the Corner
Vehicle:
12 IS-F Sold!! :(
Slowest 07 STi

Default

Quote:
Originally Posted by yuephoria View Post
I bought a Zero/Sports oil cap on clearance from FastWRX.com. Yesterday, I had Andrewtech Automotive open up a lightly used R160 case with rear Carbonetics Carbon 1.5 way LSD that I bought off the Forester forum for inspection and service. Everything checked out and I can't wait to have this installed next week!
Race car?
DavC825 is offline   Reply With Quote
Old 01-15-2014, 10:29 PM   #1745
yuephoria
Scooby Specialist
 
Member#: 64624
Join Date: Jun 2004
Chapter/Region: MAIC
Location: Kensington, MD
Vehicle:
2008 FS XT
WR Blue Pearl

Default

Quote:
Originally Posted by DavC825 View Post
Race car?
Apparently. :-)

Actually, I just found a good deal on the rear LSD and R160 case as a complete unit. It has less mileage on it than my stock LSD. I'm just trying to extend the useable life of my Forester.

Last edited by yuephoria; 01-15-2014 at 10:34 PM.
yuephoria is offline   Reply With Quote
Old 01-15-2014, 10:39 PM   #1746
AcquaCow
Scooby Guru
 
Member#: 36838
Join Date: May 2003
Chapter/Region: MAIC
Location: Reston VA
Vehicle:
2001 B50 RSTi Sedan
2011 DGM WRX hatch

Default

Bought a used roof rack for it. Yakima Whispbar.

Might be using it as early as Sat for a ski day-trip
AcquaCow is offline   Reply With Quote
Old 01-16-2014, 12:28 AM   #1747
ThatGy
Scooby Newbie
 
Member#: 137791
Join Date: Jan 2007
Chapter/Region: RMIC
Location: Holly Ridge, NC
Vehicle:
2002 Impreza WRX
WR Blue

Default

I removed the clock and started running wires for my new gage pod.

ThatGy is offline   Reply With Quote
Old 01-16-2014, 12:36 AM   #1748
HawkeyeKev26
Scooby Newbie
 
Member#: 377346
Join Date: Dec 2013
Chapter/Region: NWIC
Vehicle:
2006 Subaru Wrx Tr

Default

I didn't do much besides drive it! But I did order some parts for it!
HawkeyeKev26 is offline   Reply With Quote
Old 01-16-2014, 01:41 AM   #1749
Minorthreat7171
Scooby Specialist
 
Member#: 288712
Join Date: Jul 2011
Chapter/Region: MAIC
Location: Lancaster, PA
Vehicle:
2007 WRX IAP Stage2
WRB

Default

Installed ebay "brand" android head unit. Had to trim the bezel to get it to fit, about 3/8 off each side and 1-2 mm off the top and bottom.



sorry for the crappy cell pic
Minorthreat7171 is offline   Reply With Quote
Old 01-16-2014, 09:07 AM   #1750
Borjaq
Scooby Specialist
 
Member#: 4812
Join Date: Mar 2001
Chapter/Region: MAIC
Location: S.Korea
Vehicle:
04 STi
JBP

Default

Quote:
Originally Posted by Borjaq View Post
I stood in front of my car and listened to the bad bearring in my a/c tentioner pully for about 3 minutes at lunch while smoking a cigg.

Was deciding if I should go order a new one now or just pull off the belt and worry about it when I want a/c again.

:shrug:
Replaced it, much better. Spun the old one and it sounded like sand, lol.
Borjaq is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 06:00 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.