Welcome to the North American Subaru Impreza Owners Club Monday November 11, 2019
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 03-14-2019, 10:02 PM   #1
ZFracing
Scooby Newbie
 
Member#: 499080
Join Date: Mar 2019
Exclamation JDM swapped motor with USDM ECU

hello,

I don't know if this is the right thread to post on but I have an urgent question, so i have a 2002 bugeye with a jdm swap, i have the usdm ecu and the jdm ecu. i plugged in my usdm ecu yesterday hopping i would be able to pass smog today and even though i cleared the codes that it threw it wasnt reading the monitors as the smog shop....

Any help or information is much appreciated, i do have some time to get my car smogged but its coming up and wanted to get it done.

Thank you.
* Registered users of the site do not see these ads.
ZFracing is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 08-20-2019, 10:02 PM   #2
Ok2nvmywrx
Scooby Newbie
 
Member#: 505479
Join Date: Aug 2019
Default

I'd suggest getting it tuned that might help. or talk to a tuner to see your options.
Ok2nvmywrx is offline   Reply With Quote
Old 09-18-2019, 05:42 PM   #3
soobfan
Scooby Newbie
 
Member#: 155797
Join Date: Aug 2007
Chapter/Region: BAIC
Location: SF Bay Area
Vehicle:
2007 WRX Wagon
CGM

Default

I sort of ran into this issue. I bought a car and the previous owner didn't know this but apparently the engine is a full JDM including the manifolds and everything but it was paired with a USDM ECU. He had a pro-tune and in a state where the emissions not a big deal so he didn't need to worry.

When I bought it, I drove it back to CA and spent a month getting it back to stock. After doing the full exhaust, full intake I was left with P0457 EVAP Leak code. It just wouldn't go away.

It was only after a Subaru tuner told me the intakes is JDM and will never get the EVAP back unless you swap the various parts back to USDM (JDM intake manifolds don't have the vacuum ports needed to get EVAP back to factory). That would've been time consuming and expensive. I even got the AccessTuner for $150 in hopes of permanently deleting the CEL's but the monitors never got ready...

On the advice of the tuner, I got Tactrix cable and forced the monitors ready. That might be your best bet.
soobfan is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 08:35 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2019 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.