Welcome to the North American Subaru Impreza Owners Club Friday May 14, 2021
Home Forums Images WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Normally Aspirated with bolt-on Forced Induction Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.







* As an Amazon Associate I earn from qualifying purchases. 
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 12-27-2002, 03:40 AM   #1
Cusco
Scooby Newbie
 
Member#: 6220
Join Date: Apr 2001
Location: Gresham, OR
Vehicle:
99 ej25sett/TEC II
-:GaraGe ChimEra:-

Default TPS wire color?

WHich wire is the TPS wire on MY99 throttle bodies? I know when you are in front of the car and looking at the throttle body it is the plug harness on the left side of the throttle body. Which one of the 4 wires on the harness is the TPS??? thank you
* Registered users of the site do not see these ads.
Cusco is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-27-2002, 02:23 PM   #2
BOY
Scooby Specialist
 
Member#: 232
Join Date: Sep 1999
Chapter/Region: MWSOC
Location: Ft Wayne, IN
Vehicle:
99 RS-T RIP
02 Forster-S

Default

Not sure why you're tapping the TPS inside the engine bay but here's the wiring diagram from northursalia.com . You should be tapping the TPS signal at the ECU harness for engine management. The pinout lists the TPS signal as B136 pin #17, fully closed voltage is 0.2v-1.0v, fully opened is 4.2v-4.7v. Hope this helps.
BOY is offline   Reply With Quote
Old 12-27-2002, 06:42 PM   #3
Jaxx
Scooby Guru
 
Member#: 177
Join Date: Aug 1999
Chapter/Region: NWIC
Location: Austin, Texas, USA
Vehicle:
The 93 W/EJ20K-sold
Subaru-less :(

Default

tec 2 will need it tapped in the engine bay
did you read shiv's instructions .. i thought he had the color listed .
Jaxx is offline   Reply With Quote
Old 12-27-2002, 07:36 PM   #4
Cusco
Scooby Newbie
 
Member#: 6220
Join Date: Apr 2001
Location: Gresham, OR
Vehicle:
99 ej25sett/TEC II
-:GaraGe ChimEra:-

Default Shiv's SCC article???

I read the article from SCC, but the thing is for some reason my MY99 does not have a solid yellow wire last time I checked and yes I am tapping for TEC II.
Cusco is offline   Reply With Quote
Old 12-28-2002, 10:52 AM   #5
SteveS
Scooby Specialist
 
Member#: 6
Join Date: Jun 1999
Location: South Jersey
Vehicle:
2007 BMW Z4 M Coupe
Interlagos Blue

Default

I remember that it is a yellow wire with another color, like green, black, or blue. Or maybe it's white. I don't recall there being any other yellow wires off of the TPS, so it should be fairly obvious. Also, I think in the installation instructions it tells you which wire it is based upon its location in the connector, doesn't it?

Steve
SteveS is offline   Reply With Quote
Old 12-28-2002, 11:54 AM   #6
Jaxx
Scooby Guru
 
Member#: 177
Join Date: Aug 1999
Chapter/Region: NWIC
Location: Austin, Texas, USA
Vehicle:
The 93 W/EJ20K-sold
Subaru-less :(

Default

not scc .. here
http://www.vishnutuning.com/downloads.htm

___
I I
I X I
I X I-]
I X I-] <--- TPS Signal (splice this wire)
I X I
I__I

Last edited by Jaxx; 12-28-2002 at 12:00 PM.
Jaxx is offline   Reply With Quote
Old 12-29-2002, 01:20 AM   #7
Cusco
Scooby Newbie
 
Member#: 6220
Join Date: Apr 2001
Location: Gresham, OR
Vehicle:
99 ej25sett/TEC II
-:GaraGe ChimEra:-

Default tried that one...

THank you for posting so that I may know its the third wire down. the only yellow wire is the one with the black stripe down it which is the second one down and that one has a constant draw of .51 with IGN ON I think. I just routed a wire to the ECU in haste. hjehhehe but now I know its the thrid one down.. thank you.
Cusco is offline   Reply With Quote
Old 04-14-2021, 02:27 PM   #8
Edmondson36
Scooby Newbie
 
Member#: 519746
Join Date: Oct 2020
Default TPS wiring

I have an 06 Impreza 2.5i and my pigtail to my tps broke and all the wires were pulled out. I have no reference as to which wire goes into my new pigtail. I have looked at service manuals and wiring diagrams as to match my wires. No wires match in color. Can anyone point me in the right direction?
Edmondson36 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 WRX TPS Wire Color Wind25RS Electrical & Lighting 2 01-12-2009 04:56 PM
2007 WRX TPS Wire Color Wind25RS Subaru Conversions 5 07-11-2008 12:37 AM
TPS wire on throttle body? What color? riggs Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 4 01-12-2006 12:53 AM
TPS wiring help needed ASAP! :-) Rovah Normally Aspirated Powertrain 5 11-30-2002 02:04 PM
TPS wiring help needed ASAP! :-) Rovah New England Impreza Club Forum -- NESIC 3 11-30-2002 10:27 AM

All times are GMT -4. The time now is 04:28 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2021 Axivo Inc.
Copyright ©1999 - 2019, North American Subaru Impreza Owners Club, Inc.

As an Amazon Associate I earn from qualifying purchases.