Welcome to the North American Subaru Impreza Owners Club Thursday November 15, 2018
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 12-06-2017, 03:02 PM   #126
PizzaBoyX
Scooby Newbie
 
Member#: 474796
Join Date: Sep 2017
Chapter/Region: Tri-State
Location: NJ
Vehicle:
2016 WRX
WRB

Default

Quote:
Originally Posted by Jesone View Post
So you recently was having my car tuned and while on the dyno a seal blew or a head. Black smoke came out of the exhaust (passenger side). So all mods were put back to stock and my question is will they be able to see that it was modded before from the ecu?? It has been flashed back to normal with AP V3 but did die trying to get it home. Which it was towed to my house. I知 trying to get info as to what to be aware of. I知 under 60k so the power train is covered but I知 sketchy on the ecu part... please advise!!!
first; this is in the wrong section.

second; yes they can tell as I believe the ignition count resets to 0 when you flash the ECU. It's also the first thing they will check being that it's an engine failure.

third; even if they somehow miss that it was flashed, any competent tech can tell when bolts are removed/replaced for the most common mods. they'll see the nicks from the socket, or if you put new ones on, they'll see that they're too new for the age of the car.

bring it in, and see what happens; don't offer anymore information than they ask you.
* Registered users of the site do not see these ads.
PizzaBoyX is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-07-2017, 09:23 AM   #127
RobM
Scooby Newbie
 
Member#: 177056
Join Date: Apr 2008
Location: Alberta, Canada
Vehicle:
2015 WRX - CVT
2009 Forester XT

Default

Or you can pretend to be responsible, and own up to what you did.
RobM is offline   Reply With Quote
Old 12-09-2017, 12:48 PM   #128
Knotsure
Scooby Specialist
 
Member#: 41730
Join Date: Aug 2003
Location: Jersey
Vehicle:
1415 Legacy/Forester
D.Grey/White

Default

Quote:
Originally Posted by Jesone View Post
So you recently was having my car tuned and while on the dyno a seal blew or a head. Black smoke came out of the exhaust (passenger side). So all mods were put back to stock and my question is will they be able to see that it was modded before from the ecu?? It has been flashed back to normal with AP V3 but did die trying to get it home. Which it was towed to my house. I知 trying to get info as to what to be aware of. I知 under 60k so the power train is covered but I知 sketchy on the ecu part... please advise!!!


Not 都ketchy on the ECU part. Just SKETCHY
Knotsure is offline   Reply With Quote
Old 12-29-2017, 01:00 AM   #129
Alexisti
Scooby Newbie
 
Member#: 469528
Join Date: Jun 2017
Default

I have this problem with my sti 2011, the light you see in the picture is show up for couple minute or I can turn off the car and turn back on and the light stay off so I dont why they turn on randomly or what can cause the problem
Alexisti is offline   Reply With Quote
Old 01-01-2018, 10:13 AM   #130
Charlie-III
NASIOC Supporter
 
Member#: 30669
Join Date: Dec 2002
Chapter/Region: Tri-State
Location: USA, North NJ, 07456
Vehicle:
1998 Legacy 2.5GT
Silver Sleeper BK, 5MT

Default

Quote:
Originally Posted by Alexisti View Post
I have this problem with my sti 2011, the light you see in the picture is show up for couple minute or I can turn off the car and turn back on and the light stay off so I dont why they turn on randomly or what can cause the problem?
Wrong thread, should be in electrical since you don't appear to have a warranty denial.
Charlie-III is offline   Reply With Quote
Old 01-02-2018, 12:05 AM   #131
Alexisti
Scooby Newbie
 
Member#: 469528
Join Date: Jun 2017
Default

Quote:
Originally Posted by Charlie-III View Post
Wrong thread, should be in electrical since you don't appear to have a warranty denial.
Thanks
Alexisti is offline   Reply With Quote
Old 09-04-2018, 10:23 PM   #132
Optimus_Cr1m35
Scooby Newbie
 
Member#: 488180
Join Date: Jul 2018
Location: Phoenix, AZ
Vehicle:
2017 WRX
WR Blue

Default

Name: Josh

Make: 2017 Subaru WRX

Mileage:18000

Time Out Of Use:5 days

Problem And Likely Cause:AC compressor failure, no cause given

Modifications:All cosmetic at this point, Nameless Axle Back.

Submitted For Warranty Work (Yes/No):Yes

Reason Given For Denial:None

Your Story: Bought the car in July. About 2 weeks ago, the AC stopped getting cold. Cooled intermittently. Scheduled service, dropped it off Friday. I asked for a loaner if the repairs were going to take a while. Service manager walked out, started it, ran the AC, said "You're getting a loaner".

Since it was the Friday before a holiday, they couldn't order anything until today. I'm expecting the car back on Thursday/Friday.

They gave me no issue at all with the warranty. Said "Don't worry about it, it's all covered. Now try to sell your wife this new Outback when you get home..."

The last Dealer I spoke to wasn't so decent. Seemed pretty shady. Talked about co-pays, tried to get me to trade in a car I just bought, etc. And I was just picking up clips I ordered from SOA.
Optimus_Cr1m35 is offline   Reply With Quote
Old 09-19-2018, 06:48 AM   #133
FlySense88
Scooby Newbie
 
Member#: 327665
Join Date: Jul 2012
Default

Name: Ty

Make: 2019 Subaru STI limited

Mileage: 269

Time Out Of Use: 6 days and counting

Problem And Likely Cause: presumed to be a fried ECM, no cause given

Modifications: Tints

Submitted For Warranty Work (Yes/No):Yes

Reason Given For Denial: Appeared to be tampered with, ECM doesn't fry on it own

Your Story: I get in my car (after letting it sit for 6 days), and attempt to go to work. I noticed all the lights on the dash are on, blinking, and something isn't right. I turn it off, thinking it needed to be reset, I unplug the battery, and the car hasn't cut back on since. I get it towed to the dealer. They said its a hole in the firewall grommet, and 3 copper strands in the fuse box under the hood. The dealer say it appears as the car's electrical systems have been tampered with, there for it will not be covered. I am blown.
FlySense88 is offline   Reply With Quote
Old 09-20-2018, 06:23 PM   #134
vlad11591
Scooby Newbie
 
Member#: 295970
Join Date: Sep 2011
Chapter/Region: Tri-State
Location: Hamilton, NJ
Vehicle:
2018 WRX
ISM

Default

That's ridiculous.

I would go to another dealership or try SOA.
vlad11591 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Trouble/Warranty Denial Report Thread: Interior North Ursalia Warranty Issues & SOA Problems 71 Yesterday 09:18 AM
Trouble/Warranty Denial Report Thread: Drivetrain (Engine, Tranny, Diff, Etc.) North Ursalia Warranty Issues & SOA Problems 3140 11-12-2018 09:35 PM
Trouble/Warranty Denial Report Thread: Body/Exterior of Vehicle North Ursalia Warranty Issues & SOA Problems 145 11-06-2018 05:49 AM
Trouble/Warranty Denial Report Thread: Suspension North Ursalia Warranty Issues & SOA Problems 56 03-22-2018 12:09 AM
Trouble/Warranty Denial Report Thread: Braking System North Ursalia Warranty Issues & SOA Problems 94 11-23-2016 06:27 PM

All times are GMT -4. The time now is 04:56 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2018 Axivo Inc.
Copyright ©1999 - 2017, North American Subaru Impreza Owners Club, Inc.